Loading ...
Sorry, an error occurred while loading the content.

Re: [svg-developers] Problem in Batik

Expand Messages
  • Cameron McCormack
    Hi Rahaman. ... There was a bug at the time of the release where only text/ecmascript was accepted. Nightly builds will work with application/ecmascript. Note
    Message 1 of 2 , Nov 28, 2007
    • 0 Attachment
      Hi Rahaman.

      Md.Mustafizur Rahaman:
      > I am using batik-1.7beta1 & when i am trying to open a svg file, it
      > gives the following error
      >
      > Scripts of type (application/ecmascript) cannot be loaded and executed
      > with the current security settings.
      >
      > I have unchecked the check box in Edit->Preferences->Secutiry but
      > still the problem persists. Can any one please help me?

      There was a bug at the time of the release where only text/ecmascript
      was accepted. Nightly builds will work with application/ecmascript.

      Note also though that the example you are loading is an SVG Tiny 1.2
      document, and Batik only supports SVG Full 1.1 plus a couple of SVG 1.2
      features. Notably, it does not support traits (the getFloatTrait() and
      setFloatTrait() calls in that document).

      --
      Cameron McCormack, http://mcc.id.au/
      xmpp:heycam@... ▪ ICQ 26955922 ▪ MSN cam@...
    Your message has been successfully submitted and would be delivered to recipients shortly.