Loading ...
Sorry, an error occurred while loading the content.

Re: Geofoto.ch - Geophotomap

Expand Messages
  • Andreas Neumann
    Hi, the speed is fine in Opera9, Batik and ASV3/ASV6 (IE). In Firefox it depends. Are you testing on MacOSX or Linux? If yes, my experience is, that FFSVG is
    Message 1 of 11 , Oct 31, 2006
    View Source
    • 0 Attachment
      Hi,

      the speed is fine in Opera9, Batik and ASV3/ASV6 (IE).

      In Firefox it depends. Are you testing on MacOSX or Linux? If yes, my
      experience is, that FFSVG is very slow on Mac and on Linux (depending
      on the XServer settings). Firefox on Windows should run on reasonable
      speed.

      Thanks for more feedback on this. Maybe we should discuss it with the
      FF SVG developers, if it is really "excruciatingly slow".

      Andreas

      --- In svg-developers@yahoogroups.com, Reid Priedhorsky <reid@...>
      wrote:
      >
      > Andreas Neumann wrote:
      > > Hi group,
      > >
      > > at http://www.geofoto.ch/geophotomap/ you may find a photo browser
      > > for geographically referenced photos.
      > >
      > > The application works in ASV3/ASV6/Batik/FF2.0 and FF3.0 and
      Opera 9.
      > > For some reasons I still get crashes in Opera9. Will work on that
      and
      > > hopefully find a solution.
      >
      > Hi Andreas,
      >
      > It works for me also under FF1.5, but it's excruciatingly slow. Is
      the
      > speed better under other browsers?
      >
      > Reid
      >
    • Armin Mueller
      ... photos. ... Hi Andreas, i have tested the application with IE6 and ASV3. It works if i started the first time. When i try to refresh the screen, then the
      Message 2 of 11 , Nov 1, 2006
      View Source
      • 0 Attachment
        Andreas Neumann wrote:
        > Hi group,
        >
        > at http://www.geofoto.ch/geophotomap/
        > <http://www.geofoto.ch/geophotomap/> you may find a photo browser for geographically referenced
        photos.
        >
        > The application works in ASV3/ASV6/Batik/FF2.0 and FF3.0 and Opera 9.
        > For some reasons I still get crashes in Opera9. Will work on that and
        > hopefully find a solution.

        Hi Andreas,

        i have tested the application with IE6 and ASV3. It works if i started the first time. When i try to
        refresh the screen, then the app runs in a javascrpt error "document.getElementById is null... line
        348

        Armin
      • Armin Mueller
        Hi group, i have just installed IE7 final with ASV 3.03 on my pc. Now i have the problem that SVG files which are embedded in a html file works well. But SVG
        Message 3 of 11 , Nov 1, 2006
        View Source
        • 0 Attachment
          Hi group,

          i have just installed IE7 final with ASV 3.03 on my pc.
          Now i have the problem that SVG files which are embedded in a html file works well. But SVG files
          itself are not displayed. There are always an error that there is an error.
          I have tested it with several URLS http://tirolatlas.uibk.ac.at/,
          http://www.mapviewsvg.com/examples/bw_baulandpreise/index.svg,
          http://jwatt.org/svg/tests/gradient-dynamic.svg etc
          Just wondering if someone else has the same problems?

          Armin
        • Andreas Neumann
          Hi Armin, thanks for reporting. I am aware of this behavior, but there is not a lot I can do. Seems like a bug in IE/ASV, since the reload works fine in all
          Message 4 of 11 , Nov 1, 2006
          View Source
          • 0 Attachment
            Hi Armin,

            thanks for reporting. I am aware of this behavior, but there is not a
            lot I can do. Seems like a bug in IE/ASV, since the reload works fine
            in all other browsers. With the current situation with ASV, perhaps
            bug reports don't make any sense, I guess. They wouldn't fix it
            anyway.

            If you open the application in another browser window again (or
            another tab in IE7) it should work.

            Did you experience this problem with other (maybe your own) SVG
            applications as well or is my application the first one where this
            problem appears?

            Thanks for additional info,
            Andreas

            --- In svg-developers@yahoogroups.com, "Armin
            Mueller" <A.Mueller@...> wrote:
            >
            > Andreas Neumann wrote:
            > > Hi group,
            > >
            > > at http://www.geofoto.ch/geophotomap/
            > > <http://www.geofoto.ch/geophotomap/> you may find a photo
            browser for geographically referenced
            > photos.
            > >
            > > The application works in ASV3/ASV6/Batik/FF2.0 and FF3.0 and
            Opera 9.
            > > For some reasons I still get crashes in Opera9. Will work on that
            and
            > > hopefully find a solution.
            >
            > Hi Andreas,
            >
            > i have tested the application with IE6 and ASV3. It works if i
            started the first time. When i try to
            > refresh the screen, then the app runs in a javascrpt error
            "document.getElementById is null... line
            > 348
            >
            > Armin
            >
          • Armin Mueller
            Andreas, we do not have this problem yet. Could it be that this is a problem with ActiveX-activation in IE? Armin ... Von: svg-developers@yahoogroups.com
            Message 5 of 11 , Nov 1, 2006
            View Source
            • 0 Attachment
              Andreas,

              we do not have this problem yet. Could it be that this is a problem with ActiveX-activation in IE?

              Armin


              -----Urspr√ľngliche Nachricht-----
              Von: svg-developers@yahoogroups.com [mailto:svg-developers@yahoogroups.com] Im Auftrag von Andreas
              Neumann
              Gesendet: Mittwoch, 1. November 2006 10:07
              An: svg-developers@yahoogroups.com
              Betreff: [svg-developers] Re: Geofoto.ch - Geophotomap

              Hi Armin,

              thanks for reporting. I am aware of this behavior, but there is not a lot I can do. Seems like a bug
              in IE/ASV, since the reload works fine in all other browsers. With the current situation with ASV,
              perhaps bug reports don't make any sense, I guess. They wouldn't fix it anyway.

              If you open the application in another browser window again (or another tab in IE7) it should work.

              Did you experience this problem with other (maybe your own) SVG applications as well or is my
              application the first one where this problem appears?

              Thanks for additional info,
              Andreas

              --- In svg-developers@yahoogroups.com <mailto:svg-developers%40yahoogroups.com> , "Armin Mueller"
              <A.Mueller@...> wrote:
              >
              > Andreas Neumann wrote:
              > > Hi group,
              > >
              > > at http://www.geofoto.ch/geophotomap/
              > > <http://www.geofoto.ch/geophotomap/>
              > > <http://www.geofoto.ch/geophotomap/
              > > <http://www.geofoto.ch/geophotomap/> > you may find a photo
              browser for geographically referenced
              > photos.
              > >
              > > The application works in ASV3/ASV6/Batik/FF2.0 and FF3.0 and
              Opera 9.
              > > For some reasons I still get crashes in Opera9. Will work on that
              and
              > > hopefully find a solution.
              >
              > Hi Andreas,
              >
              > i have tested the application with IE6 and ASV3. It works if i
              started the first time. When i try to
              > refresh the screen, then the app runs in a javascrpt error
              "document.getElementById is null... line
              > 348
              >
              > Armin
              >
            • pilatfr
              I get same problem with english final IE7, I can see svg files but not svg urls local or not ... It seems that IE7 try to put svg in html using embed tag ...
              Message 6 of 11 , Nov 2, 2006
              View Source
              • 0 Attachment
                I get same problem with english final IE7, I can see svg files but not
                svg urls local or not ...
                It seems that IE7 try to put svg in html using embed tag ... without
                success
                This don't depend of Adobe plugin version ( 3.xx , 6 beta )

                Same problem for flash and pdf urls !

                As users cannot see pdfs online in IE7, we can hope that problem will
                be solved

                Michel


                --- In svg-developers@yahoogroups.com, "Armin Mueller" <A.Mueller@...>
                wrote:
                >
                > Hi group,
                >
                > i have just installed IE7 final with ASV 3.03 on my pc.
                > Now i have the problem that SVG files which are embedded in a html
                file works well. But SVG files
                > itself are not displayed. There are always an error that there is an
                error.
                > I have tested it with several URLS http://tirolatlas.uibk.ac.at/,
                > http://www.mapviewsvg.com/examples/bw_baulandpreise/index.svg,
                > http://jwatt.org/svg/tests/gradient-dynamic.svg etc
                > Just wondering if someone else has the same problems?
                >
                > Armin
                >
              • Reid Priedhorsky
                ... I m testing on Firefox 1.5.0.7 on Linux. I am pretty sure that the X server has the RENDER extension; I m not sure what other settings to look for. On
                Message 7 of 11 , Nov 2, 2006
                View Source
                • 0 Attachment
                  Andreas Neumann wrote:
                  > Hi,
                  >
                  > the speed is fine in Opera9, Batik and ASV3/ASV6 (IE).
                  >
                  > In Firefox it depends. Are you testing on MacOSX or Linux? If yes, my
                  > experience is, that FFSVG is very slow on Mac and on Linux (depending
                  > on the XServer settings). Firefox on Windows should run on reasonable
                  > speed.

                  I'm testing on Firefox 1.5.0.7 on Linux. I am pretty sure that the X
                  server has the RENDER extension; I'm not sure what other settings to
                  look for.

                  On further reflection, I think that there are two problems with speed:

                  1. Fetching things from the database is (presumably) an HTTP
                  fetch/response cycle, which takes a few to several seconds, but there's
                  no indication in the UI that something is going on -- e.g., a watch
                  cursor would be helpful here. I think this may be why I added the
                  adjective "excrutiatingly" slow.

                  2. The widgets are sluggish. For example, there is a noticeable lag
                  between when I click on a checkbox and it becomes checked.

                  > Thanks for more feedback on this. Maybe we should discuss it with the
                  > FF SVG developers, if it is really "excruciatingly slow".

                  Perhaps. I'm having performance problems in my own application, to the
                  extent that we are wondering about switching to another technology.

                  Reid
                • Andreas Neumann
                  ... for geographically ... 9. For some ... hopefully find a solution. I am happy to report that the bug that caused Opera9 to crash is now fixed. Fixes are
                  Message 8 of 11 , Nov 4, 2006
                  View Source
                  • 0 Attachment
                    > at http://www.geofoto.ch/geophotomap/ you may find a photo browser
                    for geographically
                    > referenced photos.
                    >
                    > The application works in ASV3/ASV6/Batik/FF2.0 and FF3.0 and Opera
                    9. For some
                    > reasons I still get crashes in Opera9. Will work on that and
                    hopefully find a solution.

                    I am happy to report that the bug that caused Opera9 to crash is now
                    fixed. Fixes are available at http://my.opera.com/desktopteam/blog/
                    or soon in the upcoming 9.1 Opera release.

                    Andreas
                  Your message has been successfully submitted and would be delivered to recipients shortly.