Loading ...
Sorry, an error occurred while loading the content.

escape characters in text

Expand Messages
  • bstuycke
    Hi, < 90% produces a text < 90% in asv, where I expected
    Message 1 of 4 , May 30, 2006
    View Source
    • 0 Attachment
      Hi,

      <text>< 90%</text> produces a text "< 90%" in asv, where I
      expected "< 90%".

      How do I get a less-than symbol in a text node to display correctly ?
      Is this a bug of asv ?

      thanks
      Bart
    • Martin Honnen
      ... No problems here with Adobe SVG viewer 3 and Can you post a URL where the problem happens? With
      Message 2 of 4 , May 30, 2006
      View Source
      • 0 Attachment
        --- In svg-developers@yahoogroups.com, "bstuycke" <bart.stuyckens@...>
        wrote:

        > <text>< 90%</text> produces a text "< 90%" in asv, where I
        > expected "< 90%".
        >
        > How do I get a less-than symbol in a text node to display correctly ?
        > Is this a bug of asv ?


        No problems here with Adobe SVG viewer 3 and
        <http://home.arcor.de/martin.honnen/svg/test2006053001.svg>

        Can you post a URL where the problem happens? With static markup you
        have to escape '<' as '<'. If you use script to create a text node
        then the text data contains '<' as plain text.
      • Samuel Dagan
        Hi Bart, I use < 90% It should work in all cases. Cheers, Samy ... correctly ?
        Message 3 of 4 , May 30, 2006
        View Source
        • 0 Attachment
          Hi Bart,
          I use <text>< 90%</text>
          It should work in all cases. Cheers, Samy


          --- In svg-developers@yahoogroups.com, "bstuycke"
          <bart.stuyckens@...> wrote:
          >
          > Hi,
          >
          > <text>< 90%</text> produces a text "< 90%" in asv, where I
          > expected "< 90%".
          >
          > How do I get a less-than symbol in a text node to display
          correctly ?
          > Is this a bug of asv ?
          >
          > thanks
          > Bart
          >
        • bstuycke
          Double checking, I was wrong. In asv < 90% gives correctly
          Message 4 of 4 , May 31, 2006
          View Source
          • 0 Attachment
            Double checking, I was wrong.
            In asv "<text>< 90%</text>" gives correctly "< 90%".
            Somewhere burried deep in my code, I replaced all '&' with '&'
            in text nodes.
            :( ....

            Bart
            --- In svg-developers@yahoogroups.com, "Samuel Dagan" <dagan@...>
            wrote:
            >
            > Hi Bart,
            > I use <text>< 90%</text>
            > It should work in all cases. Cheers, Samy
            >
            >
            > --- In svg-developers@yahoogroups.com, "bstuycke"
            > <bart.stuyckens@> wrote:
            > >
            > > Hi,
            > >
            > > <text>< 90%</text> produces a text "< 90%" in asv, where
            I
            > > expected "< 90%".
            > >
            > > How do I get a less-than symbol in a text node to display
            > correctly ?
            > > Is this a bug of asv ?
            > >
            > > thanks
            > > Bart
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.