Loading ...
Sorry, an error occurred while loading the content.
 

Re: [svg-developers] Re: SVG 3.02 --> 3.03

Expand Messages
  • Sylvain Rouillard
    I ve had problems with ASP.NET when I tried to view an SVG served by one server on the server itself (to be clear, the ASP-SVG code is served by machine X,
    Message 1 of 8 , Jul 3, 2005
      I've had problems with ASP.NET when I tried to view an SVG served by one
      server on the server itself (to be clear, the ASP-SVG code is served by
      machine X, browsing the page on machine X doesn't work, whereas it works
      perfectly well from any other machine Y or Z). The way the browser renders
      the SVG in such a situation seems to depend on how you integrated your SVG in
      your HTML (IFRAME, object, embed). Maybe your problem could be related?

      Le Dimanche 3 Juillet 2005 22:48, Nicholas Lucaroni a écrit :
      > I don't want to seem like an a$$ for reposting this, but it is very
      > odd, and want to make sure that the necessary people see this.
      >
      > problem: Upgrading from adobe SVG viewer 3.02 -> 3.03 causes my SVG
      > page not to be displayed. It's an ASP page that renders database
      > information into dynamically drawn flow chart. The SVG is an embedded
      > object on a page with some simple directions on navigation.
      >
      > I've looked around the internet and have seen other places with the
      > same issue. There solution is "DONT UPGRADE TO 3.03!". It seems like
      > a co-out to me. What is the problem?
      >
      > While writing the page i used the 1.1 specs on the SVG reference
      > page, so my SVG should be correct. I think the issue is with ASP,
      > rendering the SVG returns a HTML document, not one with an SVG
      > extension. (when you right click on the document in 3.02 then
      > click "view SVG" it pops up a page of text(all the text objects on in
      > the SVG image), and the URL extension is .htm.
      >
      > So what do you all think? is that the possible reason? has anyone
      > experiemented with SVG and ASP, i've seen pages with SVG and ASP.NET
      > but they weren't old or anything, but probably used 3.02. Thanks for
      > your help, i hope someone can help me.
      >
      > -nick
      >
      >
      >
      >
      > --- In svg-developers@yahoogroups.com, "Nicholas Lucaroni"
      >
      > <U.mojan@v...> wrote:
      > > yeah thats not it. but thanks for the catch. I was playing around
      > > with the namespace thinking that was the issue, and didn't change
      >
      > it
      >
      > > back. anyone experience compatability issues from 3.02->3.03?
      > >
      > > --- In svg-developers@yahoogroups.com, Jon Ferraiolo
      > >
      > > <Jon.Ferraiolo@a...> wrote:
      > > > At 04:00 PM 6/29/2005, you wrote:
      > > > >I have an application that is rendered in SVG and works
      >
      > perfectly
      >
      > > on
      > >
      > > > >3.02. My clients installed and tried testing the application and
      > >
      > > the
      > >
      > > > >page doesn't work. I personally installed to 3.03 on my computer
      > >
      > > and
      > >
      > > > >the SVBG also doesn't work. Wondering if anyone might have an
      >
      > idea
      >
      > > what
      > >
      > > > >the problem might be.
      > > > >
      > > > >I'm declaring the SVG within: <svg
      > > > >xmlns="<http://www.w3.org/TR/SVG/>http://www.w3.org/TR/SVG/"
      > > > >xml:space="preserve" width="100%" height="100%">
      > > >
      > > > I am not sure this is your problem, but it should be
      > > > xmlns="http://www.w3.org/2000/svg".
      > > >
      > > > Jon
      > > >
      > > > >and it's an embedded object.
      > > > >
      > > > >
      > > > >
      > > > >
      > > > >-----
      > > > >To unsubscribe send a message to: svg-developers-
      > >
      > > unsubscribe@yahoogroups.com
      > >
      > > > >-or-
      > > > >visit
      > > > ><http://groups.yahoo.com/group/svg-
      > >
      > > developers>http://groups.yahoo.com/group/svg-developers
      > >
      > > > >and click "edit my membership"
      > > > >----
      > > > >
      > > > ><?---- LSpots keywords ?> <?---- HM ADS ?>
      > > > >
      > > > >----------
      > > > >YAHOO! GROUPS LINKS
      > > > >
      > > > > * Visit your group
      > > > > "<http://groups.yahoo.com/group/svg-developers>svg-developers"
      >
      > on
      >
      > > the web.
      > >
      > > > > *
      > > > > * To unsubscribe from this group, send an email to:
      > > > > *
      > > > > <mailto:svg-developers-unsubscribe@yahoogroups.com?
      > >
      > > subject=Unsubscribe>svg-developers-unsubscribe@yahoogroups.com
      > >
      > > > > *
      > > > > * Your use of Yahoo! Groups is subject to the
      > > > > <http://docs.yahoo.com/info/terms/>Yahoo! Terms of Service.
      > > > >
      > > > >
      > > > >----------
      > > >
      > > > [Non-text portions of this message have been removed]
      >
      > -----
      > To unsubscribe send a message to:
      > svg-developers-unsubscribe@yahoogroups.com -or-
      > visit http://groups.yahoo.com/group/svg-developers and click "edit my
      > membership" ----
      > Yahoo! Groups Links
      >
      >
      >





      ___________________________________________________________________________
      Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! Messenger
      Téléchargez cette version sur http://fr.messenger.yahoo.com
    • Holger Will
      ... Hi Nick there are a few thing you have to care about, so that dynamicly generated svgs work across browsers. 1.you have to set the right Mime Type :
      Message 2 of 8 , Jul 3, 2005
        Nicholas Lucaroni schrieb:

        > I don't want to seem like an a$$ for reposting this, but it is very
        > odd, and want to make sure that the necessary people see this.
        >
        > problem: Upgrading from adobe SVG viewer 3.02 -> 3.03 causes my SVG
        > page not to be displayed. It's an ASP page that renders database
        > information into dynamically drawn flow chart. The SVG is an embedded
        > object on a page with some simple directions on navigation.
        >
        > I've looked around the internet and have seen other places with the
        > same issue. There solution is "DONT UPGRADE TO 3.03!". It seems like
        > a co-out to me. What is the problem?
        >
        > While writing the page i used the 1.1 specs on the SVG reference
        > page, so my SVG should be correct. I think the issue is with ASP,
        > rendering the SVG returns a HTML document, not one with an SVG
        > extension. (when you right click on the document in 3.02 then
        > click "view SVG" it pops up a page of text(all the text objects on in
        > the SVG image), and the URL extension is .htm.
        >
        > So what do you all think? is that the possible reason? has anyone
        > experiemented with SVG and ASP, i've seen pages with SVG and ASP.NET
        > but they weren't old or anything, but probably used 3.02. Thanks for
        > your help, i hope someone can help me.
        >
        > -nick

        Hi Nick
        there are a few thing you have to care about, so that dynamicly
        generated svgs work across browsers.

        1.you have to set the right Mime Type :
        response.contentEncoding="image/svg+xml" (make sure that this mime is
        registered in your iis)
        2.use the correct namespace, e.g. make sure your svg document starts
        like this:
        <svg xmlns="http://www.w3.org/2000/svg">
        3. make sure your querystring ends with .svg
        http://yourdomain/yourasp.asp?ex=.svg

        if you dont do 3., IE will somtimes not render your SVG, so i gues this
        is what your looking for.

        hth
        Holger
      • Holger Will
        ... ups! make that response.contentType !!!!!!!!!!!!!!!!!!!!!!!!!!
        Message 3 of 8 , Jul 4, 2005
          Holger Will schrieb:

          > Nicholas Lucaroni schrieb:
          >
          > > I don't want to seem like an a$$ for reposting this, but it is very
          > > odd, and want to make sure that the necessary people see this.
          > >
          > > problem: Upgrading from adobe SVG viewer 3.02 -> 3.03 causes my SVG
          > > page not to be displayed. It's an ASP page that renders database
          > > information into dynamically drawn flow chart. The SVG is an embedded
          > > object on a page with some simple directions on navigation.
          > >
          > > I've looked around the internet and have seen other places with the
          > > same issue. There solution is "DONT UPGRADE TO 3.03!". It seems like
          > > a co-out to me. What is the problem?
          > >
          > > While writing the page i used the 1.1 specs on the SVG reference
          > > page, so my SVG should be correct. I think the issue is with ASP,
          > > rendering the SVG returns a HTML document, not one with an SVG
          > > extension. (when you right click on the document in 3.02 then
          > > click "view SVG" it pops up a page of text(all the text objects on in
          > > the SVG image), and the URL extension is .htm.
          > >
          > > So what do you all think? is that the possible reason? has anyone
          > > experiemented with SVG and ASP, i've seen pages with SVG and ASP.NET
          > > but they weren't old or anything, but probably used 3.02. Thanks for
          > > your help, i hope someone can help me.
          > >
          > > -nick
          >
          > Hi Nick
          > there are a few thing you have to care about, so that dynamicly
          > generated svgs work across browsers.
          >
          > 1.you have to set the right Mime Type :
          > response.contentEncoding="image/svg+xml" (make sure that this mime is

          ups! make that response.contentType !!!!!!!!!!!!!!!!!!!!!!!!!!

          > registered in your iis)
          > 2.use the correct namespace, e.g. make sure your svg document starts
          > like this:
          > <svg xmlns="http://www.w3.org/2000/svg">
          > 3. make sure your querystring ends with .svg
          > http://yourdomain/yourasp.asp?ex=.svg
          >
          > if you dont do 3., IE will somtimes not render your SVG, so i guess this
          > is what your looking for.
          >
          > hth
          > Holger
          >
          >
        • gh_urban
          I have a sucessful implementatin of ASV 3.03, Build 94 with IIS 5.0 serving asp svg usign dynamic mapping as well as having the contentType statement as holger
          Message 4 of 8 , Jul 4, 2005
            I have a sucessful implementatin of ASV 3.03, Build 94 with IIS 5.0
            serving asp>svg usign dynamic mapping

            as well as having the contentType statement as holger states, you
            should also map the .svg extension to the asp.dll

            this way you can call filename.svg?anyvar=any

            hope this helps.

            Garry

            --- In svg-developers@yahoogroups.com, Holger Will <holger@t...>
            wrote:
            > Holger Will schrieb:
            >
            > > Nicholas Lucaroni schrieb:
            > >
            > > > I don't want to seem like an a$$ for reposting this, but it is
            very
            > > > odd, and want to make sure that the necessary people see this.
            > > >
            > > > problem: Upgrading from adobe SVG viewer 3.02 -> 3.03 causes my
            SVG
            > > > page not to be displayed. It's an ASP page that renders database
            > > > information into dynamically drawn flow chart. The SVG is an
            embedded
            > > > object on a page with some simple directions on navigation.
            > > >
            > > > I've looked around the internet and have seen other places with
            the
            > > > same issue. There solution is "DONT UPGRADE TO 3.03!". It seems
            like
            > > > a co-out to me. What is the problem?
            > > >
            > > > While writing the page i used the 1.1 specs on the SVG reference
            > > > page, so my SVG should be correct. I think the issue is with
            ASP,
            > > > rendering the SVG returns a HTML document, not one with an SVG
            > > > extension. (when you right click on the document in 3.02 then
            > > > click "view SVG" it pops up a page of text(all the text objects
            on in
            > > > the SVG image), and the URL extension is .htm.
            > > >
            > > > So what do you all think? is that the possible reason? has
            anyone
            > > > experiemented with SVG and ASP, i've seen pages with SVG and
            ASP.NET
            > > > but they weren't old or anything, but probably used 3.02.
            Thanks for
            > > > your help, i hope someone can help me.
            > > >
            > > > -nick
            > >
            > > Hi Nick
            > > there are a few thing you have to care about, so that dynamicly
            > > generated svgs work across browsers.
            > >
            > > 1.you have to set the right Mime Type :
            > > response.contentEncoding="image/svg+xml" (make sure that this
            mime is
            >
            > ups! make that response.contentType !!!!!!!!!!!!!!!!!!!!!!!!!!
            >
            > > registered in your iis)
            > > 2.use the correct namespace, e.g. make sure your svg document
            starts
            > > like this:
            > > <svg xmlns="http://www.w3.org/2000/svg">
            > > 3. make sure your querystring ends with .svg
            > > http://yourdomain/yourasp.asp?ex=.svg
            > >
            > > if you dont do 3., IE will somtimes not render your SVG, so i
            guess this
            > > is what your looking for.
            > >
            > > hth
            > > Holger
            > >
            > >
          Your message has been successfully submitted and would be delivered to recipients shortly.