Loading ...
Sorry, an error occurred while loading the content.

RE: RE: [svg-developers] Re: Trouble with Adobe's 1.0 plugin

Expand Messages
  • Jon Ferraiolo
    Hi folks, The March 3 SVG spec says that the XLink namespace is http://www.w3.org/2000/xlink/namespace/ , but the XLink spec says that the XLink namespace is
    Message 1 of 3 , Jun 8, 2000
    • 0 Attachment
      Hi folks,
      The March 3 SVG spec says that the XLink namespace is
      "http://www.w3.org/2000/xlink/namespace/", but the XLink spec says that the
      XLink namespace is "http://www.w3.org/1999/xlink/namespace/". The fact that
      the SVG spec says "2000" instead of "1999" is an editorial error, for which
      I take full responsibility.

      However, implementers of SVG need to code towards a particular SVG
      specification. Adobe's engineers, like many others, just looked at the
      March 3 spec and did what that spec says, which is that the XLink namespace
      URI has "2000" in its name instead of "1999". So, if you are using the
      Adobe SVG Viewer, then you need to specify "2000".

      The SVG working group at the W3C will be coordinating with the XLink group
      to verify what exact namespace URI to use when SVG goes final, and future
      public drafts will make appropriate changes. I hope that Adobe will be able
      to find a way to support both the "http://www.w3.org/2000/xlink/namespace/"
      and whatever is the final XLink namespace URI in future releases of the
      Adobe SVG Viewer.

      Jon Ferraiolo
      SVG Editor
      Adobe Systems Incorporated


      >> >X-eGroups-Return:
      >> sentto-1298421-16-960395349-jferraio=adobe.com@...
      >> >To: "'svg-developers@egroups.com'" <svg-developers@egroups.com>,
      >> > "'jasenj1@...'" <jasenj1@...>
      >> >X-Mailer: Internet Mail Service (5.5.2650.21)
      >> >From: Justin Friedl <justin.friedl@...>
      >> >Mailing-List: list svg-developers@egroups.com; contact
      >> svg-developers-owner@egroups.com
      >> >Delivered-To: mailing list svg-developers@egroups.com
      >> >List-Unsubscribe: <mailto:svg-developers-unsubscribe@egroups.com>
      >> >Date: Wed, 7 Jun 2000 12:29:06 -0400
      >> >Reply-To: svg-developers@egroups.com
      >> >Subject: RE: [svg-developers] Re: Trouble with Adobe's 1.0 plugin
      >> >
      >> >I was suffering the same problem as this about 20 minutes ago
      >> >I used the following namespace:
      >> >xmlns:xlink="http://www.w3.org/2000/xlink/namespace/"
      >> >notice the "2000". This worked for me. let me know if it works for you
      >> >thanks
      >> >Justin
      >> >
      >> >-----Original Message-----
      >> >From: jasenj1@... [mailto:jasenj1@...]
      >> >Sent: Wednesday, June 07, 2000 8:08 AM
      >> >To: svg-developers@egroups.com
      >> >Subject: [svg-developers] Re: Trouble with Adobe's 1.0 plugin
      >> >
      >> >
      >> >[I posted earlier this morning, but that message hasn't shown up
      >> >yet. Guess I'll post again.]
      >> >
      >> >With the beta plugin, the below SVG file works fine, in the 1.0
      >> >plugin, the GIF image does not appear.
      >> >
      >> ><?xml version="1.0" encoding="UTF-8"?>
      >> ><svg xmlns:xlink="http://www.w3.org/1999/xlink/namespace"
      >> >xml:space="preserve" viewBox="0 0 900 900"
      >> >preserveAspectRatio="xMinYMin">
      >> > <g id="map">
      >> > <image xlink:href="\xml_jbi\data\tam\maps\images\eglin.gif"
      >> >width=" 900 " height=" 900 "/>
      >> > </g>
      >> ></svg>
      >> >
      >> >By removing the "xmlns:xlink" attribute, the 1.0 plugin displays the
      >> >image just fine.
      >> >
      >> >My problem is the SVG is created via a stylesheet processed with
      >> >Xalan - which appears to automagically add the "xmlns:xlink"
      >> >attribute to the "svg" element. According to the SVG spec, the xmlns
      >> >attribute should be acceptable.
      >> >
      >> >So, something appears to be broke in the 1.0 browser that worked in
      >> >the beta version.
      >> >
      >> >Any feedback?
      >> >
      >> > - Jasen.
      >> >
      >> >
      >> >
      >> >------------------------------------------------------------------------
      >> >Never lose a file again. Protect yourself from accidental deletes,
      >> >overwrites, and viruses with @Backup.
      >> >Try @Backup it's easy, it's safe, and it's FREE!
      >> >Click here to receive 300 MyPoints just for trying @Backup.
      >> >http://click.egroups.com/1/4936/5/_/68048/_/960390502/
      >> >------------------------------------------------------------------------
      >> >
      >> >
      >> >------------------------------------------------------------------------
      >> >Old school buds here:
      >> >http://click.egroups.com/1/4057/5/_/68048/_/960395349/
      >> >------------------------------------------------------------------------
      >> >
      >>
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.