Loading ...
Sorry, an error occurred while loading the content.

Re: [SUSE Linux Users] slow boot in opensuse 11.2 due to a hdd issue ( >4min ) [[part 2]]

Expand Messages
  • Walter 'Dutch' Duering
    Dear Person, An Parallel IDE connection will only work as fast as the slowest device on the cable. You have one IDE hard drive and one IDE CD/DVD device on
    Message 1 of 6 , Dec 27, 2009
    • 0 Attachment
      Dear Person,

      An Parallel IDE connection will only work as fast as the slowest device
      on the cable. You have one IDE hard drive and one IDE CD/DVD device on
      your system: CD/DVD devices are much slower than hard drives.

      For my MS Vista system I purchased a separate add-on card to ad a second
      Parallel IDE port. I keep my CD/DVD device on the add-on card and my HD
      on the motherboard Parallel IDE.

      I do not know if a LINUX supported add-on card is available, but I
      suspect that this would be the optimal solution to your problem.

      Dutch



      Felix Miata wrote:
      >
      > On 2009/12/27 10:35 (GMT-0500) ofvergara composed:
      > [a lot]
      >
      > What happens if you add libata.dma=1 to the kernel line? I think this is
      > about your CD-ROM. Does it boot quickly if you take it off the cable
      > before
      > powering up? Is your CD-ROM jumpered correctly? Is your CD-ROM on the
      > center
      > cable connector? If not, can you switch the cable positions of your CD-ROM
      > and HD? If not, can you reverse the jumpering to make the CD-ROM
      > master and
      > the HD the slave? Is your cable a normal, or a cable-select type? Name
      > brand
      > computers typically use cable-select, while replacements and generics are
      > usually normal.
      > --
      > " We have no government armed with power capable of
      > contending with human passions unbridled by morality and
      > religion." John Adams, 2nd US President
      >
      > Team OS/2 ** Reg. Linux User #211409
      >
      > Felix Miata *** http://fm.no-ip.com/ <http://fm.no-ip.com/>
      >
      >
    • b
      This sounds like a hardware problem with the hard drive of the dvd/cd drive   0.5)  make sure to try a different cable below   1) are you using a 80 or 40
      Message 2 of 6 , Dec 27, 2009
      • 0 Attachment
        This sounds like a hardware problem with the hard drive of the dvd/cd drive

          0.5)  make sure to try a different cable below

          1) are you using a 80 or 40 pin cable, if your using both drives on same ide use 40 pin cable for testing

          2) try with only one or the other connected if trying cd then do step 3 bellow

          3) if the problem still persists then try too boot from the suse live cd, and see if it has the same problem.

          4) reset the bios on the mother board and try all over again

           5) ummm, well try a different distro, like DSL and see what happens

           6) drink cold drink relax for a while

           this kind of thing happens if the drives are creating too many errors of hanging during startup


        Brian

        --- On Sun, 12/27/09, Walter 'Dutch' Duering <duering@...> wrote:

        From: Walter 'Dutch' Duering <duering@...>
        Subject: Re: [SUSE Linux Users] slow boot in opensuse 11.2 due to a hdd issue ( >4min ) [[part 2]]
        To: suselinuxusers@yahoogroups.com
        Date: Sunday, December 27, 2009, 11:29 AM


        Dear Person,

        An Parallel IDE connection will only work as fast as the slowest device
        on the cable. You have one IDE hard drive and one IDE CD/DVD device on
        your system: CD/DVD devices are much slower than hard drives.

        For my MS Vista system I purchased a separate add-on card to ad a second
        Parallel IDE port. I keep my CD/DVD device on the add-on card and my HD
        on the motherboard Parallel IDE.

        I do not know if a LINUX supported add-on card is available, but I
        suspect that this would be the optimal solution to your problem.

        Dutch



        Felix Miata wrote:
        >
        > On 2009/12/27 10:35 (GMT-0500) ofvergara composed:
        > [a lot]
        >
        > What happens if you add libata.dma=1 to the kernel line? I think this is
        > about your CD-ROM. Does it boot quickly if you take it off the cable
        > before
        > powering up? Is your CD-ROM jumpered correctly? Is your CD-ROM on the
        > center
        > cable connector? If not, can you switch the cable positions of your CD-ROM
        > and HD? If not, can you reverse the jumpering to make the CD-ROM
        > master and
        > the HD the slave? Is your cable a normal, or a cable-select type? Name
        > brand
        > computers typically use cable-select, while replacements and generics are
        > usually normal.
        > --
        > " We have no government armed with power capable of
        > contending with human passions unbridled by morality and
        > religion." John Adams, 2nd US President
        >
        > Team OS/2 ** Reg. Linux User #211409
        >
        > Felix Miata *** http://fm.no-ip.com/ <http://fm.no-ip.com/>
        >
        >


        ------------------------------------

        Yahoo! Groups Links








        [Non-text portions of this message have been removed]
      • Aaron Kulkis
        ... no, it won t. And I can t think of any reason why a normal user would want to mount a filesystem noatime. ... something that might be a key to what is
        Message 3 of 6 , Dec 29, 2009
        • 0 Attachment
          ofvergara wrote:
          > To see the previous message I sent, follow this link:
          >
          > http://forums.opensuse.org/install-boot-login/427411-slow-boot-opensuse-11-2-due-hdd-issue-4min.html
          >
          > *****
          >
          >
          > hi experienced susers:
          >
          > yesterday, i decided to start failsafe in order to improve this booting sequence. I added 'noatime' in fstab, unfortunately it didn't help.
          >

          no, it won't. And I can't think of any reason why a normal user
          would want to mount a filesystem noatime.

          > after looking very closely to the boot.msg log file, i found
          something that might be a key to what is going on, yet i don't
          have the experience to go further...
          >
          > this is what i discovered after the system iterates the hard
          > disk/dvd transfer speed (my motherboard is a hybrid
          > 2-sata-ports/1-ide-port system) and i'm using only the ide port
          > with the gray-data-cable which goes to the hdd and the dvd
          > (master & slave) . I don't use or have any components attached
          > to the sata port im my pc:
          >
          > Take a close look at this and the time it takes iterating while
          > downgrading the transfer speed:
          >
          > <4>[ 26.937913] ata1: link is slow to respond, please be patient (ready=0)
          > <6>[ 30.931697] ata1.00: configured for UDMA/133
          > <6>[ 30.941625] ata1.01: configured for UDMA/66
          > <4>[ 51.899965] ata1.01: limiting speed to UDMA/44:PIO4
          > <4>[ 56.970353] ata1: link is slow to respond, please be patient (ready=0)
          > <6>[ 60.913168] ata1.00: configured for UDMA/133
          > <6>[ 60.923072] ata1.01: configured for UDMA/44
          > <4>[ 81.933346] ata1.01: limiting speed to UDMA/33:PIO4
          > <4>[ 87.003790] ata1: link is slow to respond, please be patient (ready=0)
          > <6>[ 90.895614] ata1.00: configured for UDMA/133
          > <6>[ 90.905516] ata1.01: configured for UDMA/33
          > <6>[ 121.186984] ata1.00: configured for UDMA/133
          > <6>[ 121.195912] ata1.01: configured for UDMA/33
          > <4>[ 152.067827] ata1.00: limiting speed to UDMA/100:PIO4
          > <6>[ 152.250284] ata1.00: configured for UDMA/100
          > <6>[ 152.259191] ata1.01: configured for UDMA/33
          > <4>[ 183.128989] ata1.00: limiting speed to UDMA/33:PIO4
          > <6>[ 183.310541] ata1.00: configured for UDMA/33
          > <6>[ 183.319515] ata1.01: configured for UDMA/33
          > <4>[ 214.188154] ata1.00: limiting speed to PIO4
          > <6>[ 214.368822] ata1.00: configured for PIO4
          > <6>[ 214.377751] ata1.01: configured for UDMA/33
          > <4>[ 235.207880] ata1.01: limiting speed to PIO4
          > <4>[ 240.272494] ata1: link is slow to respond, please be patient (ready=0)
          > <3>[ 240.808414] INFO: task ata_aux:16 blocked for more than 120 seconds.
          > <3>[ 240.811462] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
          > <6>[ 244.321281] ata1.00: configured for PIO4
          > <6>[ 244.330197] ata1.01: configured for PIO4
          > <4>[ 244.361692] sda5
          > <5>[ 244.362403] scsi 0:0:1:0: CD-ROM HL-DT-ST DVD-RAM GSA-H22N 1.00 PQ: 0 ANSI: 5
          > <7>[ 244.369123] ata2: port disabled. ignoring.
          > <4>[ 244.379736] sda6 sda7 sda8 sda9 >
          > <5>[ 244.421472] sd 0:0:0:0: [sda] Attached SCSI disk
          > <6>[ 244.428478] sda: detected capacity change from 0 to 41110142976
          >
          > As you can see, the system is iterating and downgrading the transfer
          > speed, and while it does this, it stops booting for 4 minutes until
          > it reaches pio4.
          >
          > I have 3 questions:
          > * ¿can you give me a hint on how do i set pio4 to avoid this waiting
          > (hdparm anyone?) so the system can continue booting quickly? -or-

          You have a hardware problem. The reason it is downgrading is because
          your hardware is not performing to spec. So the software repeatedly
          tries progressively slower transfer protocols.

          > * ¿what is causing this system to adopt the slowest transfer speed? -or-

          Your hardware is screwed --- either the disk drive, or the disk
          controller chip. Try throwing a cheap disk controller card into
          a card slot, and attach a drive to that and see what happens.

          > * ¿perhaps two linux drivers are competing to control the ata port?

          No.
        • Aaron Kulkis
          ... Good point, I forgot about the cable. But I would use an 80-conductor (still 40 pin) cable, because the 80-conductor ribbon has much higher bandwidth
          Message 4 of 6 , Dec 29, 2009
          • 0 Attachment
            b wrote:
            > This sounds like a hardware problem with the hard drive of the dvd/cd drive
            >
            > 0.5) make sure to try a different cable below
            >
            > 1) are you using a 80 or 40 pin cable, if your using both drives on same ide use 40 pin cable for testing
            >

            Good point, I forgot about the cable.

            But I would use an 80-conductor (still 40 pin) cable, because
            the 80-conductor ribbon has much higher bandwidth capability
            (because every other wire is ground, providing MUCH better
            isolation of each pin from its neighbors.)
          Your message has been successfully submitted and would be delivered to recipients shortly.