Loading ...
Sorry, an error occurred while loading the content.
 

Time Zone, Daylight Savings

Expand Messages
  • Jefferson Smith
    I m confused since DST change didn t work. It is set for time zone USA/Mountain. I don t see any settings related to daylight savings, so I assumed it would
    Message 1 of 15 , Nov 2, 2004
      I'm confused since DST change didn't work. It is set for time zone
      USA/Mountain. I don't see any settings related to daylight savings, so
      I assumed it would set my clock back an hour on 10-31 02:00.

      1. I booted my computer Monday 11-01, and saw that it was not set
      back, i.e. it showed 9am instead of 8am. I tried setting time
      backwards to 01:59 Sun morning. That time, it actually worked, rolling
      over to 01:00.

      2. I log in 11-02 about 08:00 and see that it says the time is about
      3am. I shut down X, and in a shell type current time something like
      `date -u 110210452004`. Time set is echoed properly to conslole. I
      reboot, and time as gone back to about 03:30.

      3. This time I use "Adjust Date & Time" menu option on the KDE Panel
      clock. I reboot, and now it is keeping proper time.

      Uh, does anybody else have trouble like this, or know what's wrong?
      --jeffs
    • Aaron Kulkis
      ... Was your computer ON at that time? ... use xntp and be done with it.
      Message 2 of 15 , Nov 3, 2004
        Jefferson Smith wrote:
        >
        > I'm confused since DST change didn't work. It is set for time zone
        > USA/Mountain. I don't see any settings related to daylight savings, so
        > I assumed it would set my clock back an hour on 10-31 02:00.
        >

        Was your computer ON at that time?

        > 1. I booted my computer Monday 11-01, and saw that it was not set
        > back, i.e. it showed 9am instead of 8am. I tried setting time
        > backwards to 01:59 Sun morning. That time, it actually worked, rolling
        > over to 01:00.
        >
        > 2. I log in 11-02 about 08:00 and see that it says the time is about
        > 3am. I shut down X, and in a shell type current time something like
        > `date -u 110210452004`. Time set is echoed properly to conslole. I
        > reboot, and time as gone back to about 03:30.
        >
        > 3. This time I use "Adjust Date & Time" menu option on the KDE Panel
        > clock. I reboot, and now it is keeping proper time.
        >
        > Uh, does anybody else have trouble like this, or know what's wrong?
        > --jeffs

        use xntp and be done with it.
      • Jefferson Smith
        Computer was off at the time. You re right about xntp. It happened again, the next time I left it off overnight. Sounds like the battery or hardware at least,
        Message 3 of 15 , Nov 3, 2004
          Computer was off at the time. You're right about xntp. It happened
          again, the next time I left it off overnight. Sounds like the battery
          or hardware at least, but I haven't verified it. Sounds like xntp
          would avoid the need for the hardware keeping time between boots (?)
          Thanks, --jeffs


          --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...> wrote:
          > Jefferson Smith wrote:
          > >
          > > I'm confused since DST change didn't work. It is set for time zone
          > > USA/Mountain. I don't see any settings related to daylight savings, so
          > > I assumed it would set my clock back an hour on 10-31 02:00.
          > >
          >
          > Was your computer ON at that time?
          >
          > > 1. I booted my computer Monday 11-01, and saw that it was not set
          > > back, i.e. it showed 9am instead of 8am. I tried setting time
          > > backwards to 01:59 Sun morning. That time, it actually worked, rolling
          > > over to 01:00.
          > >
          > > 2. I log in 11-02 about 08:00 and see that it says the time is about
          > > 3am. I shut down X, and in a shell type current time something like
          > > `date -u 110210452004`. Time set is echoed properly to conslole. I
          > > reboot, and time as gone back to about 03:30.
          > >
          > > 3. This time I use "Adjust Date & Time" menu option on the KDE Panel
          > > clock. I reboot, and now it is keeping proper time.
          > >
          > > Uh, does anybody else have trouble like this, or know what's wrong?
          > > --jeffs
          >
          > use xntp and be done with it.
        • Aaron Kulkis
          ... Here s a working /etc/ntp.conf file I have 12 level-2 servers and 1 level-3 server Make sure you read through it. # comments ending in (ark) were inserted
          Message 4 of 15 , Nov 3, 2004
            Jefferson Smith wrote:
            >
            > Computer was off at the time. You're right about xntp. It happened
            > again, the next time I left it off overnight. Sounds like the battery
            > or hardware at least, but I haven't verified it. Sounds like xntp
            > would avoid the need for the hardware keeping time between boots (?)
            > Thanks, --jeffs

            Here's a working /etc/ntp.conf file
            I have 12 level-2 servers and 1 level-3 server

            Make sure you read through it.
            # comments ending in (ark) were inserted by me.
            Notice that I specify some log files to be in /var/log/ntp

            You'll want to either edit that, or do this

            $ su
            password:
            # mkdir /var/log/ntp
            # exit
            $







            ################################################################################
            ## /etc/ntp.conf
            ##
            ## Sample NTP configuration file.
            ## See package 'xntp-doc' for documentation, Mini-HOWTO and FAQ.
            ## Copyright (c) 1998 S.u.S.E. GmbH Fuerth, Germany.
            ##
            ## Author: Michael Andres, <ma@...>
            ##
            ################################################################################
            #
            # Sat Feb 15 00:00:58 EST 2003
            # added outside servers

            ##
            ## Radio and modem clocks by convention have addresses in the
            ## form 127.127.t.u, where t is the clock type and u is a unit
            ## number in the range 0-3.
            ##
            ## Most of these clocks require support in the form of a
            ## serial port or special bus peripheral. The particular
            ## device is normally specified by adding a soft link
            ## /dev/device-u to the particular hardware device involved,
            ## where u correspond to the unit number above.
            ##
            ## Generic DCF77 clock on serial port (Conrad DCF77)
            ## Address: 127.127.8.u
            ## Serial Port: /dev/refclock-u
            ##
            ## (create soft link /dev/refclock-0 to the particular ttyS?)
            ##
            # server 127.127.8.0 mode 5 prefer

            ##
            ## Undisciplined Local Clock. This is a fake driver intended for backup
            ## and when no outside source of synchronized time is available.
            ##

            server 127.127.1.0 # local clock (LCL)
            fudge 127.127.1.0 stratum 10 # LCL is unsynchronized

            ##
            ## Outside source of synchronized time
            ##
            ## server xx.xx.xx.xx # IP address of server

            # these are all publicly-accessible ntp servers, no keys required,
            # nor any courtesy e-mail requested.
            #
            # stratum 2 servers (ark)
            server dr-zaius.cs.wisc.edu burst minpoll 6 maxpoll 12
            server ceasar.cs.wisc.edu burst minpoll 6 maxpoll 12
            server otc2.psu.edu burst minpoll 6 maxpoll 12
            server louie.udel.edu burst minpoll 6 maxpoll 12
            server harbor.ecn.purdue.edu burst minpoll 6 maxpoll 12
            server filbert.cc.columbia.edu burst minpoll 6 maxpoll 12
            server ntp-0.gw.uiuc.edu. burst minpoll 6 maxpoll 12
            server ntp-1.gw.uiuc.edu burst minpoll 6 maxpoll 12
            server ntp-2.gw.uiuc.edu burst minpoll 6 maxpoll 12
            server cudns.cit.cornell.edu burst minpoll 6 maxpoll 12
            server seismo.cmr.gov. burst minpoll 6 maxpoll 12
            server 19er.cc.vt.edu8 burst minpoll 6 maxpoll 12
            # stratum 3 servers (ark)
            server gilbreth.ecn.purdue.edu burst minpoll 6 maxpoll 12

            ##
            ## Miscellaneous stuff
            ##

            driftfile /var/lib/ntp/ntp.drift # path for drift file

            logfile /var/log/ntp # alternate log file
            # logconfig =syncstatus + sysevents
            logconfig =all

            statsdir /var/log/xntp/ # directory for statistics files
            filegen peerstats file peerstats type day enable
            filegen loopstats file loopstats type day enable
            filegen clockstats file clockstats type day enable
            filegen rawstats file rawstats type day enable

            #
            # Authentication stuff
            #
            # keys /etc/ntp.keys # path for keys file
            # trustedkey 1 2 3 4 5 6 14 15 # define trusted keys
            # requestkey 15 # key (7) for accessing server variables
            # controlkey 15 # key (6) for accessing server variables





            >
            >
            > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...> wrote:
            >
            >>Jefferson Smith wrote:
            >>
            >>>I'm confused since DST change didn't work. It is set for time zone
            >>>USA/Mountain. I don't see any settings related to daylight savings, so
            >>>I assumed it would set my clock back an hour on 10-31 02:00.
            >>>
            >>
            >>Was your computer ON at that time?
            >>
            >>
            >>>1. I booted my computer Monday 11-01, and saw that it was not set
            >>>back, i.e. it showed 9am instead of 8am. I tried setting time
            >>>backwards to 01:59 Sun morning. That time, it actually worked, rolling
            >>>over to 01:00.
            >>>
            >>>2. I log in 11-02 about 08:00 and see that it says the time is about
            >>>3am. I shut down X, and in a shell type current time something like
            >>>`date -u 110210452004`. Time set is echoed properly to conslole. I
            >>>reboot, and time as gone back to about 03:30.
            >>>
            >>>3. This time I use "Adjust Date & Time" menu option on the KDE Panel
            >>>clock. I reboot, and now it is keeping proper time.
            >>>
            >>>Uh, does anybody else have trouble like this, or know what's wrong?
            >>> --jeffs
            >>
            >>use xntp and be done with it.
            >
            >
            >
            >
            >
            >
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
            >
            >
          • Jefferson Smith
            Alright, I got the ntp updates going, here s the log from this morning: 5 Nov 07:33:56 ntpd[5447]: synchronized to LOCAL(0), stratum 10 5 Nov 07:33:56
            Message 5 of 15 , Nov 5, 2004
              Alright, I got the ntp updates going, here's the log from this morning:
              5 Nov 07:33:56 ntpd[5447]: synchronized to LOCAL(0), stratum 10
              5 Nov 07:33:56 ntpd[5447]: kernel time sync disabled 0041
              5 Nov 07:34:59 ntpd[5447]: kernel time sync enabled 0001

              Now, a strange thing I found. I want to know if I just don't have
              things configured right, or what. In the dialog "Adjust Date &
              Time..." from the Clock menu (in the corner of the taskbar), I had
              changed the setting to store time in UTC. This seems to not work
              right. It shows alright until I start the computer the next day, Then
              I think it is displaying UTC on the clock instead of the time zone I
              have selected. This happened before and after I enabled the ntp
              client. I changed back to set hwclock as local time, and it comes up
              correct in the morning.


              --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...> wrote:
              > Jefferson Smith wrote:
              > >
              > > Computer was off at the time. You're right about xntp. It happened
              > > again, the next time I left it off overnight. Sounds like the battery
              > > or hardware at least, but I haven't verified it. Sounds like xntp
              > > would avoid the need for the hardware keeping time between boots (?)
              > > Thanks, --jeffs
              >
              > Here's a working /etc/ntp.conf file
              > I have 12 level-2 servers and 1 level-3 server
              >
              > Make sure you read through it.
              > # comments ending in (ark) were inserted by me.
              > Notice that I specify some log files to be in /var/log/ntp
              >
              > You'll want to either edit that, or do this
              >
              > $ su
              > password:
              > # mkdir /var/log/ntp
              > # exit
              > $
              >
              >
              >
              >
              >
              >
              >
              >
              ################################################################################
              > ## /etc/ntp.conf
              > ##
              > ## Sample NTP configuration file.
              > ## See package 'xntp-doc' for documentation, Mini-HOWTO and FAQ.
              > ## Copyright (c) 1998 S.u.S.E. GmbH Fuerth, Germany.
              > ##
              > ## Author: Michael Andres, <ma@s...>
              > ##
              >
              ################################################################################
              > #
              > # Sat Feb 15 00:00:58 EST 2003
              > # added outside servers
              >
              > ##
              > ## Radio and modem clocks by convention have addresses in the
              > ## form 127.127.t.u, where t is the clock type and u is a unit
              > ## number in the range 0-3.
              > ##
              > ## Most of these clocks require support in the form of a
              > ## serial port or special bus peripheral. The particular
              > ## device is normally specified by adding a soft link
              > ## /dev/device-u to the particular hardware device involved,
              > ## where u correspond to the unit number above.
              > ##
              > ## Generic DCF77 clock on serial port (Conrad DCF77)
              > ## Address: 127.127.8.u
              > ## Serial Port: /dev/refclock-u
              > ##
              > ## (create soft link /dev/refclock-0 to the particular ttyS?)
              > ##
              > # server 127.127.8.0 mode 5 prefer
              >
              > ##
              > ## Undisciplined Local Clock. This is a fake driver intended for backup
              > ## and when no outside source of synchronized time is available.
              > ##
              >
              > server 127.127.1.0 # local clock (LCL)
              > fudge 127.127.1.0 stratum 10 # LCL is unsynchronized
              >
              > ##
              > ## Outside source of synchronized time
              > ##
              > ## server xx.xx.xx.xx # IP address of server
              >
              > # these are all publicly-accessible ntp servers, no keys required,
              > # nor any courtesy e-mail requested.
              > #
              > # stratum 2 servers (ark)
              > server dr-zaius.cs.wisc.edu burst minpoll 6 maxpoll 12
              > server ceasar.cs.wisc.edu burst minpoll 6 maxpoll 12
              > server otc2.psu.edu burst minpoll 6 maxpoll 12
              > server louie.udel.edu burst minpoll 6 maxpoll 12
              > server harbor.ecn.purdue.edu burst minpoll 6 maxpoll 12
              > server filbert.cc.columbia.edu burst minpoll 6 maxpoll 12
              > server ntp-0.gw.uiuc.edu. burst minpoll 6 maxpoll 12
              > server ntp-1.gw.uiuc.edu burst minpoll 6 maxpoll 12
              > server ntp-2.gw.uiuc.edu burst minpoll 6 maxpoll 12
              > server cudns.cit.cornell.edu burst minpoll 6 maxpoll 12
              > server seismo.cmr.gov. burst minpoll 6 maxpoll 12
              > server 19er.cc.vt.edu8 burst minpoll 6 maxpoll 12
              > # stratum 3 servers (ark)
              > server gilbreth.ecn.purdue.edu burst minpoll 6 maxpoll 12
              >
              > ##
              > ## Miscellaneous stuff
              > ##
              >
              > driftfile /var/lib/ntp/ntp.drift # path for drift file
              >
              > logfile /var/log/ntp # alternate log file
              > # logconfig =syncstatus + sysevents
              > logconfig =all
              >
              > statsdir /var/log/xntp/ # directory for statistics files
              > filegen peerstats file peerstats type day enable
              > filegen loopstats file loopstats type day enable
              > filegen clockstats file clockstats type day enable
              > filegen rawstats file rawstats type day enable
              >
              > #
              > # Authentication stuff
              > #
              > # keys /etc/ntp.keys # path for keys file
              > # trustedkey 1 2 3 4 5 6 14 15 # define trusted keys
              > # requestkey 15 # key (7) for accessing server variables
              > # controlkey 15 # key (6) for accessing server variables
              >
              >
              >
              >
              >
              > >
              > >
              > > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...>
              wrote:
              > >
              > >>Jefferson Smith wrote:
              > >>
              > >>>I'm confused since DST change didn't work. It is set for time zone
              > >>>USA/Mountain. I don't see any settings related to daylight
              savings, so
              > >>>I assumed it would set my clock back an hour on 10-31 02:00.
              > >>>
              > >>
              > >>Was your computer ON at that time?
              > >>
              > >>
              > >>>1. I booted my computer Monday 11-01, and saw that it was not set
              > >>>back, i.e. it showed 9am instead of 8am. I tried setting time
              > >>>backwards to 01:59 Sun morning. That time, it actually worked,
              rolling
              > >>>over to 01:00.
              > >>>
              > >>>2. I log in 11-02 about 08:00 and see that it says the time is about
              > >>>3am. I shut down X, and in a shell type current time something like
              > >>>`date -u 110210452004`. Time set is echoed properly to conslole. I
              > >>>reboot, and time as gone back to about 03:30.
              > >>>
              > >>>3. This time I use "Adjust Date & Time" menu option on the KDE Panel
              > >>>clock. I reboot, and now it is keeping proper time.
              > >>>
              > >>>Uh, does anybody else have trouble like this, or know what's wrong?
              > >>> --jeffs
              > >>
              > >>use xntp and be done with it.
              > >
              > >
              > >
              > >
              > >
              > >
              > >
              > >
              > > Yahoo! Groups Links
              > >
              > >
              > >
              > >
              > >
              > >
              > >
              > >
            • leon
              ... I had a similar thing with keyboard map, it was wrong after every boot and changes weren t saved for some reason (I think Yast has problems) I ve reloaded
              Message 6 of 15 , Nov 5, 2004
                On Saturday 06 November 2004 07:59, Jefferson Smith wrote:
                > Alright, I got the ntp updates going, here's the log from this morning:
                > 5 Nov 07:33:56 ntpd[5447]: synchronized to LOCAL(0), stratum 10
                > 5 Nov 07:33:56 ntpd[5447]: kernel time sync disabled 0041
                > 5 Nov 07:34:59 ntpd[5447]: kernel time sync enabled 0001
                >
                > Now, a strange thing I found. I want to know if I just don't have
                > things configured right, or what. In the dialog "Adjust Date &
                > Time..." from the Clock menu (in the corner of the taskbar), I had
                > changed the setting to store time in UTC. This seems to not work
                > right. It shows alright until I start the computer the next day,
                I had a similar thing with keyboard map, it was wrong after every boot and
                changes weren't saved for some reason (I think Yast has problems)
                I've reloaded the whole thing and it's OK now!!
                > Then
                > I think it is displaying UTC on the clock instead of the time zone I
                > have selected. This happened before and after I enabled the ntp
                > client. I changed back to set hwclock as local time, and it comes up
                > correct in the morning.
                >
                > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...> wrote:
                > > Jefferson Smith wrote:
                > > > Computer was off at the time. You're right about xntp. It happened
                > > > again, the next time I left it off overnight. Sounds like the battery
                > > > or hardware at least, but I haven't verified it. Sounds like xntp
                > > > would avoid the need for the hardware keeping time between boots (?)
                > > >        Thanks,   --jeffs
                > >
                > > Here's a working /etc/ntp.conf file
                > > I have 12 level-2 servers and 1 level-3 server
                > >
                > > Make sure you read through it.
                > > # comments ending in (ark) were inserted by me.
                > > Notice that I specify some log files to be in /var/log/ntp
                > >
                > > You'll want to either edit that, or do this
                > >
                > > $ su
                > > password:
                > > # mkdir /var/log/ntp
                > > # exit
                > > $
                >
                >
                > ###########################################################################
                >#####
                >
                > > ## /etc/ntp.conf
                > > ##
                > > ## Sample NTP configuration file.
                > > ## See package 'xntp-doc' for documentation, Mini-HOWTO and FAQ.
                > > ## Copyright (c) 1998 S.u.S.E. GmbH Fuerth, Germany.
                > > ##
                > > ## Author: Michael Andres,  <ma@s...>
                > > ##
                >
                >
                > ###########################################################################
                >#####
                >
                > > #
                > > # Sat Feb 15 00:00:58 EST 2003
                > > # added outside servers
                > >
                > > ##
                > > ## Radio and modem clocks by convention have addresses in the
                > > ## form 127.127.t.u, where t is the clock type and u is a unit
                > > ## number in the range 0-3.
                > > ##
                > > ## Most of these clocks require support in the form of a
                > > ## serial port or special bus peripheral. The particular
                > > ## device is normally specified by adding a soft link
                > > ## /dev/device-u to the particular hardware device involved,
                > > ## where u correspond to the unit number above.
                > > ##
                > > ## Generic DCF77 clock on serial port (Conrad DCF77)
                > > ## Address:     127.127.8.u
                > > ## Serial Port: /dev/refclock-u
                > > ##
                > > ## (create soft link /dev/refclock-0 to the particular ttyS?)
                > > ##
                > > # server 127.127.8.0 mode 5 prefer
                > >
                > > ##
                > > ## Undisciplined Local Clock. This is a fake driver intended for backup
                > > ## and when no outside source of synchronized time is available.
                > > ##
                > >
                > > server 127.127.1.0              # local clock (LCL)
                > > fudge  127.127.1.0 stratum 10   # LCL is unsynchronized
                > >
                > > ##
                > > ## Outside source of synchronized time
                > > ##
                > > ## server xx.xx.xx.xx           # IP address of server
                > >
                > > # these are all publicly-accessible ntp servers, no keys required,
                > > # nor any courtesy e-mail requested.
                > > #
                > > # stratum 2 servers (ark)
                > > server dr-zaius.cs.wisc.edu     burst   minpoll 6 maxpoll 12
                > > server ceasar.cs.wisc.edu       burst   minpoll 6 maxpoll 12
                > > server otc2.psu.edu             burst   minpoll 6 maxpoll 12
                > > server louie.udel.edu           burst   minpoll 6 maxpoll 12
                > > server harbor.ecn.purdue.edu    burst   minpoll 6 maxpoll 12
                > > server filbert.cc.columbia.edu  burst   minpoll 6 maxpoll 12
                > > server ntp-0.gw.uiuc.edu.       burst   minpoll 6 maxpoll 12
                > > server ntp-1.gw.uiuc.edu        burst   minpoll 6 maxpoll 12
                > > server ntp-2.gw.uiuc.edu        burst   minpoll 6 maxpoll 12
                > > server cudns.cit.cornell.edu    burst   minpoll 6 maxpoll 12
                > > server seismo.cmr.gov.          burst   minpoll 6 maxpoll 12
                > > server 19er.cc.vt.edu8          burst   minpoll 6 maxpoll 12
                > > # stratum 3 servers (ark)
                > > server gilbreth.ecn.purdue.edu  burst   minpoll 6 maxpoll 12
                > >
                > > ##
                > > ## Miscellaneous stuff
                > > ##
                > >
                > > driftfile /var/lib/ntp/ntp.drift # path for drift file
                > >
                > > logfile   /var/log/ntp          # alternate log file
                > > # logconfig =syncstatus + sysevents
                > > logconfig =all
                > >
                > > statsdir /var/log/xntp/     # directory for statistics files
                > > filegen peerstats       file peerstats  type day enable
                > > filegen loopstats       file loopstats  type day enable
                > > filegen clockstats      file clockstats type day enable
                > > filegen rawstats        file rawstats   type day enable
                > >
                > > #
                > > # Authentication stuff
                > > #
                > > # keys /etc/ntp.keys            # path for keys file
                > > # trustedkey 1 2 3 4 5 6 14 15  # define trusted keys
                > > # requestkey 15                 # key (7) for accessing server variables
                > > # controlkey 15                 # key (6) for accessing server variables
                > >
                > > > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...>
                >
                > wrote:
                > > >>Jefferson Smith wrote:
                > > >>>I'm confused since DST change didn't work. It is set for time zone
                > > >>>USA/Mountain. I don't see any settings related to daylight
                >
                > savings, so
                >
                > > >>>I assumed it would set my clock back an hour on 10-31 02:00.
                > > >>
                > > >>Was your computer ON at that time?
                > > >>
                > > >>>1.  I booted my computer Monday 11-01, and saw that it was not set
                > > >>>back, i.e. it showed 9am instead of 8am. I tried setting time
                > > >>>backwards to 01:59 Sun morning. That time, it actually worked,
                >
                > rolling
                >
                > > >>>over to 01:00.
                > > >>>
                > > >>>2.  I log in 11-02 about 08:00 and see that it says the time is about
                > > >>>3am. I shut down X, and in a shell type current time something like
                > > >>>`date -u 110210452004`. Time set is echoed properly to conslole. I
                > > >>>reboot, and time as gone back to about 03:30.
                > > >>>
                > > >>>3.  This time I use "Adjust Date & Time" menu option on the KDE Panel
                > > >>>clock. I reboot, and now it is keeping proper time.
                > > >>>
                > > >>>Uh, does anybody else have trouble like this, or know what's wrong? 
                > > >>>     --jeffs
                > > >>
                > > >>use xntp and be done with it.
                > > >
                > > > 
                > > > Yahoo! Groups Links
                > > >
                > > >
                > > >
                > > > 
                >
                > Yahoo! Groups Sponsor
                >
                >
                >
                > ADVERTISEMENT
                >
                >
                >
                >
                >
                >
                >
                > Yahoo! Groups Links
                >
                > To visit your group on the web, go to:
                > http://groups.yahoo.com/group/suselinuxusers/
                >  
                > To unsubscribe from this group, send an email to:
                > suselinuxusers-unsubscribe@yahoogroups.com
                >  
                > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
              • Aaron Kulkis
                ... Check to see if your motherboard has a BIOS setting which plays a part in this.
                Message 7 of 15 , Nov 5, 2004
                  Jefferson Smith wrote:
                  >
                  > Alright, I got the ntp updates going, here's the log from this morning:
                  > 5 Nov 07:33:56 ntpd[5447]: synchronized to LOCAL(0), stratum 10
                  > 5 Nov 07:33:56 ntpd[5447]: kernel time sync disabled 0041
                  > 5 Nov 07:34:59 ntpd[5447]: kernel time sync enabled 0001
                  >
                  > Now, a strange thing I found. I want to know if I just don't have
                  > things configured right, or what. In the dialog "Adjust Date &
                  > Time..." from the Clock menu (in the corner of the taskbar), I had
                  > changed the setting to store time in UTC. This seems to not work
                  > right. It shows alright until I start the computer the next day, Then
                  > I think it is displaying UTC on the clock instead of the time zone I
                  > have selected. This happened before and after I enabled the ntp
                  > client. I changed back to set hwclock as local time, and it comes up
                  > correct in the morning.

                  Check to see if your motherboard has a BIOS setting which
                  plays a part in this.


                  >
                  >
                  > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...> wrote:
                  >
                  >>Jefferson Smith wrote:
                  >>
                  >>>Computer was off at the time. You're right about xntp. It happened
                  >>>again, the next time I left it off overnight. Sounds like the battery
                  >>>or hardware at least, but I haven't verified it. Sounds like xntp
                  >>>would avoid the need for the hardware keeping time between boots (?)
                  >>> Thanks, --jeffs
                  >>
                  >>Here's a working /etc/ntp.conf file
                  >>I have 12 level-2 servers and 1 level-3 server
                  >>
                  >>Make sure you read through it.
                  >># comments ending in (ark) were inserted by me.
                  >>Notice that I specify some log files to be in /var/log/ntp
                  >>
                  >>You'll want to either edit that, or do this
                  >>
                  >>$ su
                  >>password:
                  >># mkdir /var/log/ntp
                  >># exit
                  >>$
                  >>
                  >>
                  >> < sample /etc/ntp.conf file snipped>
                • Aaron Kulkis
                  ... ^^^^^^^^^^^^^^^^^^^^^^^ This isn t windows, dude. Just change the configuration and get on with your life.
                  Message 8 of 15 , Nov 5, 2004
                    leon wrote:
                    > On Saturday 06 November 2004 07:59, Jefferson Smith wrote:
                    >
                    >> Alright, I got the ntp updates going, here's the log from this morning:
                    >> 5 Nov 07:33:56 ntpd[5447]: synchronized to LOCAL(0), stratum 10
                    >> 5 Nov 07:33:56 ntpd[5447]: kernel time sync disabled 0041
                    >> 5 Nov 07:34:59 ntpd[5447]: kernel time sync enabled 0001
                    >>
                    >> Now, a strange thing I found. I want to know if I just don't have
                    >> things configured right, or what. In the dialog "Adjust Date &
                    >> Time..." from the Clock menu (in the corner of the taskbar), I had
                    >> changed the setting to store time in UTC. This seems to not work
                    >> right. It shows alright until I start the computer the next day,
                    >
                    > I had a similar thing with keyboard map, it was wrong after every boot and
                    > changes weren't saved for some reason (I think Yast has problems)
                    > I've reloaded the whole thing and it's OK now!!
                    ^^^^^^^^^^^^^^^^^^^^^^^

                    This isn't windows, dude.
                    Just change the configuration and get on with your life.
                  • Jefferson Smith
                    I can t think of any settings in BIOS pertaining to which time zone. Any keywords to look for? Why would BIOS care which timezone the clock is set for?
                    Message 9 of 15 , Nov 5, 2004
                      I can't think of any settings in BIOS pertaining to which time zone.
                      Any keywords to look for? Why would BIOS care which timezone the clock
                      is set for? --jeffs

                      P.S. True nobody should have to reload Linux. It may be easy to say
                      "change the settings and get on with life", but what settings?


                      --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...> wrote:
                      > Jefferson Smith wrote:
                      > >
                      > > Alright, I got the ntp updates going, here's the log from this
                      morning:
                      > > 5 Nov 07:33:56 ntpd[5447]: synchronized to LOCAL(0), stratum 10
                      > > 5 Nov 07:33:56 ntpd[5447]: kernel time sync disabled 0041
                      > > 5 Nov 07:34:59 ntpd[5447]: kernel time sync enabled 0001
                      > >
                      > > Now, a strange thing I found. I want to know if I just don't have
                      > > things configured right, or what. In the dialog "Adjust Date &
                      > > Time..." from the Clock menu (in the corner of the taskbar), I had
                      > > changed the setting to store time in UTC. This seems to not work
                      > > right. It shows alright until I start the computer the next day, Then
                      > > I think it is displaying UTC on the clock instead of the time zone I
                      > > have selected. This happened before and after I enabled the ntp
                      > > client. I changed back to set hwclock as local time, and it comes up
                      > > correct in the morning.
                      >
                      > Check to see if your motherboard has a BIOS setting which
                      > plays a part in this.
                      >
                      >
                      > >
                      > >
                      > > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...>
                      wrote:
                      > >
                      > >>Jefferson Smith wrote:
                      > >>
                      > >>>Computer was off at the time. You're right about xntp. It happened
                      > >>>again, the next time I left it off overnight. Sounds like the battery
                      > >>>or hardware at least, but I haven't verified it. Sounds like xntp
                      > >>>would avoid the need for the hardware keeping time between boots (?)
                      > >>> Thanks, --jeffs
                      > >>
                      > >>Here's a working /etc/ntp.conf file
                      > >>I have 12 level-2 servers and 1 level-3 server
                      > >>
                      > >>Make sure you read through it.
                      > >># comments ending in (ark) were inserted by me.
                      > >>Notice that I specify some log files to be in /var/log/ntp
                      > >>
                      > >>You'll want to either edit that, or do this
                      > >>
                      > >>$ su
                      > >>password:
                      > >># mkdir /var/log/ntp
                      > >># exit
                      > >>$
                      > >>
                      > >>
                      > >> < sample /etc/ntp.conf file snipped>
                    • leon
                      ... Change to Mandrake, the help is friendlier!!
                      Message 10 of 15 , Nov 5, 2004
                        On Saturday 06 November 2004 09:43, Jefferson Smith wrote:
                        > I can't think of any settings in BIOS pertaining to which time zone.
                        > Any keywords to look for? Why would BIOS care which timezone the clock
                        > is set for?           --jeffs
                        >
                        > P.S. True nobody should have to reload Linux. It may be easy to say
                        > "change the settings and get on with life", but what settings?
                        Change to Mandrake, the help is friendlier!!
                        >
                        > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...> wrote:
                        > > Jefferson Smith wrote:
                        > > > Alright, I got the ntp updates going, here's the log from this
                        >
                        > morning:
                        > > >  5 Nov 07:33:56 ntpd[5447]: synchronized to LOCAL(0), stratum 10
                        > > >  5 Nov 07:33:56 ntpd[5447]: kernel time sync disabled 0041
                        > > >  5 Nov 07:34:59 ntpd[5447]: kernel time sync enabled 0001
                        > > >
                        > > > Now, a strange thing I found. I want to know if I just don't have
                        > > > things configured right, or what. In the dialog "Adjust Date &
                        > > > Time..." from the Clock menu (in the corner of the taskbar), I had
                        > > > changed the setting to store time in UTC. This seems to not work
                        > > > right. It shows alright until I start the computer the next day, Then
                        > > > I think it is displaying UTC on the clock instead of the time zone I
                        > > > have selected. This happened before and after I enabled the ntp
                        > > > client. I changed back to set hwclock as local time, and it comes up
                        > > > correct in the morning.
                        > >
                        > > Check to see if your motherboard has a BIOS setting which
                        > > plays a part in this.
                        > >
                        > > > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...>
                        >
                        > wrote:
                        > > >>Jefferson Smith wrote:
                        > > >>>Computer was off at the time. You're right about xntp. It happened
                        > > >>>again, the next time I left it off overnight. Sounds like the battery
                        > > >>>or hardware at least, but I haven't verified it. Sounds like xntp
                        > > >>>would avoid the need for the hardware keeping time between boots (?)
                        > > >>>       Thanks,   --jeffs
                        > > >>
                        > > >>Here's a working /etc/ntp.conf file
                        > > >>I have 12 level-2 servers and 1 level-3 server
                        > > >>
                        > > >>Make sure you read through it.
                        > > >># comments ending in (ark) were inserted by me.
                        > > >>Notice that I specify some log files to be in /var/log/ntp
                        > > >>
                        > > >>You'll want to either edit that, or do this
                        > > >>
                        > > >>$ su
                        > > >>password:
                        > > >># mkdir /var/log/ntp
                        > > >># exit
                        > > >>$
                        > > >>
                        > > >>
                        > > >>  < sample /etc/ntp.conf file snipped>
                        >
                        > Yahoo! Groups Sponsor
                        >
                        >
                        >
                        > ADVERTISEMENT
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                        > Yahoo! Groups Links
                        >
                        > To visit your group on the web, go to:
                        > http://groups.yahoo.com/group/suselinuxusers/
                        >  
                        > To unsubscribe from this group, send an email to:
                        > suselinuxusers-unsubscribe@yahoogroups.com
                        >  
                        > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
                      • Aaron Kulkis
                        ... No... not timezones. Localtime vs. GMT time
                        Message 11 of 15 , Nov 7, 2004
                          Jefferson Smith wrote:
                          >
                          > I can't think of any settings in BIOS pertaining to which time zone.
                          > Any keywords to look for? Why would BIOS care which timezone the clock
                          > is set for? --jeffs

                          No... not timezones.
                          Localtime vs. GMT time

                          >
                          > P.S. True nobody should have to reload Linux. It may be easy to say
                          > "change the settings and get on with life", but what settings?
                          >
                          >
                          > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...> wrote:
                          >
                          >>Jefferson Smith wrote:
                          >>
                          >>>Alright, I got the ntp updates going, here's the log from this
                          >
                          > morning:
                          >
                          >>> 5 Nov 07:33:56 ntpd[5447]: synchronized to LOCAL(0), stratum 10
                          >>> 5 Nov 07:33:56 ntpd[5447]: kernel time sync disabled 0041
                          >>> 5 Nov 07:34:59 ntpd[5447]: kernel time sync enabled 0001
                          >>>
                          >>>Now, a strange thing I found. I want to know if I just don't have
                          >>>things configured right, or what. In the dialog "Adjust Date &
                          >>>Time..." from the Clock menu (in the corner of the taskbar), I had
                          >>>changed the setting to store time in UTC. This seems to not work
                          >>>right. It shows alright until I start the computer the next day, Then
                          >>>I think it is displaying UTC on the clock instead of the time zone I
                          >>>have selected. This happened before and after I enabled the ntp
                          >>>client. I changed back to set hwclock as local time, and it comes up
                          >>>correct in the morning.
                          >>
                          >>Check to see if your motherboard has a BIOS setting which
                          >>plays a part in this.
                          >>
                          >>
                          >>
                          >>>
                          >>>--- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...>
                          >
                          > wrote:
                          >
                          >>>>Jefferson Smith wrote:
                          >>>>
                          >>>>
                          >>>>>Computer was off at the time. You're right about xntp. It happened
                          >>>>>again, the next time I left it off overnight. Sounds like the battery
                          >>>>>or hardware at least, but I haven't verified it. Sounds like xntp
                          >>>>>would avoid the need for the hardware keeping time between boots (?)
                          >>>>> Thanks, --jeffs
                          >>>>
                          >>>>Here's a working /etc/ntp.conf file
                          >>>>I have 12 level-2 servers and 1 level-3 server
                          >>>>
                          >>>>Make sure you read through it.
                          >>>># comments ending in (ark) were inserted by me.
                          >>>>Notice that I specify some log files to be in /var/log/ntp
                          >>>>
                          >>>>You'll want to either edit that, or do this
                          >>>>
                          >>>>$ su
                          >>>>password:
                          >>>># mkdir /var/log/ntp
                          >>>># exit
                          >>>>$
                          >>>>
                          >>>>
                          >>>> < sample /etc/ntp.conf file snipped>
                          >
                          >
                          >
                          >
                          >
                          >
                          >
                          >
                          > Yahoo! Groups Links
                          >
                          >
                          >
                          >
                          >
                          >
                          >
                          >
                        • Jefferson Smith
                          ... zone. ... clock ... Go on, I m listening... and the difference would be...
                          Message 12 of 15 , Nov 8, 2004
                            --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...>
                            wrote:
                            > Jefferson Smith wrote:
                            > >
                            > > I can't think of any settings in BIOS pertaining to which time
                            zone.
                            > > Any keywords to look for? Why would BIOS care which timezone the
                            clock
                            > > is set for? --jeffs
                            >
                            > No... not timezones.
                            > Localtime vs. GMT time

                            Go on, I'm listening... and the difference would be...
                          • Aaron Kulkis
                            ... As far as the BIOS... I m not sure. It s just an idea.
                            Message 13 of 15 , Nov 8, 2004
                              Jefferson Smith wrote:
                              >
                              > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...>
                              > wrote:
                              >
                              >>Jefferson Smith wrote:
                              >>
                              >>>I can't think of any settings in BIOS pertaining to which time
                              >
                              > zone.
                              >
                              >>>Any keywords to look for? Why would BIOS care which timezone the
                              >
                              > clock
                              >
                              >>>is set for? --jeffs
                              >>
                              >>No... not timezones.
                              >>Localtime vs. GMT time
                              >
                              >
                              > Go on, I'm listening... and the difference would be...
                              >

                              As far as the BIOS... I'm not sure. It's just an idea.
                            • Horror Vacui
                              On Mon, 08 Nov 2004 14:49:01 -0000 ... ...the value of your timezone. If your hardware clock is set to use GMT, then at this moment it has the same time my
                              Message 14 of 15 , Nov 8, 2004
                                On Mon, 08 Nov 2004 14:49:01 -0000
                                Jefferson wrote:

                                >
                                > --- In suselinuxusers@yahoogroups.com, Aaron Kulkis <akulkis@H...>
                                > wrote:
                                > > Jefferson Smith wrote:
                                > > >
                                > > > I can't think of any settings in BIOS pertaining to which time
                                > zone.
                                > > > Any keywords to look for? Why would BIOS care which timezone the
                                > clock
                                > > > is set for? --jeffs
                                > >
                                > > No... not timezones.
                                > > Localtime vs. GMT time
                                >
                                > Go on, I'm listening... and the difference would be...

                                ...the value of your timezone. If your hardware clock is set to use GMT,
                                then at this moment it has the same time my hardware clock has. But I'm
                                on CET, meaning +01, so I'm one hour ahead when I get my time from the
                                system. You're probably elsewhere, and you'll get something different.

                                Problems arise when people use this kind of config on dual-boot systems
                                with Windows (I also have a dual-boot, but Linux & FreeBSD :) ). Windows
                                always stores the local time in the hardware clock. In my timezone, a
                                user would set the time to his local time, that value (localtime - ($TZ
                                = 1)) = GMT, goes to the hardware clock. The user then reboots, and
                                Windows shows a time 1hr behind. The user then sets the time in windows,
                                reboots, and sees ( hwclock + ($TZ = 1)), time one hour ahead in Linux.
                                The solution is to let Linux also use local time on hwclock, which is
                                achieved simply by not setting a timezone.

                                You set your timezone by declaring an environment variable $TZ. Here's
                                the line that does this for me, in my /etc/profile:

                                TZ='CET'; export TZ

                                Replace CET with your timezone, of course.

                                Cheers

                                --
                                Horror Vacui

                                Registered Linux user #257714

                                Go get yourself... counted: http://counter.li.org/
                                - and keep following the GNU.
                              • Jefferson Smith
                                Horror, I think you gave a good explanation of why there is not a BIOS setting having to do with timezone settings. It is handled by OS. There is no reason why
                                Message 15 of 15 , Nov 9, 2004
                                  Horror, I think you gave a good explanation of why there is not a BIOS
                                  setting having to do with timezone settings. It is handled by OS.
                                  There is no reason why the BIOS could or should care what timezone it
                                  is in. BTW I am in MST (-7).

                                  Here is what I did that is working now: I used yast2 to go to the
                                  module to change the timezone and time. I also did it in two steps.
                                  First change to store in UTC, apply settings, then go back and set
                                  current time. When it didn't work, I had been right-clicking on the
                                  clock to open the module for setting time. The whole problem is that I
                                  can't say now what actually made it work this time.

                                  My theory is that when I chose to set the time, it changed some
                                  configuration to remember it is stored in UTC, but missed something.
                                  When I rebooted, the missed configuration told it that the hwclock was
                                  in local time, and set the system clock incorrectly.


                                  --- In suselinuxusers@yahoogroups.com, Horror Vacui <horrorvacui@g...>
                                  wrote:
                                  > On Mon, 08 Nov 2004 14:49:01 -0000
                                  > Jefferson wrote:
                                  >
                                  ...
                                  > >
                                  > > Go on, I'm listening... and the difference would be...
                                  >

                                  > ...the value of your timezone. If your hardware clock is set to use GMT,
                                  > then at this moment it has the same time my hardware clock has. But I'm
                                  > on CET, meaning +01, so I'm one hour ahead when I get my time from the
                                  > system. You're probably elsewhere, and you'll get something different.
                                  >
                                  > Problems arise when people use this kind of config on dual-boot systems
                                  > with Windows (I also have a dual-boot, but Linux & FreeBSD :) ). Windows
                                  > always stores the local time in the hardware clock. In my timezone, a
                                  > user would set the time to his local time, that value (localtime - ($TZ
                                  > = 1)) = GMT, goes to the hardware clock. The user then reboots, and
                                  > Windows shows a time 1hr behind. The user then sets the time in windows,
                                  > reboots, and sees ( hwclock + ($TZ = 1)), time one hour ahead in Linux.
                                  > The solution is to let Linux also use local time on hwclock, which is
                                  > achieved simply by not setting a timezone.
                                  >
                                  > You set your timezone by declaring an environment variable $TZ. Here's
                                  > the line that does this for me, in my /etc/profile:
                                  >
                                  > TZ='CET'; export TZ
                                  >
                                  > Replace CET with your timezone, of course.
                                  >
                                  > Cheers
                                  >
                                  > --
                                  > Horror Vacui
                                  >
                                  > Registered Linux user #257714
                                  >
                                  > Go get yourself... counted: http://counter.li.org/
                                  > - and keep following the GNU.
                                Your message has been successfully submitted and would be delivered to recipients shortly.