Loading ...
Sorry, an error occurred while loading the content.
 

Re: 2 SAMBA Questions

Expand Messages
  • verdain1121
    ... online ... and ... RUNLEVEL=5 ... I ... S14smb ... am ... in ... get ... Bob: Wow, you re out front of me on rc editor . Is that the same as Runlevel
    Message 1 of 6 , Jan 30, 2003
      --- In suselinuxusers@yahoogroups.com, "bob hunchberger
      <sftwengnr@y...>" <sftwengnr@y...> wrote:
      > Wow, I can hardly believe what I am seeing. Someone who actually
      > figured samba out for SuSE 8.1. Congrats. I recently did an
      online
      > install of 8.1 over top of my 7.3 which had a working samba
      > installation. Life was good. Now with 8.1 only smbd starts at
      > boot. Even going into the rc editor and setting nmbd to levels 3
      and
      > 5 does not start it. I am running samba in a classic installation.
      >
      > Here is what my boot log says about samba.
      >
      > <notice>/etc/init.d/rc5.d/S14smb start
      > Samba SMB: Needed classic NMB service not running. You should start
      > it with
      >
      > Samba SMB: rcnmb start
      >
      > Starting Samba classic SMB daemon<notice>startproc: execve
      > (/usr/lib/samba/classic/smbd) [ /usr/lib/samba/classic/smbd -D ], [
      > CONSOLE=/dev/console TERM=linux SHELL=/bin/sh TMPDIR=/var/tmp
      > INIT_VERSION=sysvinit-2.82 REDIRECT=/dev/tty1 COLUMNS=80
      > PATH=/usr/local/sbin:/sbin:/bin:/usr/sbin:/usr/bin vga=785
      RUNLEVEL=5
      > PWD=/
      > PREVLEVEL=S LINES=30 HOME=/ SHLVL=2 _=/sbin/startproc
      > DAEMON=/usr/lib/samba/classic/smbd ]
      >
      > Unfortunately, they do not say what file to put the rcmb in. When
      I
      > try to run rcnmb start manually it still does not show nmbd running
      > when I do a ps.
      >
      > In my 8.1 the S14smb starts samba and it is in /etc/init.d/rc5.d
      > while rcnmb is in /usr/sbin. I checked out all my symbols in
      S14smb
      > and they all point to the correct directories including
      > the /usr/lib/samba/classic directory containing the daemons. So I
      am
      > puzzled as to why nmbd will not start. There is even a reference
      in
      > the S14smb to the nmbd but I wonder if it is not written correctly.
      >
      > Perhaps if you could show me the lines in the scripts you used to
      get
      > it to start at boot I could get up and going.
      >
      > Thanks
      >
      > Bob H.
      ----------------------------------------------------------------------
      Bob:

      Wow, you're out front of me on "rc editor". Is that the same
      as "Runlevel editor"? If so, you're still ahead of me. I just found
      that after seeing you mention it. I thought "what the heck is
      that?". I'm really a novice here myself, believe me. Looks like
      that's a tool I need to investigate. What I did instead was just go
      into the /etc/init.d/rc5.d directory and manually add entries (links)
      using the native linux/unix ln command (if you're thinking "wow, this
      guy must be some sort of unix guru", WRONG!! I just followed what I
      read out of a Linux manual and was lucky enough that it worked and
      didn't hose me!). Anyway, what I did was create a link called
      S10nmbd to /usr/sbin/rcnmb and a link called S10smbd
      to /usr/sbin/rcsmb. I was counting on them running in alphabetical
      order (rcnmb before rcsmb) because I had earlier gotten that same
      message you got about smbd needing nmbd. Sure enough, nmbd ran
      first, then smbd. I also think it's important to use rcnmb instead
      of nmbd and rcsmb instead of smbd. I inadvertently set the above
      links up to use nmbd/smbd instead of rcnmb/rcsmb the first time
      around and it didn't seem to work right (but I can't swear to that).
      The way it is now (with rcnmb/rcsmb), I can see in "View start-up
      log" that smbd seems to be checking to make sure that nmbd (or
      something) is finished running before it tries starting (or at least
      it's waiting for something to be kosher before it starts). What I
      see in the log is the following --

      SAMBA SMB: Waiting for cupsd to get ready

      then there's a bunch of .,......'s

      then I see

      Starting Samba classic SMB dameon ...

      Anyway, not sure if this is the sort of help you were looking for
      (maybe there's an easier way to do it) but that's how I got it going.

      Regarding my other problem, not being able to get a Windows
      directory automatically mounted on my Linux machine at start-up via
      SMBFS, I've hacked my way through to a certain point and at least
      found out what part of the problem is. The smbfs script you get with
      the "samba-client" has a bug in it! It reads through a file
      called /etc/samba/smbfstab and (supposedly) attaches any of those
      remote network/Windows directories to whatever mount point you
      specify on your Linux machine. Well, as it turns out, the script
      (/etc/init.d/smbfs) ignores the last line in /etc/samba/smbfstab (a
      bug in the smbfs script it would seem)! After adding a trace to that
      script and spending hours trying to figure out what was going on, I
      finally discovered the problem. The easy fix is to just add a
      comment (*....) line at the bottom of /etc/samba/smbfstab so that it
      actually processes the line above it (the actual line you enter that
      says what to mount). Pretty hokey!! Now that I've figured that out,
      all would be well and good if not for one other little problem. I'm
      trying to link to a shared file that has a name with an embedded
      blank in it! My question for you is, if you have a script construct
      such as

      read var1, var2; do
      .
      .
      .
      done < file

      and (say) var1 in your file has an embedded blank, can you do
      something in the file so that it will treat the string with the blank
      as one variable (i. e., var1)? I tried putting both single and
      double quotes around it and neither worked. I would like to just
      change the name of the file on the windows machine and eliminate the
      blank, but it's a purchased product and I can't change the file
      name! My only options are to do something in the smbfstab file to
      make it treat the string with the blank as a single variable or
      modify the Linux supplied smbfs script. I really hate to do the
      latter, if you know what I mean. Any suggestions?

      Thanks,
      Greg W
    Your message has been successfully submitted and would be delivered to recipients shortly.