Loading ...
Sorry, an error occurred while loading the content.

2993Re: [solectria_ev] Battery charger

Expand Messages
  • Joshua Goldstein
    Aug 1, 2007
    • 0 Attachment
      Azure Dynamics (Solectria) did fix my charger - yay. It took 25 days
      and cost $450 but they diagnosed a blown capacitor, replaced it, and
      tested the charger. They charge by the hour. Since Scott is new to this
      since Kevin left Solectria, it's possible fewer hours would be needed in
      the future for an equivalent repair.
      Again, Scott Parisi at Azure is at 781-932-9009, x285
      The other guy, Bruce Gowan at electronic-orphanage.com in New
      Hampshire, is 603-627-9885. He says he may be able to fix dead Brusas
      but I haven't tried him.
      Joshua Goldstein

      > Let us know how things turn out on getting your brusa repaired. I think there are alot of dead brusa chargers sitting around collecting dust. Mike young

      > ----- Original Message -----
      > From: Joshua Goldstein
      > To: solectria_ev@yahoogroups.com
      > Sent: Monday, July 30, 2007 6:24 PM
      > Subject: Re: [solectria_ev] Battery charger
      > Eric,
      > I recently had a fuse on the circuit board of my single (Brusa 412b)
      > charger blow repeatedly. It may be a different charger than yours. I
      > brought it to Scott Parisi, Kevin's replacement at Azure Dynamics
      > (Solectria), 781-932-9009, and he diagnosed that a capacitor had blown
      > up. (He thinks he can fix it but hasn't yet after several weeks.) If
      > they can't fix it, I will probably try a guy in New Hampshire
      > (Bruce@...) who says he may be able to fix these
      > chargers -- he's worked on Solectria Forces before. I'm not sure the
      > propriety of posting their contact info to the group so I apologize if
      > that was an error but these are the two places I know of that might be
      > able to fix the circuit boards on these chargers, so many of us might
      > need it someday. Hopefully there are other resources out there as well
      > which I'd like to know about.
      > Joshua
      > ehsif727 wrote:
      > > I have a 1996 Force with two 1000u chargers the one on the drivers
      > > side of the car works fine but the other one doesn't work. I took the
      > > unit out and took the cover off of it and found a fuse on a circuit
      > > board that was blown so I replaced it and reinstalled but that fuse
      > > blew to. If any one might have had this problem let me know also if
      > > any body has any of these old charges for sale let me know.
      > >
      > > Eric Fisher
      > >
      > >
    • Show all 5 messages in this topic