Loading ...
Sorry, an error occurred while loading the content.

Re: Thumb button on USB Logitech wheel mouse

Expand Messages
  • Juergen Keil
    ... of 6 ... Your X server s mouse module seems to be reporting only 3 physical buttons, like this: % xmodmap -pp There are 3 pointer buttons defined. Physical
    Message 1 of 5 , Jul 19, 2004
    • 0 Attachment
      --- In solarisx86@yahoogroups.com, Cyril Plisko <cyril.plisko@c...> wrote:
      > Juergen Keil wrote:
      > > --- In solarisx86@yahoogroups.com, Cyril Plisko
      <cyril.plisko@c...> wrote:

      > > Then use xmodmap to create a pointer button map, to shuffle around the
      > > the buttons, so that the thumb button 4 is remapped to button 6, and
      > > the scroll button events 5 & 6 get remapped to buttons 4 & 5 (4 & 5
      > > are the buttons most X11 applications expect for mouse wheel scroll
      > > events):
      > >
      > > xmodmap -e "pointer = 1 2 3 6 4 5"'
      > >
      > >
      >
      > $ xmodmap -e "pointer = 1 2 3 6 4 5"
      > xmodmap: commandline:1: bad number of buttons, must have 3 instead
      of 6
      > xmodmap: 1 error encountered, aborting.
      > $
      >
      >
      > Bummer...


      Your X server's mouse module seems to be reporting only 3 physical
      buttons, like this:

      % xmodmap -pp
      There are 3 pointer buttons defined.

      Physical Button
      Button Code
      1 1
      2 2
      3 3
      %

      Is there a

      buttons="3"

      setting in the /etc/openwin/server/etc/OWconfig file? Try to change
      that to buttons="6", then restart the X server. xmodmap -pp should
      report 6 pointer buttons.
    • Cyril Plisko
      ... You were quite right. That did the trick. Thanks a lot. Cyril
      Message 2 of 5 , Jul 19, 2004
      • 0 Attachment
        Juergen Keil wrote:
        >
        >
        > Your X server's mouse module seems to be reporting only 3 physical
        > buttons, like this:
        >
        > % xmodmap -pp
        > There are 3 pointer buttons defined.
        >
        > Physical Button
        > Button Code
        > 1 1
        > 2 2
        > 3 3
        > %
        >
        > Is there a
        >
        > buttons="3"
        >
        > setting in the /etc/openwin/server/etc/OWconfig file? Try to change
        > that to buttons="6", then restart the X server. xmodmap -pp should
        > report 6 pointer buttons.
        >
        >

        You were quite right. That did the trick.
        Thanks a lot.

        Cyril


        >
        >
        >
        >
        > Please check the Links page before posting:
        > http://groups.yahoo.com/group/solarisx86/links
        > Post message: solarisx86@yahoogroups.com
        > UNSUBSCRIBE: solarisx86-unsubscribe@yahoogroups.com
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.