Loading ...
Sorry, an error occurred while loading the content.

PowerSDR IF with K3 issues

Expand Messages
  • n4nrwham
    I have a Softrock lite Rx for the 8.215 MhZ K3 IF, Clifton Labs Z010000B Isolation buffer, Creative X-Fi soundcard (96 kHz sampling). When setting up the
    Message 1 of 4 , Jul 29, 2014
    • 0 Attachment
      I have a Softrock lite Rx for the 8.215 MhZ K3 IF, Clifton Labs Z010000B Isolation buffer, Creative X-Fi soundcard (96 kHz sampling).  When setting up the PowerSDR IF software  I have to input offsets for USB/LSB/AM etc., set Swap I/Q starting at 0Hz to get the display to track in the correct direction and line up with the actual frequency display.  I thought when using PowerSDR IF with a K3 all that is needed is to enter the LO freq of the softrock Rx. (mine is actually 8.1914 Mhz)  Also, when I change to my narrow SSB filter the signals on the panadaptor display shift approx 1 - 2 kHz on the screen and are no longer in line with the display frequency.  Something just does not seem right.  I have tried blowing away the program and reloading and same results.  Anyone else seen this?  It still displays fine and tracks etc just shifts the display when the narrow filter is selected.  I am CAT controlling via an RS232 connection.  control seems to work both ways to the K3 and to the PowerSDR IF.  It just seems like the shifts for USB/LSB/AM and filters are not being communicated to PowerSDR IF?

      Thanks for any help.
      Rodger
      N4NRW


    • Alan
      Original Message ----- Subject: [softrock40] PowerSDR IF with K3 issues ... Rodger, I ve never tried this with PSDR and I do not have a K3...... If it is only
      Message 2 of 4 , Jul 30, 2014
      • 0 Attachment
        Original Message -----
        Subject: [softrock40] PowerSDR IF with K3 issues


        >I have a Softrock lite Rx for the 8.215 MhZ K3 IF, Clifton Labs Z010000B Isolation buffer, Creative X-Fi soundcard (96 kHz
        >sampling). When setting up the PowerSDR IF software I have to input offsets for USB/LSB/AM etc., set Swap I/Q starting at 0Hz to
        >get the display to track in the correct direction and line up with the actual frequency display. I thought when using PowerSDR IF
        >with a K3 all that is needed is to enter the LO freq of the softrock Rx. (mine is actually 8.1914 Mhz) Also, when I change to my
        >narrow SSB filter the signals on the panadaptor display shift approx 1 - 2 kHz on the screen and are no longer in line with the
        >display frequency. Something just does not seem right. I have tried blowing away the program and reloading and same results.
        >Anyone else seen this? It still displays fine and tracks etc just shifts the display when the narrow filter is selected. I am CAT
        >controlling via an RS232 connection. control seems to work both ways to the K3 and to the PowerSDR IF. It just seems like the
        >shifts for USB/LSB/AM and filters are not being communicated to PowerSDR IF?
        >

        Rodger,

        I've never tried this with PSDR and I do not have a K3......

        If it is only wrong on the narrow filter then maybe that has a different offset. Is there another offset setting? Maybe it's not
        compatible?

        73 Alan G4ZFQ
      • n4nrwham
        From reading the info on WU2X website (PowerSDR IF) when using PowerSDR IF with a K3 and CAT control all that is required is to enter the LO freq. of your
        Message 3 of 4 , Jul 31, 2014
        • 0 Attachment

          From reading the info on WU2X website (PowerSDR IF) when using PowerSDR IF with a K3 and CAT control all that is required is to enter the LO freq. of your Softrock.  The K3 is supposed to communicate via the CAT, all information regarding IF shifts for USB/LSB/AM/CW etc.  As well as track the filter width changes as they are selected. You are told not to enter any offsets, leave them all 0. This just does not seem to be working correctly.  As I indicated I have had to manually enter the offsets for USB/LSB/AM etc to get the displayed frequency Center line of the PowerSDR IF to agree with the dial frequencies of the K3.  Doing this, it still works fine except for the display shift when a narrow filter is used.


          Maybe someone else with this type of set up can straighten me out?  Thanks for your reply.


          Rodger

          N4NRW

        • Alan
          Original Message ----- Subject: Re: [softrock40] PowerSDR IF with K3 issues ... Rodger Then your problem has nothing to do with K3 RX Filter Width Syncing on
          Message 4 of 4 , Jul 31, 2014
          • 0 Attachment
            Original Message -----
            Subject: Re: [softrock40] PowerSDR IF with K3 issues


            > From reading the info on WU2X website (PowerSDR IF) when using PowerSDR IF with a K3 and CAT control all that is required is to
            > enter the LO freq. of your Softrock. The K3 is supposed to communicate via the CAT, all information regarding IF shifts for
            > USB/LSB/AM/CW etc. As well as track the filter width changes as they are selected. You are told not to enter any offsets, leave
            > them all 0. This just does not seem to be working correctly. As I indicated I have had to manually enter the offsets for
            > USB/LSB/AM etc to get the displayed frequency Center line of the PowerSDR IF to agree with the dial frequencies of the K3. Doing
            > this, it still works fine except for the display shift when a narrow filter is used.
            >
            >

            Rodger

            Then your problem has nothing to do with "K3 RX Filter Width Syncing" on that page?
            This seems somewhat confusing to me, but seems to describe what you say?

            73 Alan G4ZFQ
          Your message has been successfully submitted and would be delivered to recipients shortly.