Loading ...
Sorry, an error occurred while loading the content.

TF3LJ and Atmega168 Firmware

Expand Messages
  • yt1dl
    Hello, I just built TF3LJ/PE0FKO port for ATmega168 and put 1.03 firmware on it. Now I have one problem that I can not solve it. Every time I connect USB to my
    Message 1 of 3 , Sep 22, 2013
    • 0 Attachment
      Hello,

      I just built TF3LJ/PE0FKO port for ATmega168 and put 1.03 firmware on it. Now I have one problem that I can not solve it. Every time I connect USB to my computer I have "device not recognized " error. I try on two different PCs with Windows XP and Windows 7. Debug LED flashes about 3-4 Hz. Fuses programmed like on Arduino. I check a USB cable and D-/D+ position. QRP2000 with ATtiny85 works fine at same computers.

      Any help?

      vy 73 de YT1DL, Dusan
    • jbforrer
      Dusan, ... a few pointers that may get you sorted out. I am using an ATmega328P instead of the ATTiny85 to control my Si570 and assume you will have to follow
      Message 2 of 3 , Sep 23, 2013
      • 0 Attachment

        Dusan,


         ... a few pointers that may get you sorted out. 


        I am using an ATmega328P instead of the ATTiny85 to control my Si570 and assume you will have to follow similar steps to get it to work on the 168.


        1). When you switch from the 8-pin ATTiny to the 28-pin ATMega family,  check whether you connected INT0 pin on ATMega (pin 4 -- ATMega). It won't work otherwise. This fact is often overlooked in Si570-controller documentation but you will find it described in other V-USB and USBasp projects.


        For PE0FKO & DG8SAQ firmware on ATTiny85, USB is connected to PB0/PB2. The firmware needs to fire an interrupt coming in on USB, thus INT0 and PB2 must also be connected on ATMega.


        2). I used the last-released firmware from PE0FKO ... V15.15.


        3). Make sure fuses are up correctly.


        It took me some effort to get it to work but it does work on XP. However, in my case, the XP driver reported XP Device Manager happen to be "USBasp" ... seem to work fine with that.


        Good Luck!

        Johan, KC7WW.




        --- In softrock40@yahoogroups.com, <softrock40@yahoogroups.com> wrote:

        Hello,

        I just built TF3LJ/PE0FKO port for ATmega168 and put 1.03 firmware on it. Now I have one problem that I can not solve it. Every time I connect USB to my computer I have "device not recognized " error. I try on two different PCs with Windows XP and Windows 7. Debug LED flashes about 3-4 Hz. Fuses programmed like on Arduino. I check a USB cable and D-/D+ position. QRP2000 with ATtiny85 works fine at same computers.

        Any help?

        vy 73 de YT1DL, Dusan
      • Dusan Milovanovic
        Hello Johan, I will try this evening and will report here. Thank you for help. VY 73 DE DUŠAN, YT1DL Sent from Yahoo! Mail on Android Hello Johan, I will try
        Message 3 of 3 , Sep 24, 2013
        • 0 Attachment

          Hello Johan,

          I will try this evening and will report here. Thank you for help.

          VY 73 DE DUŠAN, YT1DL

          Sent from Yahoo! Mail on Android



          From: jbforrer@... <jbforrer@...>;
          To: <softrock40@yahoogroups.com>;
          Subject: [softrock40] RE: TF3LJ and Atmega168 Firmware
          Sent: Mon, Sep 23, 2013 9:46:12 PM

           

          Dusan,


           ... a few pointers that may get you sorted out. 


          I am using an ATmega328P instead of the ATTiny85 to control my Si570 and assume you will have to follow similar steps to get it to work on the 168.


          1). When you switch from the 8-pin ATTiny to the 28-pin ATMega family,  check whether you connected INT0 pin on ATMega (pin 4 -- ATMega). It won't work otherwise. This fact is often overlooked in Si570-controller documentation but you will find it described in other V-USB and USBasp projects.


          For PE0FKO & DG8SAQ firmware on ATTiny85, USB is connected to PB0/PB2. The firmware needs to fire an interrupt coming in on USB, thus INT0 and PB2 must also be connected on ATMega.


          2). I used the last-released firmware from PE0FKO ... V15.15.


          3). Make sure fuses are up correctly.


          It took me some effort to get it to work but it does work on XP. However, in my case, the XP driver reported XP Device Manager happen to be "USBasp" ... seem to work fine with that.


          Good Luck!

          Johan, KC7WW.




          --- In softrock40@yahoogroups.com, <softrock40@yahoogroups.com> wrote:

          Hello,

          I just built TF3LJ/PE0FKO port for ATmega168 and put 1.03 firmware on it. Now I have one problem that I can not solve it. Every time I connect USB to my computer I have "device not recognized " error. I try on two different PCs with Windows XP and Windows 7. Debug LED flashes about 3-4 Hz. Fuses programmed like on Arduino. I check a USB cable and D-/D+ position. QRP2000 with ATtiny85 works fine at same computers.

          Any help?

          vy 73 de YT1DL, Dusan
        Your message has been successfully submitted and would be delivered to recipients shortly.