Loading ...
Sorry, an error occurred while loading the content.

Re: [softrock40] Re: Softrock + opensuse 12.3 linux

Expand Messages
  • Sid Boyce
    Hi Chris, that card should work. Please post the results of these 2 commands cat /proc/asound/cards lsmod|grep snd which show these 3 modules loaded
    Message 1 of 14 , Aug 23, 2013
    • 0 Attachment
      Hi Chris, that card should work.
      Please post the results of these 2 commands
      "cat /proc/asound/cards"

      "lsmod|grep snd" which show these 3 modules loaded
      73 ... Sid.

      On 23/08/13 08:31, kf5jmd@... wrote:

      Thanks Sid for the great help. I got it working with WebSDR on my local network and have been playing with that for now, which is why I have the Lite II receivers, I plan on eventually putting 4 of them online for the WWW. So getting it to work with a "local" client is not that big of a deal for now anyway, I build them, then test them on my XP machine with HDSDR. Eventually going to get the other 2 built (2 built so far, 20M,40M) and put them all in one box and get the WebSDR running with all 4. I have a RX Ensemble II HF version that I use on my XP machine, works great, will order another to build for LF soon too.

      I AM having some problems with the sound drivers. The onboard is Realtek ALC662, and I do have it working, but it's noisy (seems alot noisier than my XP machine with ALC882). Will post up or contact you directly (since it's linux) once I get more into messing with the sound drivers. Looking to get 2 192K cards, like Xonar DS or DX/DS combo for this linux machine.

      The WebSDR on my local network is nice because I can monitor 4 bands at one time, and not worry about Internet usage using other peoples servers, and I don't think there is another one in TX, I will be the only one in Texas once it finally goes live.

      Thanks again,


      --- In softrock40@yahoogroups.com, Sid Boyce <sboyce@...> wrote:
      > Comments embedded.
      > On 22/08/13 04:30, kf5jmd@... wrote:
      > >
      > > Ok, so I have working lite II receiver, works fine under Windows.
      > > Tried to hook it up to a brand new install opensuse 12.3 linux
      > > machine, can't find any SDR software that works.
      > >
      > > 1. GHPSDR pops up a window that says cannot locate Ozy. I have no idea
      > > what Ozy is.
      > >
      > May be you are using John Melton's ghpsdr or ghpsdr3, you need ghpsdr3-alex
      > http://napan.ca/ghpsdr3/index.php/Main_Page
      > This supplies many servers for many SDR's including the "softrock"
      > server - talks to the SDR.
      > "dspserver" which puts the server on the internet.
      > "QtRadio" is the client that can connect locally to or across
      > your LAN to the IP address running dspserver or across the internet
      > using QtRadio or glHPSDR running on an Android phone or tablet.
      > You can see who and what's currently online by going to
      > http://qtradio.napan.ca/qtradio/qtradio.pl
      > > 2. Quisk says Traceback (most recent call last):
      > > File "./quisk", line 3, in <module>
      > > import quisk # May be quisk.py or package quisk
      > > File "/home/cschmidt/software/quisk/quisk/quisk.py", line 34, in <module>
      > > import _quisk as QS
      > > ImportError: ./_quisk.so: wrong ELF class: ELFCLASS32
      > >
      > > My system is 64 bit, not sure if it will work at all...
      > >
      > The latest is quisk-3.6.12 at james.ahlstrom.name/quisk/
      > One exploded - "tar zxfv quisk-3.6.12.tar.gz"
      > "cd quisk-3.6.12" then run make.
      > Pre-reqs
      > -------------
      > sudo apt-get install libfftw3-dev libasound2-dev libportaudio2
      > portaudio19-dev libncurses5-dev libwxbase2.8-0 libwxgtk2.8-0
      > python-wxgtk2.8 python-wxversion libusb-dev python2.7-dev
      > In the softrock subdirectory
      > # ls /opt/quisk-3.6.12/softrock/
      > conf_fixed.py conf_rx_ensemble2.py conf_rx_tx_ensemble.py
      > hardware_usb_new.py hardware_usb.py
      > Use the "conf_rx_ensemble2.py" file as the template for your
      > ~/.quisk_conf.py file.
      > You may have to change the name_of _sound_play and name_of_sound_capt
      > designations in ~/.quisk_conf.py
      > e.g name_of_sound_capt = "hw:1" or in some cases "plughw:1" for
      > interfacing with the softrock as I-Q.
      > name_of_sound_play = "hw:0" or "plughw:0" for Mic/Speakers.
      > microphone_name = "hw:0" or "plughw:0"
      > name_of_mic_play = "hw:0" or "plughw:0" for Ensemble RXTX.
      > With everything in place execute "python quisk.py" and you are up and
      > running.
      > >
      > > 3. QTradio -- does this work? Cannot find it
      > >
      > QtRadio is part of ghpsdr3-alex, glHPSDR for Android phone/tablet is
      > available from Google Play Store.
      > >
      > > 4. GnuRadio Companion -- Installed, runs, but no idea how to work it,
      > > looks super complicated and/or a backend for some other program to
      > > use, not to be used directly with SDR as frontend/gui.
      > >
      > I don't think there is a softrock module in gnuradio and as far as I
      > know, no one has built one using gnuradio-companion. I have been trying
      > to get the HiQSDR module to run under gnuradio-3.6.5, it didn't work and
      > I haven't got back to looking at it.
      > May be when gnuradio 3.7 has stabilized I'll look at it again.
      > >
      > >
      > > Sorry for being so "dumb" on this subject, I am new to SDR, but had no
      > > problems getting Ensemble II to work under Windows XP, or the Lite II
      > > receivers, all work fine. I know plenty about Linux, but thought I'd
      > > ask this question before I spend hours reading crap and making my hair
      > > even more gray:
      > >
      > > The big question: Am I barking up the wrong tree? Do ANY of the
      > > popular software packages for the Softrock work under OpenSuse 12.3 or
      > > should I be trying an older version of Opensuse? I have install DVD's
      > > for 9, 10, and 11, as I have been using Opensuse for webserver duties
      > > for a long time now, years and years.
      > >
      > > I am spoiled to HDSDR in Windows, it just "works" and looks so nice.
      > > Would like something similar that will work under Linux (X86_64).
      > >
      > > Thanks in advance.
      > >
      > Not dumb at all, all the questions have been very reasonably put and
      > answerable.
      > I use openSUSE 13.1 Milestone 4 x86_64, Kubuntu x86_64 and Ubuntu ARM
      > all 13.04 and I have built and set up quisk on Mint for a friend to use
      > with his Ensemble RXTX.
      > ARM boxes here are Pandaboard, Beaglebone and ODROID-X - awaiting
      > delivery of the Parallela Supercomputer board to play SDR on.
      > openSUSE and I go all the way back to 6.0 and Ubuntu since maybe 8.10 or
      > 9.04, SLS (the first Linux distro), Slackware, RedHat, CentOS, Mint,
      > etc. ..... I've done most of them standalone or running on openSUSE
      > under VirtualBox.
      > If it's Linux I am happy with it and I would say the same about any of
      > the dozen or more OS's I have worked with in my time, though quite a few
      > expletives have aired when dealing with Solaris as part of the day job
      > before retirement and also with the Ultra SPARC5 and the Sun Enterprise
      > E4500 I have here at home.
      > IBM's z/OS, z/VM and their forerunners, Amdahl UTS (Unix on Mainframes)
      > were all as much fun as Linux is.
      > On Mainframes and SPARC, Linux appeared the same as Linux running on a PC.
      > 73 ... Sid.
      > >
      > >
      > >
      > --
      > Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
      > Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
      > Senior Staff Specialist, Cricket Coach
      > Microsoft Windows Free Zone - Linux used for all Computing Tasks

      Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
      Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
      Senior Staff Specialist, Cricket Coach
      Microsoft Windows Free Zone - Linux used for all Computing Tasks
    Your message has been successfully submitted and would be delivered to recipients shortly.