Loading ...
Sorry, an error occurred while loading the content.

RXTX: Unable to change frequency - everything else seems to be working

Expand Messages
  • Phil Frost
    I recently built the Ensemble RXTX, and everything appeared to be working. Then quite mysteriously, I lost the ability to change frequency. I can still enable
    Message 1 of 3 , Mar 25, 2013
    • 0 Attachment
      I recently built the Ensemble RXTX, and everything appeared to be
      working. Then quite mysteriously, I lost the ability to change
      frequency. I can still enable transmit, and the oscillator must be
      oscillating because I can still receive signals. Just can't change
      frequency. On Linux, usbsoftrock status says:

      Version : 15.12
      USB SerialID: PE0FKO-0
      Startup Freq: 7.050000 (x 4.00)
      Xtall Freq : 114.285000
      Smooth Tune : 3500 PPM
      Si570 I2C : 55 Hex
      BPF Enabled: 0

      usbsoftrock getfreq prints just:

      Version : 15.12

      Normally, it would print that, and also the current frequency.

      To rule out software issues, I also tried on my OS X laptop, which had
      worked in the past. The softrock app there draws little green checkmarks
      on icons representing the AVR and Si570, but also can't change
      frequency. It says in the lower-left corner of the window, "debugging",
      but I don't know if this is normal or if not, what to do about it.

      I put a scope on pin 2 of the AVR, and it's 2.5V relative to the USB
      ground plane most of the time, with some excursions that are too fast to
      see on my analog scope near 0V and 5V. Not sure what's normal.

      Any ideas what could be wrong here? Is there a simpler way I can verify
      that the AVR and Si570 are communicating with Linux or Mac OS software?
    • Phil Frost
      ... Based on my best guess of what could be wrong, I re-worked pin 8 on the Si750 a second time and all seems good now. Touchy little bugger.
      Message 2 of 3 , Mar 25, 2013
      • 0 Attachment
        On 13-03-25 06:36 PM, Phil Frost wrote:
        > I recently built the Ensemble RXTX, and everything appeared to be
        > working. Then quite mysteriously, I lost the ability to change
        > frequency.

        Based on my best guess of what could be wrong, I re-worked pin 8 on the
        Si750 a second time and all seems good now. Touchy little bugger.
      • Alan
        ... Subject: [softrock40] RXTX: Unable to change frequency - everything else seems to be working ... Presumably they are not communicating. The usual fault is
        Message 3 of 3 , Mar 26, 2013
        • 0 Attachment
          ----- Original Message -----
          Subject: [softrock40] RXTX: Unable to change frequency - everything else seems to be working


          >I recently built the Ensemble RXTX, and everything appeared to be
          > working. Then quite mysteriously, I lost the ability to change
          > frequency.> Any ideas what could be wrong here? Is there a simpler way I can verify
          > that the AVR and Si570 are communicating with Linux or Mac OS software?
          >

          Presumably they are not communicating.
          The usual fault is bad joints, or too much solder on pins 7,8 of the Si570.
          And it is not unusual for someone to remake these several times before it gets done properly.

          73 Alan G4ZFQ
        Your message has been successfully submitted and would be delivered to recipients shortly.