Loading ...
Sorry, an error occurred while loading the content.

Re: WSPR, Softrock RXTX, snd Raspberry Pi

Expand Messages
  • vbifyz
    Your post finally made me to try it. I ve compiled WSPR from source following Dave s instructions. He now has updated instructions in his blog. It is now
    Message 1 of 12 , Jan 29, 2013
    • 0 Attachment
      Your post finally made me to try it.
      I've compiled WSPR from source following Dave's instructions. He now has updated instructions in his blog.
      It is now working with Ensemble II RX on 40m, you can query the database with my call sign, VE3YXA.
      I haven't tried controlling the frequency yet. At the moment it is controlled by CFGSR running on another computer. I need to connect a USB hub to try.
      My Pi is overclocked to 1GHz. CPU usage is about 20% when receiving, the decoding takes about 20sec. The soundcard is SD-AUD20101.
      I have an RXTX as well, trying the TX will be my next project.

      73, Mike

      --- In softrock40@yahoogroups.com, "William" wrote:
      >
      > I've searched google and found successful cases of WSPR being used on a Raspbery Pi(http://g4fre.blogspot.com/2012/11/wsjt-on-raspberry-pi.html)
      >
      > and I found successful cases of WSPR being used on a Softrock RXTX...ergo can it be done? Can you make a low power beacon station with a Raspberry Pi and a Softrock?
      >
      > Obviously have soundcard issues but can you use an external usb soundcard to achieve results?
      >
      > 73
      > Will
      > KB5USW
      >
    • William
      Mike, Glad to hear you got it to work! I ve been trying for the past several hours to get WSPR to compile and no luck. Headed to bed but will do a fresh
      Message 2 of 12 , Feb 2, 2013
      • 0 Attachment
        Mike,
        Glad to hear you got it to work! I've been trying for the past several hours to get WSPR to compile and no luck. Headed to bed but will do a fresh install of wheezy and try again this weekend. I saw the JAN 28 update to G4FRE's blog but still had errors. I also noticed that it caused my wifi usb dongle to stop working properly...did you run into any of these issues?

        73,
        Will

        --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@...> wrote:
        >
        > Your post finally made me to try it.
        > I've compiled WSPR from source following Dave's instructions. He now has updated instructions in his blog.
        > It is now working with Ensemble II RX on 40m, you can query the database with my call sign, VE3YXA.
        > I haven't tried controlling the frequency yet. At the moment it is controlled by CFGSR running on another computer. I need to connect a USB hub to try.
        > My Pi is overclocked to 1GHz. CPU usage is about 20% when receiving, the decoding takes about 20sec. The soundcard is SD-AUD20101.
        > I have an RXTX as well, trying the TX will be my next project.
        >
        > 73, Mike
        >
        > --- In softrock40@yahoogroups.com, "William" wrote:
        > >
        > > I've searched google and found successful cases of WSPR being used on a Raspbery Pi(http://g4fre.blogspot.com/2012/11/wsjt-on-raspberry-pi.html)
        > >
        > > and I found successful cases of WSPR being used on a Softrock RXTX...ergo can it be done? Can you make a low power beacon station with a Raspberry Pi and a Softrock?
        > >
        > > Obviously have soundcard issues but can you use an external usb soundcard to achieve results?
        > >
        > > 73
        > > Will
        > > KB5USW
        > >
        >
      • vbifyz
        No, my install went pretty well. I had a bunch of other packages installed before, so maybe Dave is missing something in his instructions. I am using wired
        Message 3 of 12 , Feb 2, 2013
        • 0 Attachment
          No, my install went pretty well. I had a bunch of other packages installed before, so maybe Dave is missing something in his instructions.
          I am using wired Ethernet. My peripherals are Syba sound dongle : http://www.sybausa.com/productInfo.php?iid=1191
          and some ancient wireless keyboard/mouse combo. RPi is 512MB version overclocked to 1GHz with 16GB Sandisk Ultra micro SD card.

          73, Mike

          --- In softrock40@yahoogroups.com, "William" wrote:
          >
          > Mike,
          > Glad to hear you got it to work! I've been trying for the past several hours to get WSPR to compile and no luck. Headed to bed but will do a fresh install of wheezy and try again this weekend. I saw the JAN 28 update to G4FRE's blog but still had errors. I also noticed that it caused my wifi usb dongle to stop working properly...did you run into any of these issues?
          >
          > 73,
          > Will
          >
          > --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@> wrote:
          > >
          > > Your post finally made me to try it.
          > > I've compiled WSPR from source following Dave's instructions. He now has updated instructions in his blog.
          > > It is now working with Ensemble II RX on 40m, you can query the database with my call sign, VE3YXA.
          > > I haven't tried controlling the frequency yet. At the moment it is controlled by CFGSR running on another computer. I need to connect a USB hub to try.
          > > My Pi is overclocked to 1GHz. CPU usage is about 20% when receiving, the decoding takes about 20sec. The soundcard is SD-AUD20101.
          > > I have an RXTX as well, trying the TX will be my next project.
          > >
          > > 73, Mike
          > >
          > > --- In softrock40@yahoogroups.com, "William" wrote:
          > > >
          > > > I've searched google and found successful cases of WSPR being used on a Raspbery Pi(http://g4fre.blogspot.com/2012/11/wsjt-on-raspberry-pi.html)
          > > >
          > > > and I found successful cases of WSPR being used on a Softrock RXTX...ergo can it be done? Can you make a low power beacon station with a Raspberry Pi and a Softrock?
          > > >
          > > > Obviously have soundcard issues but can you use an external usb soundcard to achieve results?
          > > >
          > > > 73
          > > > Will
          > > > KB5USW
          > > >
          > >
          >
        • William
          Finally got the install to run but haven t decoded any signals yet...I only overclocked to 900 MHZ and it seems to struggle with the decode, I get the follow
          Message 4 of 12 , Feb 3, 2013
          • 0 Attachment
            Finally got the install to run but haven't decoded any signals yet...I only overclocked to 900 MHZ and it seems to struggle with the decode, I get the follow message occasionally:

            <code> Attempted to start decode thread when already running</code>
            With my KX3 it appears that the RPi puts off alot of QRM, about 1-2 S units...I'm running it bare so that may add it to the RF.
            I ordered a Syba SD-CM-UAUD USB Stereo Audio Adapter, C-Media Chipset, RoHS, hopefully it will work better than the Signalink USB.
            --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@...> wrote:
            >
            > No, my install went pretty well. I had a bunch of other packages installed before, so maybe Dave is missing something in his instructions.
            > I am using wired Ethernet. My peripherals are Syba sound dongle : http://www.sybausa.com/productInfo.php?iid=1191
            > and some ancient wireless keyboard/mouse combo. RPi is 512MB version overclocked to 1GHz with 16GB Sandisk Ultra micro SD card.
            > > 73, Mike
            > > --- In softrock40@yahoogroups.com, "William" wrote:
            > >
            > > Mike,
            > > Glad to hear you got it to work! I've been trying for the past several hours to get WSPR to compile and no luck. Headed to bed but will do a fresh install of wheezy and try again this weekend. I saw the JAN 28 update to G4FRE's blog but still had errors. I also noticed that it caused my wifi usb dongle to stop working properly...did you run into any of these issues?
            > > > > 73,
            > > Will
            > > > > --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@> wrote:
            > > >
            > > > Your post finally made me to try it.
            > > > I've compiled WSPR from source following Dave's instructions. He now has updated instructions in his blog.
            > > > It is now working with Ensemble II RX on 40m, you can query the database with my call sign, VE3YXA.
            > > > I haven't tried controlling the frequency yet. At the moment it is controlled by CFGSR running on another computer. I need to connect a USB hub to try.
            > > > My Pi is overclocked to 1GHz. CPU usage is about 20% when receiving, the decoding takes about 20sec. The soundcard is SD-AUD20101.
            > > > I have an RXTX as well, trying the TX will be my next project.
            > > > > > > 73, Mike
            > > > > > > --- In softrock40@yahoogroups.com, "William" wrote:
            > > > >
            > > > > I've searched google and found successful cases of WSPR being used on a Raspbery Pi(http://g4fre.blogspot.com/2012/11/wsjt-on-raspberry-pi.html)
            > > > > > > > > and I found successful cases of WSPR being used on a Softrock RXTX...ergo can it be done? Can you make a low power beacon station with a Raspberry Pi and a Softrock? > > > > > > > > Obviously have soundcard issues but can you use an external usb soundcard to achieve results?
            > > > > > > > > 73
            > > > > Will
            > > > > KB5USW
            > > > >
            > > >
            > >
            >
          • MIKE DURKIN
            if it has the 1602 sound IC ... i would think so .... but also shielding the RaspberyPI would be a good thing. Mike KC7NOA To: softrock40@yahoogroups.com From:
            Message 5 of 12 , Feb 3, 2013
            • 0 Attachment
              if it has the 1602 sound IC ... i would think so .... but also shielding the RaspberyPI would be a good thing.

              Mike KC7NOA


              To: softrock40@yahoogroups.com
              From: wrh3mmi@...
              Date: Sun, 3 Feb 2013 21:34:28 +0000
              Subject: [softrock40] Re: WSPR, Softrock RXTX, snd Raspberry Pi

               


              Finally got the install to run but haven't decoded any signals yet...I only overclocked to 900 MHZ and it seems to struggle with the decode, I get the follow message occasionally:

              Attempted to start decode thread when already running
              With my KX3 it appears that the RPi puts off alot of QRM, about 1-2 S units...I'm running it bare so that may add it to the RF.
              I ordered a Syba SD-CM-UAUD USB Stereo Audio Adapter, C-Media Chipset, RoHS, hopefully it will work better than the Signalink USB.
              --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@...> wrote:
              >
              > No, my install went pretty well. I had a bunch of other packages installed before, so maybe Dave is missing something in his instructions.
              > I am using wired Ethernet. My peripherals are Syba sound dongle : http://www.sybausa.com/productInfo.php?iid=1191
              > and some ancient wireless keyboard/mouse combo. RPi is 512MB version overclocked to 1GHz with 16GB Sandisk Ultra micro SD card.
              > > 73, Mike
              > > --- In softrock40@yahoogroups.com, "William" wrote:
              > >
              > > Mike,
              > > Glad to hear you got it to work! I've been trying for the past several hours to get WSPR to compile and no luck. Headed to bed but will do a fresh install of wheezy and try again this weekend. I saw the JAN 28 update to G4FRE's blog but still had errors. I also noticed that it caused my wifi usb dongle to stop working properly...did you run into any of these issues?
              > > > > 73,
              > > Will
              > > > > --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@> wrote:
              > > >
              > > > Your post finally made me to try it.
              > > > I've compiled WSPR from source following Dave's instructions. He now has updated instructions in his blog.
              > > > It is now working with Ensemble II RX on 40m, you can query the database with my call sign, VE3YXA.
              > > > I haven't tried controlling the frequency yet. At the moment it is controlled by CFGSR running on another computer. I need to connect a USB hub to try.
              > > > My Pi is overclocked to 1GHz. CPU usage is about 20% when receiving, the decoding takes about 20sec. The soundcard is SD-AUD20101.
              > > > I have an RXTX as well, trying the TX will be my next project.
              > > > > > > 73, Mike
              > > > > > > --- In softrock40@yahoogroups.com, "William" wrote:
              > > > >
              > > > > I've searched google and found successful cases of WSPR being used on a Raspbery Pi(http://g4fre.blogspot.com/2012/11/wsjt-on-raspberry-pi.html)
              > > > > > > > > and I found successful cases of WSPR being used on a Softrock RXTX...ergo can it be done? Can you make a low power beacon station with a Raspberry Pi and a Softrock? > > > > > > > > Obviously have soundcard issues but can you use an external usb soundcard to achieve results?
              > > > > > > > > 73
              > > > > Will
              > > > > KB5USW
              > > > >
              > > >
              > >
              >


            • David Turnbull
              ... I ve had a Raspberry Pi for many months and finally fired it up for the first time yesterday. Ran some benchmarks on the PSK31 decoder that I wrote. With a
              Message 6 of 12 , Feb 3, 2013
              • 0 Attachment
                On Sun, Feb 3, 2013 at 1:34 PM, William <wrh3mmi@...> wrote:
                > Finally got the install to run but haven't decoded any signals yet...I only overclocked to 900 MHZ and it seems to struggle with the decode...

                I've had a Raspberry Pi for many months and finally fired it up for
                the first time yesterday. Ran some benchmarks on the PSK31 decoder
                that I wrote. With a 15 second test file:

                Core2Duo using only one 3GHz core: 0.14 seconds
                Raspberry Pi 700MHz -mfloat-abi=hard: 4.5 seconds

                73 David AE9RB
                http://AE9RB.com/
              • va3dxz
                Just wondering if anyone been able to use WSPR, running on a Raspberry PI, to control the Softrock Ensemble TX/RX? I was able to get WSPR compiled and running
                Message 7 of 12 , Feb 4, 2013
                • 0 Attachment
                  Just wondering if anyone been able to use WSPR, running on a Raspberry PI, to control the Softrock Ensemble TX/RX?

                  I was able to get WSPR compiled and running on the PI using the G4FRE's Jan 28th instructions found at http://g4fre.blogspot.ca/2013/01/wspr-on-rpilapdock-under-raspian.html

                  However, the WSPR CAT function is not able to communicate with the Softrock via the USB. It would seem that I need a version of the PEOFKO USB-Driver compatible with the PI to control the ensemble rx/tx Si570. I have no idea how to compile this driver for the PI but I can follow instructions.

                  If anyone has this working, please let me know.

                  My set up is as follows:
                  2012-12-16-wheezy-raspbian loaded on 32G SD card
                  Pi overclocked at 1Ghz
                  SignaLink USB attached to PI for Audio In

                  Also, I have WSPR running under XP using WSPR's I/Q functionality with full CAT control of the softrock and this works very well.


                  73,
                  Chris VA3DXZ

                  --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@...> wrote:
                  >
                  > Your post finally made me to try it.
                  > I've compiled WSPR from source following Dave's instructions. He now has updated instructions in his blog.
                  > It is now working with Ensemble II RX on 40m, you can query the database with my call sign, VE3YXA.
                  > I haven't tried controlling the frequency yet. At the moment it is controlled by CFGSR running on another computer. I need to connect a USB hub to try.
                  > My Pi is overclocked to 1GHz. CPU usage is about 20% when receiving, the decoding takes about 20sec. The soundcard is SD-AUD20101.
                  > I have an RXTX as well, trying the TX will be my next project.
                  >
                  > 73, Mike
                  >
                  > --- In softrock40@yahoogroups.com, "William" wrote:
                  > >
                  > > I've searched google and found successful cases of WSPR being used on a Raspbery Pi(http://g4fre.blogspot.com/2012/11/wsjt-on-raspberry-pi.html)
                  > >
                  > > and I found successful cases of WSPR being used on a Softrock RXTX...ergo can it be done? Can you make a low power beacon station with a Raspberry Pi and a Softrock?
                  > >
                  > > Obviously have soundcard issues but can you use an external usb soundcard to achieve results?
                  > >
                  > > 73
                  > > Will
                  > > KB5USW
                  > >
                  >
                • MIKE DURKIN
                  there might be something that works ... its used in ghpsdr3-alex and quisk ... try joining the sdr-widget group, we ve been banging up against the O-DroidX(2)
                  Message 8 of 12 , Feb 4, 2013
                  • 0 Attachment
                    there might be something that works ... its used in ghpsdr3-alex and quisk ...
                    try joining the sdr-widget group,
                    we've been banging up against the O-DroidX(2) .... its a quad Arm

                    so solutions there should work 4 you....


                    To: softrock40@yahoogroups.com
                    From: chris.mcgaffey@...
                    Date: Tue, 5 Feb 2013 03:24:25 +0000
                    Subject: [softrock40] Re: WSPR, Softrock RXTX, snd Raspberry Pi

                     
                    Just wondering if anyone been able to use WSPR, running on a Raspberry PI, to control the Softrock Ensemble TX/RX?

                    I was able to get WSPR compiled and running on the PI using the G4FRE's Jan 28th instructions found at http://g4fre.blogspot.ca/2013/01/wspr-on-rpilapdock-under-raspian.html

                    However, the WSPR CAT function is not able to communicate with the Softrock via the USB. It would seem that I need a version of the PEOFKO USB-Driver compatible with the PI to control the ensemble rx/tx Si570. I have no idea how to compile this driver for the PI but I can follow instructions.

                    If anyone has this working, please let me know.

                    My set up is as follows:
                    2012-12-16-wheezy-raspbian loaded on 32G SD card
                    Pi overclocked at 1Ghz
                    SignaLink USB attached to PI for Audio In

                    Also, I have WSPR running under XP using WSPR's I/Q functionality with full CAT control of the softrock and this works very well.

                    73,
                    Chris VA3DXZ

                    --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@...> wrote:
                    >
                    > Your post finally made me to try it.
                    > I've compiled WSPR from source following Dave's instructions. He now has updated instructions in his blog.
                    > It is now working with Ensemble II RX on 40m, you can query the database with my call sign, VE3YXA.
                    > I haven't tried controlling the frequency yet. At the moment it is controlled by CFGSR running on another computer. I need to connect a USB hub to try.
                    > My Pi is overclocked to 1GHz. CPU usage is about 20% when receiving, the decoding takes about 20sec. The soundcard is SD-AUD20101.
                    > I have an RXTX as well, trying the TX will be my next project.
                    >
                    > 73, Mike
                    >
                    > --- In softrock40@yahoogroups.com, "William" wrote:
                    > >
                    > > I've searched google and found successful cases of WSPR being used on a Raspbery Pi(http://g4fre.blogspot.com/2012/11/wsjt-on-raspberry-pi.html)
                    > >
                    > > and I found successful cases of WSPR being used on a Softrock RXTX...ergo can it be done? Can you make a low power beacon station with a Raspberry Pi and a Softrock?
                    > >
                    > > Obviously have soundcard issues but can you use an external usb soundcard to achieve results?
                    > >
                    > > 73
                    > > Will
                    > > KB5USW
                    > >
                    >


                  • vbifyz
                    When you install WSPR according to Dave s instructions, a copy of hamlib is installed in the process. WSPR uses the hamlib to control the Softrock. The only
                    Message 9 of 12 , Feb 5, 2013
                    • 0 Attachment
                      When you install WSPR according to Dave's instructions, a copy of hamlib is installed in the process. WSPR uses the hamlib to control the Softrock. The only issue is that the USB permissions have to be changed. Quick googling will show you how to do that.
                      After fixing the permissions, WSPR controls the Softrock frequency just fine. I also used "rigctl -m 2509 F <frequency>" command in a terminal window to control Si570.

                      73, Mike

                      --- In softrock40@yahoogroups.com, "va3dxz" wrote:
                      >
                      > Just wondering if anyone been able to use WSPR, running on a Raspberry PI, to control the Softrock Ensemble TX/RX?
                      >
                      > I was able to get WSPR compiled and running on the PI using the G4FRE's Jan 28th instructions found at http://g4fre.blogspot.ca/2013/01/wspr-on-rpilapdock-under-raspian.html
                      >
                      > However, the WSPR CAT function is not able to communicate with the Softrock via the USB. It would seem that I need a version of the PEOFKO USB-Driver compatible with the PI to control the ensemble rx/tx Si570. I have no idea how to compile this driver for the PI but I can follow instructions.
                      >
                      > If anyone has this working, please let me know.
                      >
                      > My set up is as follows:
                      > 2012-12-16-wheezy-raspbian loaded on 32G SD card
                      > Pi overclocked at 1Ghz
                      > SignaLink USB attached to PI for Audio In
                      >
                      > Also, I have WSPR running under XP using WSPR's I/Q functionality with full CAT control of the softrock and this works very well.
                      >
                      >
                      > 73,
                      > Chris VA3DXZ
                      >
                      > --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@> wrote:
                      > >
                      > > Your post finally made me to try it.
                      > > I've compiled WSPR from source following Dave's instructions. He now has updated instructions in his blog.
                      > > It is now working with Ensemble II RX on 40m, you can query the database with my call sign, VE3YXA.
                      > > I haven't tried controlling the frequency yet. At the moment it is controlled by CFGSR running on another computer. I need to connect a USB hub to try.
                      > > My Pi is overclocked to 1GHz. CPU usage is about 20% when receiving, the decoding takes about 20sec. The soundcard is SD-AUD20101.
                      > > I have an RXTX as well, trying the TX will be my next project.
                      > >
                      > > 73, Mike
                      > >
                      > > --- In softrock40@yahoogroups.com, "William" wrote:
                      > > >
                      > > > I've searched google and found successful cases of WSPR being used on a Raspbery Pi(http://g4fre.blogspot.com/2012/11/wsjt-on-raspberry-pi.html)
                      > > >
                      > > > and I found successful cases of WSPR being used on a Softrock RXTX...ergo can it be done? Can you make a low power beacon station with a Raspberry Pi and a Softrock?
                      > > >
                      > > > Obviously have soundcard issues but can you use an external usb soundcard to achieve results?
                      > > >
                      > > > 73
                      > > > Will
                      > > > KB5USW
                      > > >
                      > >
                      >
                    • va3dxz
                      Thanks Mike. When I log into the pi, I start the gui with startx, then I open a terminal window, cd to wspr then ./wspr to start the application. The
                      Message 10 of 12 , Feb 6, 2013
                      • 0 Attachment
                        Thanks Mike. When I log into the pi, I start the gui with startx, then I open a terminal window, cd to wspr then ./wspr to start the application. The application starts up but can't talk to the softrock:

                        rig_open: error = IO error
                        Error attempting to set rig freq
                        rigctl -m 2509 -r USD F 10126729

                        So I looked at the permissions as you suggested. Each of the hamlib files were set to -rw-r--r--. I changed each to -rwxrwxrwx but same problem. After putting the permissions back to -rw-r--r--, I tried starting wspr using sudo ./wspr and it worked. I was able to tx and change frequency.

                        However, after the 1st receive cycle, when the decode kicked in, the CPU was pegged at 100% and stayed there. When the next TX cycle came around, I would see

                        error executing rigctl to set TX mode
                        rigctl -m 2509 -r USB T 1

                        In most cases I needed to reboot the PI to bring it back to life. I have the PI overclocked to 1Ghz and set this up using raspi-config. I double checked the clock speed using vcgencmd get_config arm_freq.

                        Is anyone else seeing performance issues like this?

                        Thanks and 73,

                        Chris / VA3DXZ



                        --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@...> wrote:
                        >
                        > When you install WSPR according to Dave's instructions, a copy of hamlib is installed in the process. WSPR uses the hamlib to control the Softrock. The only issue is that the USB permissions have to be changed. Quick googling will show you how to do that.
                        > After fixing the permissions, WSPR controls the Softrock frequency just fine. I also used "rigctl -m 2509 F " command in a terminal window to control Si570.
                        >
                        > 73, Mike
                        >
                        > --- In softrock40@yahoogroups.com, "va3dxz" wrote:
                        > >
                        > > Just wondering if anyone been able to use WSPR, running on a Raspberry PI, to control the Softrock Ensemble TX/RX?
                        > >
                        > > I was able to get WSPR compiled and running on the PI using the G4FRE's Jan 28th instructions found at http://g4fre.blogspot.ca/2013/01/wspr-on-rpilapdock-under-raspian.html
                        > >
                        > > However, the WSPR CAT function is not able to communicate with the Softrock via the USB. It would seem that I need a version of the PEOFKO USB-Driver compatible with the PI to control the ensemble rx/tx Si570. I have no idea how to compile this driver for the PI but I can follow instructions.
                        > >
                        > > If anyone has this working, please let me know.
                        > >
                        > > My set up is as follows:
                        > > 2012-12-16-wheezy-raspbian loaded on 32G SD card
                        > > Pi overclocked at 1Ghz
                        > > SignaLink USB attached to PI for Audio In
                        > >
                        > > Also, I have WSPR running under XP using WSPR's I/Q functionality with full CAT control of the softrock and this works very well.
                        > >
                        > >
                        > > 73,
                        > > Chris VA3DXZ
                        > >
                        > > --- In softrock40@yahoogroups.com, "vbifyz" <3ym3ym@> wrote:
                        > > >
                        > > > Your post finally made me to try it.
                        > > > I've compiled WSPR from source following Dave's instructions. He now has updated instructions in his blog.
                        > > > It is now working with Ensemble II RX on 40m, you can query the database with my call sign, VE3YXA.
                        > > > I haven't tried controlling the frequency yet. At the moment it is controlled by CFGSR running on another computer. I need to connect a USB hub to try.
                        > > > My Pi is overclocked to 1GHz. CPU usage is about 20% when receiving, the decoding takes about 20sec. The soundcard is SD-AUD20101.
                        > > > I have an RXTX as well, trying the TX will be my next project.
                        > > >
                        > > > 73, Mike
                        > > >
                        > > > --- In softrock40@yahoogroups.com, "William" wrote:
                        > > > >
                        > > > > I've searched google and found successful cases of WSPR being used on a Raspbery Pi(http://g4fre.blogspot.com/2012/11/wsjt-on-raspberry-pi.html)
                        > > > >
                        > > > > and I found successful cases of WSPR being used on a Softrock RXTX...ergo can it be done? Can you make a low power beacon station with a Raspberry Pi and a Softrock?
                        > > > >
                        > > > > Obviously have soundcard issues but can you use an external usb soundcard to achieve results?
                        > > > >
                        > > > > 73
                        > > > > Will
                        > > > > KB5USW
                        > > > >
                        > > >
                        > >
                        >
                      • vbifyz
                        It is not file permissions, but the USB access permissions that you need to change. Good step-by-step reading for beginners here:
                        Message 11 of 12 , Feb 7, 2013
                        • 0 Attachment
                          It is not file permissions, but the USB access permissions that you need to change.
                          Good step-by-step reading for beginners here:
                          http://www.n8mdp.com/sdr_quisk.html

                          I noticed that sometimes WSPR decoding phase takes a few seconds, and sometimes more than 2 minutes, so there is sometimes a message that the next decoding can not start (maybe 1 out of 20-50 cycles). But for me it always eventually finishes.

                          73, Mike

                          --- In softrock40@yahoogroups.com, "va3dxz" wrote:
                          >
                          > Thanks Mike. When I log into the pi, I start the gui with startx, then I open a terminal window, cd to wspr then ./wspr to start the application. The application starts up but can't talk to the softrock:
                          >
                          > rig_open: error = IO error
                          > Error attempting to set rig freq
                          > rigctl -m 2509 -r USD F 10126729
                          >
                          > So I looked at the permissions as you suggested. Each of the hamlib files were set to -rw-r--r--. I changed each to -rwxrwxrwx but same problem. After putting the permissions back to -rw-r--r--, I tried starting wspr using sudo ./wspr and it worked. I was able to tx and change frequency.
                          >
                          > However, after the 1st receive cycle, when the decode kicked in, the CPU was pegged at 100% and stayed there. When the next TX cycle came around, I would see
                          >
                          > error executing rigctl to set TX mode
                          > rigctl -m 2509 -r USB T 1
                          >
                          > In most cases I needed to reboot the PI to bring it back to life. I have the PI overclocked to 1Ghz and set this up using raspi-config. I double checked the clock speed using vcgencmd get_config arm_freq.
                          >
                          > Is anyone else seeing performance issues like this?
                          >
                          > Thanks and 73,
                          >
                          > Chris / VA3DXZ
                        Your message has been successfully submitted and would be delivered to recipients shortly.