Loading ...
Sorry, an error occurred while loading the content.

RE: [softrock40] ghpsdr3-alex and Ubuntu 12.04

Expand Messages
  • MIKE DURKIN
    Tried Sudo softrock? If that works you have to set permissions still ... To: softrock40@yahoogroups.com From: ars_n8mdp@windstream.net Date: Thu, 6 Dec 2012
    Message 1 of 7 , Dec 6, 2012
    • 0 Attachment
      Tried

      Sudo softrock?

      If that works you have to set permissions still ...


      To: softrock40@yahoogroups.com
      From: ars_n8mdp@...
      Date: Thu, 6 Dec 2012 12:37:00 +0000
      Subject: [softrock40] ghpsdr3-alex and Ubuntu 12.04

       
      Hopefully Sid or Andrea read this message.

      Hi guys. I am installing the latest GIT on another computer that is currently running Ubuntu 12.04 LTS. I followed the instructions to the letter on installing all of the software for this version. Everything seems to install fine without any errors. QTRadio is working just fine. But when I start up the 'softrock' and 'dspserver', I don't think the servers are working.

      In a Terminal window, here is what happens for softrock:

      n8mdp@AlphaSite:~$ softrock --si570 --iq --samplerate 48000
      option samplerate with arg 48000
      process_args: samplerate=48000
      Listening for TCP connections on port 11000
      n8mdp@AlphaSite:~$

      for dspserver, I get:

      n8mdp@AlphaSite:~$ dspserver --lo 9000 --share
      Reading conf file /home/n8mdp/dspserver.conf
      Activating Web register
      gHPSDR rx 0 (Version 0.7)
      dspserver string: 20121116;-master
      getSoundcardId: HPSDR id=8
      setSoundcard: 8
      setSoundcard -41.000000 -48.000000
      setup sdr thread 0: done
      setup sdr thread 1: done
      setup sdr thread 2: done
      G711A_init
      ozy_init: command bound to port 12000 socket 3
      ozy_init: audio bound to port 0 socket 4
      ozy_init: server audio is in port 15000
      ozy_init: server 127.0.0.1
      ozy_init: connect failed: Connection refused
      n8mdp@AlphaSite:~$

      On my other computer running the same software, I know it is working as I don't go back to the command prompt. I am using the Softrock Ensemble II.

      I am trying this software out on another computer that has a much better sound system and I can sample at 96,000. So my goal is to improve the performance at my station.

      Do these problems ring a bell with anyone? I may have to go back and reinstall Ubuntu 11.04 or 11.10. I would prefer not to have to do this when I know this probably does work in 12.04. I am missing something.

      Thanks again for everyone's help.
      John
      N8MDP


    • kk4dcf
      Go back over the pulseaudio setup. I think you haven t enabled the network access. James.
      Message 2 of 7 , Dec 6, 2012
      • 0 Attachment
        Go back over the pulseaudio setup. I think you haven't enabled the network access.

        James.

        --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@...> wrote:
        >
        > Hopefully Sid or Andrea read this message.
        >
        > Hi guys. I am installing the latest GIT on another computer that is currently running Ubuntu 12.04 LTS. I followed the instructions to the letter on installing all of the software for this version. Everything seems to install fine without any errors. QTRadio is working just fine. But when I start up the 'softrock' and 'dspserver', I don't think the servers are working.
        >
        > In a Terminal window, here is what happens for softrock:
        >
        > n8mdp@AlphaSite:~$ softrock --si570 --iq --samplerate 48000
        > option samplerate with arg 48000
        > process_args: samplerate=48000
        > Listening for TCP connections on port 11000
        > n8mdp@AlphaSite:~$
        >
        > for dspserver, I get:
        >
        > n8mdp@AlphaSite:~$ dspserver --lo 9000 --share
        > Reading conf file /home/n8mdp/dspserver.conf
        > Activating Web register
        > gHPSDR rx 0 (Version 0.7)
        > dspserver string: 20121116;-master
        > getSoundcardId: HPSDR id=8
        > setSoundcard: 8
        > setSoundcard -41.000000 -48.000000
        > setup sdr thread 0: done
        > setup sdr thread 1: done
        > setup sdr thread 2: done
        > G711A_init
        > ozy_init: command bound to port 12000 socket 3
        > ozy_init: audio bound to port 0 socket 4
        > ozy_init: server audio is in port 15000
        > ozy_init: server 127.0.0.1
        > ozy_init: connect failed: Connection refused
        > n8mdp@AlphaSite:~$
        >
        > On my other computer running the same software, I know it is working as I don't go back to the command prompt. I am using the Softrock Ensemble II.
        >
        > I am trying this software out on another computer that has a much better sound system and I can sample at 96,000. So my goal is to improve the performance at my station.
        >
        > Do these problems ring a bell with anyone? I may have to go back and reinstall Ubuntu 11.04 or 11.10. I would prefer not to have to do this when I know this probably does work in 12.04. I am missing something.
        >
        > Thanks again for everyone's help.
        > John
        > N8MDP
        >
      • n8mdp
        That might be the culprit. If memory serves, that is in the System Settings area, correct? I noticed that in my sound system that ALSA was listed, not
        Message 3 of 7 , Dec 6, 2012
        • 0 Attachment
          That might be the culprit. If memory serves, that is in the System Settings area, correct? I noticed that in my sound system that ALSA was listed, not pulseaudio. My other Ubuntu system is using pulseaudio.

          I'll check this tonight.
          Thanks.
          John
          N8MDP

          --- In softrock40@yahoogroups.com, "kk4dcf" <oohay@...> wrote:
          >
          > Go back over the pulseaudio setup. I think you haven't enabled the network access.
          >
          > James.
          >
          > --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@> wrote:
          > >
          > > Hopefully Sid or Andrea read this message.
          > >
          > > Hi guys. I am installing the latest GIT on another computer that is currently running Ubuntu 12.04 LTS. I followed the instructions to the letter on installing all of the software for this version. Everything seems to install fine without any errors. QTRadio is working just fine. But when I start up the 'softrock' and 'dspserver', I don't think the servers are working.
          > >
          > > In a Terminal window, here is what happens for softrock:
          > >
          > > n8mdp@AlphaSite:~$ softrock --si570 --iq --samplerate 48000
          > > option samplerate with arg 48000
          > > process_args: samplerate=48000
          > > Listening for TCP connections on port 11000
          > > n8mdp@AlphaSite:~$
          > >
          > > for dspserver, I get:
          > >
          > > n8mdp@AlphaSite:~$ dspserver --lo 9000 --share
          > > Reading conf file /home/n8mdp/dspserver.conf
          > > Activating Web register
          > > gHPSDR rx 0 (Version 0.7)
          > > dspserver string: 20121116;-master
          > > getSoundcardId: HPSDR id=8
          > > setSoundcard: 8
          > > setSoundcard -41.000000 -48.000000
          > > setup sdr thread 0: done
          > > setup sdr thread 1: done
          > > setup sdr thread 2: done
          > > G711A_init
          > > ozy_init: command bound to port 12000 socket 3
          > > ozy_init: audio bound to port 0 socket 4
          > > ozy_init: server audio is in port 15000
          > > ozy_init: server 127.0.0.1
          > > ozy_init: connect failed: Connection refused
          > > n8mdp@AlphaSite:~$
          > >
          > > On my other computer running the same software, I know it is working as I don't go back to the command prompt. I am using the Softrock Ensemble II.
          > >
          > > I am trying this software out on another computer that has a much better sound system and I can sample at 96,000. So my goal is to improve the performance at my station.
          > >
          > > Do these problems ring a bell with anyone? I may have to go back and reinstall Ubuntu 11.04 or 11.10. I would prefer not to have to do this when I know this probably does work in 12.04. I am missing something.
          > >
          > > Thanks again for everyone's help.
          > > John
          > > N8MDP
          > >
          >
        • n8mdp
          James, yep, that was the problem. Everything is working fine now. The only thing I have to do now is figure out how to set the sampling rate on the internal
          Message 4 of 7 , Dec 6, 2012
          • 0 Attachment
            James, yep, that was the problem. Everything is working fine now.

            The only thing I have to do now is figure out how to set the sampling rate on the internal audio system to 96kHz sampling. The internal integrated audio system is spec'ed for that but I am not sure how to do that. Somehow, I don't think the Softrock server software sets it through the "softrock --samplerate 96000" command.

            Thanks for your help.
            John
            N8MDP

            --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@...> wrote:
            >
            > That might be the culprit. If memory serves, that is in the System Settings area, correct? I noticed that in my sound system that ALSA was listed, not pulseaudio. My other Ubuntu system is using pulseaudio.
            >
            > I'll check this tonight.
            > Thanks.
            > John
            > N8MDP
            >
            > --- In softrock40@yahoogroups.com, "kk4dcf" <oohay@> wrote:
            > >
            > > Go back over the pulseaudio setup. I think you haven't enabled the network access.
            > >
            > > James.
            > >
            > > --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@> wrote:
            > > >
            > > > Hopefully Sid or Andrea read this message.
            > > >
            > > > Hi guys. I am installing the latest GIT on another computer that is currently running Ubuntu 12.04 LTS. I followed the instructions to the letter on installing all of the software for this version. Everything seems to install fine without any errors. QTRadio is working just fine. But when I start up the 'softrock' and 'dspserver', I don't think the servers are working.
            > > >
            > > > In a Terminal window, here is what happens for softrock:
            > > >
            > > > n8mdp@AlphaSite:~$ softrock --si570 --iq --samplerate 48000
            > > > option samplerate with arg 48000
            > > > process_args: samplerate=48000
            > > > Listening for TCP connections on port 11000
            > > > n8mdp@AlphaSite:~$
            > > >
            > > > for dspserver, I get:
            > > >
            > > > n8mdp@AlphaSite:~$ dspserver --lo 9000 --share
            > > > Reading conf file /home/n8mdp/dspserver.conf
            > > > Activating Web register
            > > > gHPSDR rx 0 (Version 0.7)
            > > > dspserver string: 20121116;-master
            > > > getSoundcardId: HPSDR id=8
            > > > setSoundcard: 8
            > > > setSoundcard -41.000000 -48.000000
            > > > setup sdr thread 0: done
            > > > setup sdr thread 1: done
            > > > setup sdr thread 2: done
            > > > G711A_init
            > > > ozy_init: command bound to port 12000 socket 3
            > > > ozy_init: audio bound to port 0 socket 4
            > > > ozy_init: server audio is in port 15000
            > > > ozy_init: server 127.0.0.1
            > > > ozy_init: connect failed: Connection refused
            > > > n8mdp@AlphaSite:~$
            > > >
            > > > On my other computer running the same software, I know it is working as I don't go back to the command prompt. I am using the Softrock Ensemble II.
            > > >
            > > > I am trying this software out on another computer that has a much better sound system and I can sample at 96,000. So my goal is to improve the performance at my station.
            > > >
            > > > Do these problems ring a bell with anyone? I may have to go back and reinstall Ubuntu 11.04 or 11.10. I would prefer not to have to do this when I know this probably does work in 12.04. I am missing something.
            > > >
            > > > Thanks again for everyone's help.
            > > > John
            > > > N8MDP
            > > >
            > >
            >
          • n8mdp
            Just figured out the sampling rate. Had to change teh daemon.conf file in the /etc/pulse/ file folder. Learning as we go.... John
            Message 5 of 7 , Dec 6, 2012
            • 0 Attachment
              Just figured out the sampling rate. Had to change teh daemon.conf file in the /etc/pulse/ file folder.

              Learning as we go....
              John

              --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@...> wrote:
              >
              > James, yep, that was the problem. Everything is working fine now.
              >
              > The only thing I have to do now is figure out how to set the sampling rate on the internal audio system to 96kHz sampling. The internal integrated audio system is spec'ed for that but I am not sure how to do that. Somehow, I don't think the Softrock server software sets it through the "softrock --samplerate 96000" command.
              >
              > Thanks for your help.
              > John
              > N8MDP
              >
              > --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@> wrote:
              > >
              > > That might be the culprit. If memory serves, that is in the System Settings area, correct? I noticed that in my sound system that ALSA was listed, not pulseaudio. My other Ubuntu system is using pulseaudio.
              > >
              > > I'll check this tonight.
              > > Thanks.
              > > John
              > > N8MDP
              > >
              > > --- In softrock40@yahoogroups.com, "kk4dcf" <oohay@> wrote:
              > > >
              > > > Go back over the pulseaudio setup. I think you haven't enabled the network access.
              > > >
              > > > James.
              > > >
              > > > --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@> wrote:
              > > > >
              > > > > Hopefully Sid or Andrea read this message.
              > > > >
              > > > > Hi guys. I am installing the latest GIT on another computer that is currently running Ubuntu 12.04 LTS. I followed the instructions to the letter on installing all of the software for this version. Everything seems to install fine without any errors. QTRadio is working just fine. But when I start up the 'softrock' and 'dspserver', I don't think the servers are working.
              > > > >
              > > > > In a Terminal window, here is what happens for softrock:
              > > > >
              > > > > n8mdp@AlphaSite:~$ softrock --si570 --iq --samplerate 48000
              > > > > option samplerate with arg 48000
              > > > > process_args: samplerate=48000
              > > > > Listening for TCP connections on port 11000
              > > > > n8mdp@AlphaSite:~$
              > > > >
              > > > > for dspserver, I get:
              > > > >
              > > > > n8mdp@AlphaSite:~$ dspserver --lo 9000 --share
              > > > > Reading conf file /home/n8mdp/dspserver.conf
              > > > > Activating Web register
              > > > > gHPSDR rx 0 (Version 0.7)
              > > > > dspserver string: 20121116;-master
              > > > > getSoundcardId: HPSDR id=8
              > > > > setSoundcard: 8
              > > > > setSoundcard -41.000000 -48.000000
              > > > > setup sdr thread 0: done
              > > > > setup sdr thread 1: done
              > > > > setup sdr thread 2: done
              > > > > G711A_init
              > > > > ozy_init: command bound to port 12000 socket 3
              > > > > ozy_init: audio bound to port 0 socket 4
              > > > > ozy_init: server audio is in port 15000
              > > > > ozy_init: server 127.0.0.1
              > > > > ozy_init: connect failed: Connection refused
              > > > > n8mdp@AlphaSite:~$
              > > > >
              > > > > On my other computer running the same software, I know it is working as I don't go back to the command prompt. I am using the Softrock Ensemble II.
              > > > >
              > > > > I am trying this software out on another computer that has a much better sound system and I can sample at 96,000. So my goal is to improve the performance at my station.
              > > > >
              > > > > Do these problems ring a bell with anyone? I may have to go back and reinstall Ubuntu 11.04 or 11.10. I would prefer not to have to do this when I know this probably does work in 12.04. I am missing something.
              > > > >
              > > > > Thanks again for everyone's help.
              > > > > John
              > > > > N8MDP
              > > > >
              > > >
              > >
              >
            • kk4dcf
              Check the pulseaudio section of the ghpsdr3-alex wiki. It s something like this: edit /etc/pulse/daemon.conf There s a commented out section ;
              Message 6 of 7 , Dec 6, 2012
              • 0 Attachment
                Check the pulseaudio section of the ghpsdr3-alex wiki.
                It's something like this:

                edit /etc/pulse/daemon.conf

                There's a commented out section
                ; default-sample-format = s16le
                ; default-sample-rate = 44100
                ; default-sample-channels = 2
                ; default-channel-map = front-left,front-right

                Uncomment default-sameple-format and set it to s24le
                Uncomment default-sample-rate and set it to 96000

                James.


                --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@...> wrote:
                >
                > James, yep, that was the problem. Everything is working fine now.
                >
                > The only thing I have to do now is figure out how to set the sampling rate on the internal audio system to 96kHz sampling. The internal integrated audio system is spec'ed for that but I am not sure how to do that. Somehow, I don't think the Softrock server software sets it through the "softrock --samplerate 96000" command.
                >
                > Thanks for your help.
                > John
                > N8MDP
                >
                > --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@> wrote:
                > >
                > > That might be the culprit. If memory serves, that is in the System Settings area, correct? I noticed that in my sound system that ALSA was listed, not pulseaudio. My other Ubuntu system is using pulseaudio.
                > >
                > > I'll check this tonight.
                > > Thanks.
                > > John
                > > N8MDP
                > >
                > > --- In softrock40@yahoogroups.com, "kk4dcf" <oohay@> wrote:
                > > >
                > > > Go back over the pulseaudio setup. I think you haven't enabled the network access.
                > > >
                > > > James.
                > > >
                > > > --- In softrock40@yahoogroups.com, "n8mdp" <ars_n8mdp@> wrote:
                > > > >
                > > > > Hopefully Sid or Andrea read this message.
                > > > >
                > > > > Hi guys. I am installing the latest GIT on another computer that is currently running Ubuntu 12.04 LTS. I followed the instructions to the letter on installing all of the software for this version. Everything seems to install fine without any errors. QTRadio is working just fine. But when I start up the 'softrock' and 'dspserver', I don't think the servers are working.
                > > > >
                > > > > In a Terminal window, here is what happens for softrock:
                > > > >
                > > > > n8mdp@AlphaSite:~$ softrock --si570 --iq --samplerate 48000
                > > > > option samplerate with arg 48000
                > > > > process_args: samplerate=48000
                > > > > Listening for TCP connections on port 11000
                > > > > n8mdp@AlphaSite:~$
                > > > >
                > > > > for dspserver, I get:
                > > > >
                > > > > n8mdp@AlphaSite:~$ dspserver --lo 9000 --share
                > > > > Reading conf file /home/n8mdp/dspserver.conf
                > > > > Activating Web register
                > > > > gHPSDR rx 0 (Version 0.7)
                > > > > dspserver string: 20121116;-master
                > > > > getSoundcardId: HPSDR id=8
                > > > > setSoundcard: 8
                > > > > setSoundcard -41.000000 -48.000000
                > > > > setup sdr thread 0: done
                > > > > setup sdr thread 1: done
                > > > > setup sdr thread 2: done
                > > > > G711A_init
                > > > > ozy_init: command bound to port 12000 socket 3
                > > > > ozy_init: audio bound to port 0 socket 4
                > > > > ozy_init: server audio is in port 15000
                > > > > ozy_init: server 127.0.0.1
                > > > > ozy_init: connect failed: Connection refused
                > > > > n8mdp@AlphaSite:~$
                > > > >
                > > > > On my other computer running the same software, I know it is working as I don't go back to the command prompt. I am using the Softrock Ensemble II.
                > > > >
                > > > > I am trying this software out on another computer that has a much better sound system and I can sample at 96,000. So my goal is to improve the performance at my station.
                > > > >
                > > > > Do these problems ring a bell with anyone? I may have to go back and reinstall Ubuntu 11.04 or 11.10. I would prefer not to have to do this when I know this probably does work in 12.04. I am missing something.
                > > > >
                > > > > Thanks again for everyone's help.
                > > > > John
                > > > > N8MDP
                > > > >
                > > >
                > >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.