Loading ...
Sorry, an error occurred while loading the content.

Re: [softrock40] Installing on Ubuntu 12.04

Expand Messages
  • Ross Ballantyne
    Mind you if you have a 64bit system the locations are slightly different: ./configure --with-portaudio-include-dir=/usr/include
    Message 1 of 105 , Jul 1, 2012
    • 0 Attachment
      Mind you if you have a 64bit system the locations are slightly different:

      ./configure \
        --with-portaudio-include-dir=/usr/include \

      On 01/07/2012, at 9:05 PM, Ross Ballantyne wrote:


      Jon Ove,

      Have a look at http://blog.marxy.org/2012/05/build-wspr-on-ubuntu-1204.html Peter solved that a whilre ago, some of the libraries have been move in 12.04

      ./configure \
      --with-portaudio-include-dir=/usr/include \



      On 01/07/2012, at 8:54 PM, LA3JJ wrote:


      Hi all Linux experts,
      You have helped me out before and I do hope some of you will be so kind as to give some advice on this.
      I have converted some old and some rather new laptops to Ubuntu 12.04 and am now trying to install WSPR and   on them.
      Let me first ask about my wspr problem:

      After having added all the required programs, including portaudio19-dev,
      then svn from berlios everything seems ok.
      After the ./configure this message comes:

      This program needs portaudio v19 to compile.
      Please use --with-portaudio-include-dir= and
      --with-portaudio-lib-dir= to set the paths.
      configure: error: Please check error messages and install missing packages.

      Should I do these changes in the source code or as an addition to the configure command or maybe change the file structure? -and how?


      As a comment to previous tread, I do have a 40 year old degree in EE, but it does not seem to help me much now.

      73 la3jj Jon Ove

    • Alex
      (You also need the autoreconf -i step) Do: $ ./cleanup $ autoreconf -i $ ./configure CFLAGS= -O3 -msse2 -fopenmp CXXFLAGS= -O3 -msse2 -fopenmp $ make -j8 $
      Message 105 of 105 , Jul 18, 2012
      • 0 Attachment
        (You also need the autoreconf -i step)


        $ ./cleanup
        $ autoreconf -i
        $ ./configure CFLAGS='-O3 -msse2 -fopenmp' CXXFLAGS='-O3 -msse2 -fopenmp'
        $ make -j8
        $ sudo make install

        --- In softrock40@yahoogroups.com, Roger Critchlow <rec@...> wrote:
        > Mike --
        > To summarize
        > cd ~/ghpsdr3-alex
        > ./cleanup
        > ./configure CFLAGS='-fopenmp -O3 -msse2' CXXFLAGS='-fopenmp -O3 -msse2'
        > make
        > sudo make install
        > and see what happens when you start dspserver this time.
        > The gmail app on my Samsung has a checkbox for including text in replies,
        > maybe there's something similar on the DroidX email app you're using.
        > -- rec --
      Your message has been successfully submitted and would be delivered to recipients shortly.