Loading ...
Sorry, an error occurred while loading the content.


Expand Messages
    Ok ... finally got Ubuntu 11.10 installed .... Dang, im having a hard time with installing Linrad .... any one in the list do this recently? Or any other
    Message 1 of 67 , Apr 19 11:47 PM
    • 0 Attachment
      Ok ... finally got Ubuntu 11.10 installed ....

      Dang, im having a hard time with installing Linrad .... any one in the list do this recently? Or any other linux based software?

      Mike KC7NOA
    • Sid Boyce
      Sound cards are a pain at times. On 2 boxes I had different Asus motherboards with the same on-board sound. One worked and the other didn t until I posted
      Message 67 of 67 , May 18, 2012
      • 0 Attachment
        Sound cards are a pain at times.
        On 2 boxes I had  different Asus motherboards with the "same" on-board sound. One worked and the other didn't until I posted the problem to the Linux kernel mailing list and with some diagnostic information they asked me to supply, it got fixed.
        73 ... Sid.

        On 18/05/12 07:35, MIKE DURKIN wrote:

        Ok ... im up and running ...
        New pci soundcard .... for speaker out and microphone in ...

        Weird thing is I can get microphone on the SBlive24 under linux but not windows and a CM106 based pci,  microphone works but can't get it to work under windows .... go figure.

        So next to see about a UBW32 to replace the QRP2000 and fet Quisk to change /pick between 8 different BPF ....

        Mike KC7NOA

        To: softrock40@yahoogroups.com
        From: sboyce@...
        Date: Tue, 8 May 2012 04:04:11 +0100
        Subject: Re: [softrock40] Re: Linux

        That I've not seen in quisk.
        For the last few hours I've been running quisk-3.6.1 on the UHFSDR/Widget connected to the Intel i5 12.04 box and it's been clean apart from the usual startup "ALSA lib messages" etc.

        At 04:03 local Stateside stations are still booming in on 20m.
        73 ... Sid.

        On 08/05/12 03:33, MIKE DURKIN wrote:

        Well getting a better idea ...

        I guess ....

        Today while running HDSDR (windows) I had a receiver over-run ... not sure what it means yet ...
        Might be the same thing happening with Quisk ..
        Im hopping that when the good LiquidCrystal soundcard gets installed all will be fine ( probably not)

        -----Original Message-----

        From: Sid Boyce
        Sent: 3 May 2012 01:58:56 GMT
        To: softrock40@yahoogroups.com
        Subject: Re: [softrock40] Re: Linux

        That rules that out. It runs fine on an Atom N330 1.6GHz.
        Possibility, mine aren't sharing sound interrupts.
        73 ... Sid.

        On 03/05/12 00:05, MIKE DURKIN wrote:

        Cpu shouldn't be an issue ... 3.2Ghz dual X2

        Not sure what's is causing it ... might be that the onboard sound & one of the USB ports share an IRQ ..

        -----Original Message-----

        From: Sid Boyce
        Sent: 2 May 2012 20:18:31 GMT
        To: softrock40@yahoogroups.com
        Subject: Re: [softrock40] Re: Linux

        On 02/05/12 17:11, MIKE DURKIN wrote:
        Ok .. that looks great .. id like to use some thing with more bandpass filters than what the Ensemble Rx/Tx offers ..
        The standard UBW firmware caters for 4 BPF's and 8 LPF's, perhaps the number could be expanded, Alex is the firmware author.
        The source code is in files/9V1AL/UBW Emulator/UBW Emulator-v16.04.zip.
        IO Port Pin assignment

        Pin assignments for the UBW are as follows:

        Pin     Name            Input/Output    Active          Remarks

        RA0     BPF_SO          O               H               BPF select S0
        RA1     BPF_S1          O               H               BPF select S1
                                                               S1,S0 selects 1 of 4 BPF's for Softrock
        RA2     RXTX            O               H               PTT, H = Transmit

        RB0     SDA             Open Collector                  For i2c connection to Si570
        RB1     SCL             Open Collector                  may need conversion to +3v3
                                                               in case of firmware failure
                                                               (eg wrong firmware loaded)
                                                               then RB0 and RB1 may be set
                                                               to logic high output of +5V                            

        RB6     PADDLE_DIT      I               L               Paddle DIT Input, active low
        RB7     PADDLE_DAH      I               L               Paddle DAH Input, active low
                                                               As internal pullup is enabled,
                                                               there is no need to add external
                                                               pullup resistors.

        RA3-5, RB2-5    LPF_x   O               H               LPF select
                                                               This has to be customised for
                                                               the LPF bank you use.

        and i have 10 pic32MX440/460's to play with ....

        Question about quisk .. im getting clicks on peeks of moderate to strong signals ... any thoughts to help ? (BTY - linrad is quite smooth and clear)

        Mike KC7NOA

        I've never experienced that even on the HiQSDR at 960K samplerate.

        With underpowered CPU's like the Beagleboard XM I get intermittent sound that come in 1 second pulses.
        73 ... Sid.

        To: softrock40@yahoogroups.com
        From: sboyce@...
        Date: Wed, 2 May 2012 03:01:09 +0100
        Subject: Re: [softrock40] Re: Linux

        You'llfind fsusb-0.1.11-2.tar.gz at http://www.internetking.org/fsusb/ with full instructions which are "make", then copy it to somewhere in your PATH like /usr/local/bin.
        fsusb <file>             program board with <file> and verify
        fsusb --program <file>   program board with <file> and verify
        fsusb --verify <file>    verify board against <file>
        fsusb --read <file>      read board, saving result in <file>

        File is UBW-x2.hex

        Better still, I've just found everything in http://groups.yahoo.com/group/softrock40/files/9V1AL/UBW%20Emulator/

        UBW 16 or 32 - I have both, no difference in procedure.
        73 ... Sid.

        On 01/05/12 22:27, MIKE DURKIN wrote:

        I was trying to use onboard for sound out (speaker) and another USB card for microphone ... the C-media is for I/Q in/out....

        Can you lead me to some good UBW (32) info?

        -----Original Message-----

        From: Sid Boyce
        Sent: 1 May 2012 20:28:43 GMT
        To: softrock40@yahoogroups.com
        Subject: Re: [softrock40] Re: Linux

        Hmmmm.....I have used 3 sound cards before, on-board sound, PCI card 1 and E-MU 0404 USB card 2.

        Card 0 for Mic/SPKR and card 1 or 2 for I-Q without problems.
        I was using card 2 to test out UAC2 at 192K samplerate when Alex first wrote the UAC2 code and I didn't have a SDR-Widget. Besides he wanted to know if it would work with any other 192K capable sound card.

        I happily reported back to Alex that it worked with the E-MU 0404 USB.

        All it took was changing ~/.quisk_conf.py from hw:1 to hw:2.
        73 ... Sid.
        On 01/05/12 18:58, MIKE DURKIN wrote:

        Guess Quisk dosent like 3 soundcards ....

        Linux not working right with my onboard S/C. Mic is just hash ... actually has 3 mic inputs,  only shows 2.... none work ..lol

        -----Original Message-----

        From: Sid Boyce
        Sent: 1 May 2012 10:52:36 GMT
        To: softrock40@yahoogroups.com
        Subject: Re: [softrock40] Re: Linux

        That'sprobably my fault, initially the vk6jbl files went into the top directory as there was no softrock directory until Jim had hands on the Ensemble RXTX and saw what was needed to support it.
        73 ... Sid.

        On 01/05/12 07:18, MIKE DURKIN wrote:
        Jesh....talk about simple ...

        After remming out the call for the Mobo ...

        changing usbsoftrock", '-a', '-d', '-m 2') in "quisk_hardware_vk6jbl.py" made no changes ....

        Even changing the offset and other things had no effect ....

        I had noticed that a :Starting daemon..." kept happening .. so i was following the call outs .. when i noticed that
        "import quisk_hardware_vk6jbl as quisk_hardware" was not called "from softrock " like the  Mobo was called "from softrock import quisk_widgets_mobo as quisk_widgets"

        Yea .. i was editing the "quisk_hardware_vk6jbl" from the softrock folder -- not the one that i missed in the quisk folder ....

        moving on ....

        Mike KC7NOA

        To: softrock40@yahoogroups.com
        From: sboyce@...
        Date: Tue, 1 May 2012 04:57:09 +0100
        Subject: Re: [softrock40] Re: Linux

        havea look at quisk_hardware_vk6jbl.py
        The line I have commented out.
        #    self.usbsoftrock_pid = os.spawnlp(os.P_NOWAIT, "usbsoftrock", "usbsoftrock", '-a', '-d', '-m 2')

        If that doesn't work as expected you can try "-m 0.5" in case the program logic expects "0.5x4".
        Unfortunately x4 is what most SDR's use whereas it's x2 for the UHFSDR.
        73 ... Sid.

        On 01/05/12 03:37, MIKE DURKIN wrote:

        Ok ....

        Did see that and thought it was something to do with band pass filteris setting....

        The reame with usbsoftrock had me to believe that "usbsoftrock -a -m 2" was what I needed.

        I want the same multiplier no matter what - even to 600mhz its still the same.

        -----Original Message-----

        From: Sid Boyce
        Sent: 1 May 2012 01:19:24 GMT
        To: softrock40@yahoogroups.com
        Subject: Re: [softrock40] Re: Linux

        I'venever used the ATTiny85 with UHFSDR but this is what I had to do with the UBW and the SDR-Widget.
        Details of which eeprom it gets store on I don't remember if it was the SDR-Widget or eeprom on the si570, I'd have to check the si570 pdf.
        I did point out these steps in an earlier post, may be to a different group. You can use the following script.

        --------------------------CUT -------------------
        usbsoftrock set si570_multiplier 0 0.5
        usbsoftrock set si570_multiplier 1 0.5
        usbsoftrock set si570_multiplier 2 0.5
        sbsoftrock set si570_multiplier3 0.5
        usbsoftrock set si570_multiplier 4 0.5
        usbsoftrock set si570_multiplier 5 0.5
        usbsoftrock set si570_multiplier 6 0.5
        usbsoftrock set si570_multiplier 7 0.5
        usbsoftrock set si570_multiplier 8 0.5

        I have only had to execute this script once and the UHFSDR's frequency is where it should be. I don't know if the ATTiny85 supports per band multipliers, if not just one "usbsoftrock set si570_multiplier 0.5" is all that's needed. Above, the script sets a multiplier for each band.
        73 ... Sid.

        On 30/04/12 23:24, MIKE DURKIN wrote:

        Im not sure if the AVR settings are ignored .... I previously had PE0FKO 15.15 working with a X2 of requested vfo

        Linrad's Si570 settings were for a X2 ....

        Quisk is also set for a "-m 2" but im quite confused which ".py" file is actually sending commands to the Si570(PE0FKO15.15)

        I did have some sort of sound this morning - the Tx from my HF radio sounded terrible and um not sure if I was hearing a harmonic. Also WWVH/WWVB were verry week this morning and threw me off the course -

        Ill keep at it .... I want to pull my pre/driver and use the manual pre-selector with the computer and use a UHFSDR2GO in a man pack with a yet to source and build 1W amp.

        Mike KC7NOA

        Ill try a build rather just pasting the files from you into my working folder ....

        (Message over 64 KB, truncated)
      Your message has been successfully submitted and would be delivered to recipients shortly.