Loading ...
Sorry, an error occurred while loading the content.

Two identical USB sound cards at the same time? (Windows XP)

Expand Messages
  • Sivan
    Hi, Did anybody manage to get two identical USB sound cards to work at the same time under Windows XP? I have two Creative sound cards, and each works fine
    Message 1 of 15 , Jan 1, 2011
    View Source
    • 0 Attachment
      Hi,

      Did anybody manage to get two identical USB sound cards to work at the same time under Windows XP?

      I have two Creative sound cards, and each works fine under XP. But when I plug both of them in, one shows with a yellow exclamation mark in the device manager, and it's not usable.

      I'm trying to work with two Softrocks in parallel. The radio setup works if I route the audio to two different computers, but I'd like to do it with one computer.

      Thanks, Sivan
    • Alan
      ... From: Sivan Subject: [softrock40] Two identical USB sound cards at the same time? (Windows XP) ... I have two Creative SB24 Live! USB devices that work
      Message 2 of 15 , Jan 1, 2011
      View Source
      • 0 Attachment
        ----- Original Message -----
        From: "Sivan"
        Subject: [softrock40] Two identical USB sound cards at the same time?
        (Windows XP)



        > Did anybody manage to get two identical USB sound cards to work at the
        > same time under Windows XP?
        >

        I have two Creative SB24 Live! USB devices that work together.
        Windows identifies them as Creative Live! 24 Bit External(1) and (2)

        73 Alan G4ZFQ
      • Sivan
        I have the same cards. I ll double check to see if I can get both to work. Thanks a lot, Sivan
        Message 3 of 15 , Jan 1, 2011
        View Source
        • 0 Attachment
          I have the same cards. I'll double check to see if I can get both to work. Thanks a lot, Sivan

          --- In softrock40@yahoogroups.com, "Alan" <alan4alan@...> wrote:
          >
          >
          > ----- Original Message -----
          > From: "Sivan"
          > Subject: [softrock40] Two identical USB sound cards at the same time?
          > (Windows XP)
          >
          >
          >
          > > Did anybody manage to get two identical USB sound cards to work at the
          > > same time under Windows XP?
          > >
          >
          > I have two Creative SB24 Live! USB devices that work together.
          > Windows identifies them as Creative Live! 24 Bit External(1) and (2)
          >
          > 73 Alan G4ZFQ
          >
        • Sivan
          Alan, which version of Windows are you using and which version of the driver? I upgraded to the latest drivers from Creative and I still have the same problem;
          Message 4 of 15 , Jan 1, 2011
          View Source
          • 0 Attachment
            Alan, which version of Windows are you using and which version of the driver? I upgraded to the latest drivers from Creative and I still have the same problem; the first card I insert works but the second does not.

            I am running on XP (SP3) and the driver is dated 5/16/2005.

            The creative web site has newer drivers, but only for Vista and Windows 7.

            Sivan

            --- In softrock40@yahoogroups.com, "Alan" <alan4alan@...> wrote:
            >
            >
            > ----- Original Message -----
            > From: "Sivan"
            > Subject: [softrock40] Two identical USB sound cards at the same time?
            > (Windows XP)
            >
            >
            >
            > > Did anybody manage to get two identical USB sound cards to work at the
            > > same time under Windows XP?
            > >
            >
            > I have two Creative SB24 Live! USB devices that work together.
            > Windows identifies them as Creative Live! 24 Bit External(1) and (2)
            >
            > 73 Alan G4ZFQ
            >
          • Alan
            ... From: Sivan Subject: [softrock40] Re: Two identical USB sound cards at the same time? (Windows XP) ... Ah! Same Windows but they seem to be using the
            Message 5 of 15 , Jan 1, 2011
            View Source
            • 0 Attachment
              ----- Original Message -----
              From: "Sivan"
              Subject: [softrock40] Re: Two identical USB sound cards at the same time?
              (Windows XP)


              > Alan, which version of Windows are you using and which version of the
              > driver? I upgraded to the latest drivers from Creative and I still have
              > the same problem; the first card I insert works but the second does not.
              >
              > I am running on XP (SP3)

              Ah!
              Same Windows but they seem to be using the generic USB drivers.
              Presumably I did not install the Creative drivers.
              Funny, but one I use for SDRServer and that works at 96KHz, receive only. I
              did not think the generic drivers would work at 96KHz.
              It says Microsoft - 1 July 2001 version 5.1.2535.0

              I think you will have to list and delete the Creative drivers to try the
              generic drivers. If you do not it will automatically re-install the Creative
              ones..

              73 Alan G4ZFQ
            • aa9wqham@aol.com
              I have also ran 2 of the same sound cards. I have found that some cards won t allow it. Not all will allow it. Larry Sent on the Sprint® Now Network from my
              Message 6 of 15 , Jan 1, 2011
              View Source
              • 0 Attachment
                I have also ran 2 of the same sound cards. I have found that some cards won't allow it. Not all will allow it.

                Larry

                Sent on the Sprint® Now Network from my BlackBerry®


                From: "Alan" <alan4alan@...>
                Sender: softrock40@yahoogroups.com
                Date: Sat, 1 Jan 2011 19:18:15 -0000
                To: <softrock40@yahoogroups.com>
                ReplyTo: softrock40@yahoogroups.com
                Subject: Re: [softrock40] Re: Two identical USB sound cards at the same time? (Windows XP)

                 


                ----- Original Message -----
                From: "Sivan"
                Subject: [softrock40] Re: Two identical USB sound cards at the same time?
                (Windows XP)

                > Alan, which version of Windows are you using and which version of the
                > driver? I upgraded to the latest drivers from Creative and I still have
                > the same problem; the first card I insert works but the second does not.
                >
                > I am running on XP (SP3)

                Ah!
                Same Windows but they seem to be using the generic USB drivers.
                Presumably I did not install the Creative drivers.
                Funny, but one I use for SDRServer and that works at 96KHz, receive only. I
                did not think the generic drivers would work at 96KHz.
                It says Microsoft - 1 July 2001 version 5.1.2535.0

                I think you will have to list and delete the Creative drivers to try the
                generic drivers. If you do not it will automatically re-install the Creative
                ones..

                73 Alan G4ZFQ

              • Sivan
                Thanks Alan, I ll try to do that. I filed a support request on the Creative web site and got the response below response (no editing, just cut-and-paste).
                Message 7 of 15 , Jan 1, 2011
                View Source
                • 0 Attachment
                  Thanks Alan, I'll try to do that.

                  I filed a support request on the Creative web site and got the response below response (no editing, just cut-and-paste). Didn't help me resolve the problem, but taught me something about the quality of Creative's drivers and support, as well as some important lessons in British spelling. Here it is:

                  Dear Sivan,

                  Thank you for writing in to Creative.

                  With regards to your enquiry, I am sorry to inform you that we never recomment customers to use two sound card on one computer because there may be chrashes.

                  Sorry for the inconvenience caused.

                  If you still require assistance, please reply to this email and include any previous correspondence to ensure a quick response.

                  Best Regards,

                  Lerry
                  Worldwide Customer Response
                  Creative

                  --- In softrock40@yahoogroups.com, "Alan" <alan4alan@...> wrote:
                  >
                  >
                  > ----- Original Message -----
                  > From: "Sivan"
                  > Subject: [softrock40] Re: Two identical USB sound cards at the same time?
                  > (Windows XP)
                  >
                  >
                  > > Alan, which version of Windows are you using and which version of the
                  > > driver? I upgraded to the latest drivers from Creative and I still have
                  > > the same problem; the first card I insert works but the second does not.
                  > >
                  > > I am running on XP (SP3)
                  >
                  > Ah!
                  > Same Windows but they seem to be using the generic USB drivers.
                  > Presumably I did not install the Creative drivers.
                  > Funny, but one I use for SDRServer and that works at 96KHz, receive only. I
                  > did not think the generic drivers would work at 96KHz.
                  > It says Microsoft - 1 July 2001 version 5.1.2535.0
                  >
                  > I think you will have to list and delete the Creative drivers to try the
                  > generic drivers. If you do not it will automatically re-install the Creative
                  > ones..
                  >
                  > 73 Alan G4ZFQ
                  >
                • Sivan
                  This did the trick, thanks a lot! It was VERY difficult to remove the Creative driver. The instructions from the Creative web site did not work, a driver
                  Message 8 of 15 , Jan 3, 2011
                  View Source
                  • 0 Attachment
                    This did the trick, thanks a lot!

                    It was VERY difficult to remove the Creative driver. The instructions from the Creative web site did not work, a driver removal program did not work (not completely), so eventually I resorted to erasing any trace of the USB product ID from the registry and from c:\windows.

                    This allowed Windows to treat the cards as new hardware and to attach the Microsoft drivers for them. Now I can indeed use the two cards simultaneously.

                    I'm now running two versions on WSPR on different bands using two Softrock receivers driven by an antenna splitter.

                    Sivan

                    --- In softrock40@yahoogroups.com, "Alan" <alan4alan@...> wrote:
                    >
                    >
                    > ----- Original Message -----
                    > From: "Sivan"
                    > Subject: [softrock40] Re: Two identical USB sound cards at the same time?
                    > (Windows XP)
                    >
                    >
                    > > Alan, which version of Windows are you using and which version of the
                    > > driver? I upgraded to the latest drivers from Creative and I still have
                    > > the same problem; the first card I insert works but the second does not.
                    > >
                    > > I am running on XP (SP3)
                    >
                    > Ah!
                    > Same Windows but they seem to be using the generic USB drivers.
                    > Presumably I did not install the Creative drivers.
                    > Funny, but one I use for SDRServer and that works at 96KHz, receive only. I
                    > did not think the generic drivers would work at 96KHz.
                    > It says Microsoft - 1 July 2001 version 5.1.2535.0
                    >
                    > I think you will have to list and delete the Creative drivers to try the
                    > generic drivers. If you do not it will automatically re-install the Creative
                    > ones..
                    >
                    > 73 Alan G4ZFQ
                    >
                  • Alan
                    ... From: Sivan Subject: [softrock40] Re: Two identical USB sound cards at the same time? (Windows XP) ... Well done! I did not think it would be easy. I
                    Message 9 of 15 , Jan 3, 2011
                    View Source
                    • 0 Attachment
                      ----- Original Message -----
                      From: "Sivan"
                      Subject: [softrock40] Re: Two identical USB sound cards at the same time?
                      (Windows XP)


                      >
                      > It was VERY difficult to remove the Creative driver.

                      Well done! I did not think it would be easy.
                      I expect it only works at 16 bits but the Windows driver is better than
                      Creative if you want to run two of them. I wonder what is the limit to the
                      number of cards.

                      73 Alan G4ZFQ
                    • Sivan
                      ... If I remember correctly, the 16-bit versus 24-bit was the reason that I installed the Creative drivers in the first place. If somebody knows whether this
                      Message 10 of 15 , Jan 4, 2011
                      View Source
                      • 0 Attachment
                        --- In softrock40@yahoogroups.com, "Alan" <alan4alan@...> wrote:
                        >
                        > Well done! I did not think it would be easy.
                        > I expect it only works at 16 bits but the Windows driver is better than
                        > Creative if you want to run two of them. I wonder what is the limit to the
                        > number of cards.
                        >
                        > 73 Alan G4ZFQ

                        If I remember correctly, the 16-bit versus 24-bit was the reason that I installed the Creative drivers in the first place. If somebody knows whether this really makes a difference, I'll be happy to hear about it.

                        The two copies of WSPR produces spots that seemed pretty normal to me, compared to earlier nights, and with a similar geographic range. So I don't think that switching the drivers has a bad effect on WSPR. Maybe WSPR only reads 16 bits; I can check.

                        Sivan
                      • G3RIR
                        I have just completed a Softrock Lite II and used the band specific components for 30m but I intend to use it on the IF of my TS2000. The IF is 10.695 MHz but
                        Message 11 of 15 , Jan 4, 2011
                        View Source
                        • 0 Attachment
                          I have just completed a Softrock Lite II and used the band specific
                          components for 30m but I intend to use it on the IF of my TS2000. The IF is
                          10.695 MHz but an article I have found by K4DSP suggests setting the
                          Softrock at 10.680 MHz to avoid a "DC hump".

                          I have left one turn off the band-pass filter coil in the Softrock so that
                          the band pass moves up a little from 10.1 MHz (30m band). I have also built
                          a QRP2000 which has an Si570. I intend to disable the xtal oscillator in the
                          Softrock and inject the QRP2000 signal into the divider of the Softrock.

                          I understand that the way that the Softrock works "normally" for 30m is that
                          the xtal is on 13.5 MHz which when divided by 4 in the divider is 3.375 MHz
                          but this is rich in harmonics so the 3rd harmonic at 10.125 MHz is available
                          which of course is in the 30m band and this is injected into the mixer.

                          Now my question; the QRP2000 is capable of a very wide range of frequencies
                          and before I go "chasing my tail" which frequency should I use?

                          One possibility is to set it to 14.240 MHz so that dividing by 4 and
                          multiplying by 3 gives me 10.68 and this would be very similar to the
                          "basic" 30m setup. But it would seem to me better to set the QRP2000 to
                          42.72 MHz and this gives 10.68 from the divider and not relying on the
                          presence of harmonics.

                          One significant problem with the 14.24 MHz setting is that is well inside
                          the 20m band and the divided by 4 frequency of 3.56 MHz is within the 80m
                          band. I know that I will not use an antenna on the Softrock as it be
                          connected (via a buffer) to the IF of the TS2000 but I still suspect big 20m
                          signals to be picked up.

                          So what do the gurus think?

                          I have already built a Softrock for 80m and it is outstandingly good.

                          73

                          HNY to Tony Parks and to all

                          Neil, G3RIR
                        • Alan
                          ... From: G3RIR Subject: [softrock40] Softrock frequency for 10.680 MHz ... It should be no more than just a spike, but yes, this is the usual way of doing
                          Message 12 of 15 , Jan 4, 2011
                          View Source
                          • 0 Attachment
                            ----- Original Message -----
                            From: "G3RIR"
                            Subject: [softrock40] Softrock frequency for 10.680 MHz


                            >I have just completed a Softrock Lite II and used the band specific
                            > components for 30m but I intend to use it on the IF of my TS2000. The IF
                            > is
                            > 10.695 MHz but an article I have found by K4DSP suggests setting the
                            > Softrock at 10.680 MHz to avoid a "DC hump".
                            >

                            It should be no more than just a spike, but yes, this is the usual way of
                            doing it.

                            >But it would seem to me better to set the QRP2000 to
                            > 42.72 MHz and this gives 10.68 from the divider and not relying on the
                            > presence of harmonics.
                            >

                            This is the normal way with Si570 Softrocks.
                            The "subharmonic" way is used when the requirement would be for crystals on
                            unusually high fundamentals.

                            73 Alan G4ZFQ
                          • Tony Parks
                            Hi Neil, The 14.089 MHz crystal provided in the Lite II Combined kit may be used to give a 1/3 sub-harmonic sampled center frequency of about 10.56 MHz. With
                            Message 13 of 15 , Jan 4, 2011
                            View Source
                            • 0 Attachment
                              Hi Neil,

                              The 14.089 MHz crystal provided in the Lite II Combined kit may be used to give a 1/3 sub-harmonic sampled center frequency of about 10.56 MHz.   With 96kHz soundcard sampling the band coverage would be from about 10.51 MHz to 10.61 MHz.  Not sure, but would this cover your IF band?

                              The QSD circuit is sensitive to odd harmonic signals and the response to the 3rd harmonic of its clocking frequency is only down about 4 dB from the fundamental response.

                              73,
                              --
                              Tony Parks
                              kb9yig@...
                              http://www.kb9yig.com
                              
                              


                              On Tue, 2011-01-04 at 09:24 +0000, G3RIR wrote:
                               
                              I have just completed a Softrock Lite II and used the band specific
                              components for 30m but I intend to use it on the IF of my TS2000. The IF is
                              10.695 MHz but an article I have found by K4DSP suggests setting the
                              Softrock at 10.680 MHz to avoid a "DC hump".

                              I have left one turn off the band-pass filter coil in the Softrock so that
                              the band pass moves up a little from 10.1 MHz (30m band). I have also built
                              a QRP2000 which has an Si570. I intend to disable the xtal oscillator in the
                              Softrock and inject the QRP2000 signal into the divider of the Softrock.

                              I understand that the way that the Softrock works "normally" for 30m is that
                              the xtal is on 13.5 MHz which when divided by 4 in the divider is 3.375 MHz
                              but this is rich in harmonics so the 3rd harmonic at 10.125 MHz is available
                              which of course is in the 30m band and this is injected into the mixer.

                              Now my question; the QRP2000 is capable of a very wide range of frequencies
                              and before I go "chasing my tail" which frequency should I use?

                              One possibility is to set it to 14.240 MHz so that dividing by 4 and
                              multiplying by 3 gives me 10.68 and this would be very similar to the
                              "basic" 30m setup. But it would seem to me better to set the QRP2000 to
                              42.72 MHz and this gives 10.68 from the divider and not relying on the
                              presence of harmonics.

                              One significant problem with the 14.24 MHz setting is that is well inside
                              the 20m band and the divided by 4 frequency of 3.56 MHz is within the 80m
                              band. I know that I will not use an antenna on the Softrock as it be
                              connected (via a buffer) to the IF of the TS2000 but I still suspect big 20m
                              signals to be picked up.

                              So what do the gurus think?

                              I have already built a Softrock for 80m and it is outstandingly good.

                              73

                              HNY to Tony Parks and to all

                              Neil, G3RIR




                            • Dave - WB6DHW
                              Neil: Much better to set it to 42.72 MHz. If you set it to 14,24m the receiver will receive 3.56 MHz better than your IF frequency. The original reason for
                              Message 14 of 15 , Jan 4, 2011
                              View Source
                              • 0 Attachment
                                Neil:
                                Much better to set it to 42.72 MHz. If you set it to 14,24m the receiver
                                will receive 3.56 MHz better than your IF frequency. The original reason for
                                the harmonic mixing was that 42 MHz crystals are either hard to find or are
                                expensive.

                                Dave - WB6DHW
                                <http://wb6dhw.com>

                                On 1/4/2011 1:24 AM, G3RIR wrote:
                                > I have just completed a Softrock Lite II and used the band specific
                                > components for 30m but I intend to use it on the IF of my TS2000. The IF is
                                > 10.695 MHz but an article I have found by K4DSP suggests setting the
                                > Softrock at 10.680 MHz to avoid a "DC hump".
                                >
                                > I have left one turn off the band-pass filter coil in the Softrock so that
                                > the band pass moves up a little from 10.1 MHz (30m band). I have also built
                                > a QRP2000 which has an Si570. I intend to disable the xtal oscillator in the
                                > Softrock and inject the QRP2000 signal into the divider of the Softrock.
                                >
                                > I understand that the way that the Softrock works "normally" for 30m is that
                                > the xtal is on 13.5 MHz which when divided by 4 in the divider is 3.375 MHz
                                > but this is rich in harmonics so the 3rd harmonic at 10.125 MHz is available
                                > which of course is in the 30m band and this is injected into the mixer.
                                >
                                > Now my question; the QRP2000 is capable of a very wide range of frequencies
                                > and before I go "chasing my tail" which frequency should I use?
                                >
                                > One possibility is to set it to 14.240 MHz so that dividing by 4 and
                                > multiplying by 3 gives me 10.68 and this would be very similar to the
                                > "basic" 30m setup. But it would seem to me better to set the QRP2000 to
                                > 42.72 MHz and this gives 10.68 from the divider and not relying on the
                                > presence of harmonics.
                                >
                                > One significant problem with the 14.24 MHz setting is that is well inside
                                > the 20m band and the divided by 4 frequency of 3.56 MHz is within the 80m
                                > band. I know that I will not use an antenna on the Softrock as it be
                                > connected (via a buffer) to the IF of the TS2000 but I still suspect big 20m
                                > signals to be picked up.
                                >
                                > So what do the gurus think?
                                >
                                > I have already built a Softrock for 80m and it is outstandingly good.
                                >
                                > 73
                                >
                                > HNY to Tony Parks and to all
                                >
                                > Neil, G3RIR
                                >
                                >
                                >
                                >
                              • lbeugnet
                                ... They were quartz for old frequencies for radiocommand planes or boats... Take a look around this hobby... ;-) 73 Laurent F6GOX
                                Message 15 of 15 , Jan 5, 2011
                                View Source
                                • 0 Attachment
                                  Le 04/01/2011 20:50, Dave - WB6DHW a écrit :
                                  > 42 MHz crystals are either hard to find or are
                                  > expensive.

                                  They were quartz for old frequencies for radiocommand planes or boats...
                                  Take a look around this hobby... ;-)

                                  73 Laurent F6GOX
                                Your message has been successfully submitted and would be delivered to recipients shortly.