Loading ...
Sorry, an error occurred while loading the content.

Re: [softrock40] Re: USB driver install for Softrock Ensemble RX

Expand Messages
  • Dan
    Hi Dick, Have you tried to connect Softrock before starting the notebook? It is working then? If yes, then I m afraid that this is the only option till this
    Message 1 of 45 , Dec 2, 2010
    • 0 Attachment
      Hi Dick,

      Have you tried to connect Softrock before starting the notebook?
      It is working then?

      If yes, then I'm afraid that this is the only option till this bug is solved in the AVR firmware (or maybe in hardware?).
      Please check my thread regarding a similar issue. Even if I try to restart the controller from software, after this is shown as "Unknown Device".

      73
      Dan
      YO3GGX
      WebSDR http://yo3ggx.1p.ro:8765/

      On 12/2/2010 9:58 AM, dickallen wrote:
       

      Hi Dan,
      Actually, the Device Interface ID exists in Device Manager. It is USB\VIF_0000&PID_0000\7&350CD513&0&1.
      So you are correct--thePID is 0000:0000. I'm not sure how to take out other USB devices as this is a MacBook Pro and I have no other external USB devices plugged-in.

      There are several USB busses. One USB bus has the internal keyboard/trackpad and the IR receiver. The second US bus has the external softrock reported as DG8SAQ-I2C with product ID 0x0001, Vendor ID: 0x0e0f, Version 1.0, Serial Number PE0FKO-0, Manufacturer www.obdev.at, Location ID: 0x06200000. Also on this second USB bus is a BRCM2046 Hub with the Bluetooth USB Host Controller. One High Speed USB Bus has the Internal Memory Card Reader. Another High Speed Bus has the built-in iSight camera.

      Without disassembling the laptop (and maybe unsoldering some chips), I'm unable to disconnect other devices before plugging-in the softrock.

      Regards,
      Dick AA6UZ

      --- In softrock40@yahoogroups.com, Dan <danto@...> wrote:
      >
      > Hi Dick,
      >
      > Whet you get "Unknown Device" please chech the VID:PID for that device
      > and you will see that it is 0000:0000 so for sure no driver can be
      > installed for such a device..:-)
      > The reason is a problem with USB devices enumeration when other devices
      > are plugged in the USB ports before the Softrock.
      > Try to take out any other USB device and then plug the Softrock and see
      > if this will solve the problem (device correctly recognized by windows).
      > I still think this is a bug not yet solved in any revision of the firmware.
      >
      > 73
      > Dan
      > YO3GGX
      > WebSDR http://yo3ggx.1p.ro:8765/
      >


    • pe0fko
      The xtal speed from the internal RC oscillator is not that big problem. The inter RC is running on 8MHz and and drive a PLL to generate 16.5MHz to run the
      Message 45 of 45 , Jul 27 12:36 AM
      • 0 Attachment
        The xtal speed from the internal RC oscillator is not that big problem.
        The inter RC is running on 8MHz and and drive a PLL to generate 16.5MHz to run the code. The PLL is synced by software with the USB signals of the USB master (PC), not that big problem.

        There is a problem with the at tiny avr chips and that is they are not designed (hardware and interrupt) to handle a USB signal's direct by hardware like a lot of the new avr (and other) microcontrolers.

                          
        73, Fred
        PE0FKO




        2011/7/25 hrpch <hrpch@...>
         

        I've strugged with this issue for several days, since I was stumped in the process of building my kit at the stage where the driver needs to be installed. "USB device not recognized" failure !!!

        After considerable wild goose chasing, I've come to the conclusion it has to do with timing of the USB signals generated back from the ATTiny85. I remember a while back working with the PIC 18F14K50 and reading on the data sheet that, for USB, the microcontroller has to run on an external 48Mhz crystal-controlled clock instead of the internal oscillator, in order to meet the strict timing requirements of the USB protocol. Well, look at the ATTiny... it's running on an internal clock !!!!! (8Mhz). It's freqiuency drifts with temperature and voltage, according to the data sheet. It can be tweaked via firmware but there will still be variations from one device to another. That's why it works for some people but not for others, some of the time but not all the time. Sometimes it's on time, sometimes not.

        With all due respect to the Softrock designers, we have a design flaw here. There are not enough pins for an external xtal on the ATTiny... plus the other tasks. We need a different microcontroller that can handle USB more accurately. How about the PIC 18F14K50 ?
        ----------------------------------------------------------



        --- In softrock40@yahoogroups.com, Dick Allen <rallen@...> wrote:
        >
        > Simon,
        > I had a similar problem installing the driver on my PowerMac running XP under Vmware and solved it thanks to Robin's suggestion. See below:
        > 73
        > Dick AA6UZ
        >
        > On Jan 9, 2011, at 10:32 AM, mrszymon wrote:
        > >
        > SUCCESS!!! Robin's suggestion about editing the VmWare .vmx file to add the line
        > usb.quirks.device0= "0x16c0:0x05dc skip-reset"
        > allowed Windows to recognize the device and allowed me to install the drivers.
        >
        > Robin, Thank you so much. And thanks to all the others who helped me along the way. I have been able to run WinRad.
        >
        > I still can't pickup any signals on my short ~20 ft wire antenna put I'm making progress.
        > Regards to all,
        > Dick AA6UZ
        >
        > --- In softrock40@yahoogroups.com, pe0fko <pe0fko@> wrote:
        > >
        > > OK Robin, nice result!!
        > >
        > > The VMware docs say :
        > > >> These issues can occur because the USB devices do not implement the USB
        > > protocol as expected by Fusion.
        > > But what is the "USB protocol as expected by Fusion", is that different from
        > > the USB 1 specs? Looks like a VMware problem to me.
        > >
        > > Is it only a MAC (VMware Fusion) problem or are there others with the
        > > problem in VMware Player in Windows? (for me it is working without the
        > > tweak).
        > >
        > > --
        > > 73, Fred
        > > PE0FKO
        > >
        > >
        > > 2010/12/2 rdavies6 <rdavies6@>
        > >
        > > >
        > > >
        > > > Dick
        > > >
        > > > Given Fred had some success in his installation I was encouraged to spend a
        > > > few hours playing with options and have made some progress. I tried a couple
        > > > of options in my VMWare config and one seems to have made a positive
        > > > difference:
        > > >
        > > > 1) Add a single USB quirk to the VMware config file:
        > > >
        > > > usb.quirks.device0= "0x16c0:0x05dc skip-reset"
        > > >
        > > > To add the quirk you to firstly find the virtual machine bundle in the OS X
        > > > file system (
        > > > http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1007599)
        > > > - the default bundle location is Macintosh HD/Users/<User
        > > > name>/Documents/Virtual Machines.
        > > >
        > > > Open up the bundle and edit the .vmx file for the guest OS to add the
        > > > USB.quirk (
        > > > http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1014782
        > > > ).
        > > >
        > > > More detailed instructions on the format of USB quirks can be found here -
        > > > http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1025256
        > > >
        > > > 2) I removed a "usb.generic.skipsetconfig" line from my .vmx file (this may
        > > > just have been a remnant in my config from previous troubleshooting attempts
        > > > though)
        > > >
        > > > 3) Powered the Softrock up before starting VMWare (this doesn't appear to
        > > > be a significant step though as I could also add the Softrock after the VM
        > > > had started)
        > > >
        > > > 4) Auto attached the Softrock at the guest OS startup (VMware should auto
        > > > connect devices that were previously attached in earlier sessions) (this
        > > > doesn't appear to be a critical step as manually attaching also subsequently
        > > > worked)
        > > >
        > > > Success!! The Softrock attached and I could then install the driver. The
        > > > process should be OK for VMWare platforms other than Fusion as well I
        > > > believe (although i can't test this as I only have Fusion)
        > > >
        > > > I also tried the same process with other USB devices (a Griffin iMac and
        > > > some ATEN rs232/usb adapters) attached to the machine - and got the same
        > > > success.
        > > >
        > > > I would be interested if this works for you..and would be happy to help
        > > > troubleshoot if your still not getting any joy.
        > > >
        > > > 73
        > > >
        > > > Robin
        > > > G7VKQ
        > Dick Allen
        > rallen@...
        >


      Your message has been successfully submitted and would be delivered to recipients shortly.