Loading ...
Sorry, an error occurred while loading the content.
 

Re: USB driver install for Softrock Ensemble RX

Expand Messages
  • rdavies6
    Windows has many foibles, and USB devices equally share those foibles. However I do agree that the recent discussion is very much related to the behavior of
    Message 1 of 45 , Dec 1, 2010
      Windows has many foibles, and USB devices equally share those foibles. However I do agree that the recent discussion is very much related to the behavior of USB devices under virtualization software, and this might not necessarily even be a function of Windows handling of USB devices. I would freely accept that the solution here may be in the hands of VMWare themselves...as this may be a bug in their software, in which case we can expect a solution to be some way away. I'm also aware that it's not only devices like Softrocks that display this behavior either - I know HTC phones also have similar issues under VMWare. However I do know the AVR / Obdev device drivers can work in a VM - as they are used in the VNWA, and I have no problems with that on my specific VM environment. Frustratingly the Softrock fails to enumerate though...

      In my case I'd like to use a VM for convenience ... as the only physical Windows device I have is a work machine...and I really shouldn't be using it for anything but work. However I tried it out to prove my particular Softrock was built OK and worked on a standard physical Windows installation. It would be unrealistic to expect anyone to resolve this problem, but in the spirt of sharing knowledge I can contribute data about the observed behavior and I'm certainly willing to help someone (with more knowledge than I :-) ) diagnose the concerns - if there's enough interest. I have enough knowledge to obtain the Windows USB stack level events that occur....but sort of run out of steam at that point

      73
      Robin
      G7VKQ

      --- In softrock40@yahoogroups.com, "Alan" <alan4alan@...> wrote:
      >
      >
      > ----- Original Message -----
      > From: "The Silver Fox"
      > Subject: RE: [softrock40] Re: USB driver install for Softrock Ensemble RX
      >
      >
      > >I don't know how many times this has to happen before the group admits it
      > >is
      > > a problem. Read through the messages on the web site for observations and
      > > suggestions. A lot of people have recommended work arounds but I am
      > > unconvinced that this issue is not understood and that all we are doing is
      > > curing some symptoms not the root cause. My opinion is that it is
      > > probably
      > > related to the horribly handicapped hardware management particularly in
      > > the
      > > older versions of windows.
      >
      > Most of the posts come down to three things. Nobody reads or searches old
      > posts so the same things come along regularly. Sometimes the same question
      > is asked the day after it has been answered.
      >
      > 1) Windows way of hiding an unknown device so that an "expert" user has to
      > uninstall it and go through the correct procedure. I think in most cases
      > this is the big problem.
      > It could be eased by having an installation program like most other USB
      > devices. Until someone comes up with one we have to make do with what we
      > have.
      > 2) Sometimes another USB device blocks the detection of the Softrock device.
      > Other than pulling out that device there seems no solution. Most seem to
      > find that once the Softrock driver has been installed it is best to startup
      > with the Softrock connected and switched on.
      > 3) A hardware problem that requires fault finding.
      >
      > I do not think the problems are specific to the version of Windows. If a
      > Windows "issue" is involved we cannot do anything about it except use a
      > work-round.
      >
      > I'm not sure what you mean by "before the group admits it is a problem."
      > This group is a collection of people who ask questions and those that try to
      > help. Like most other groups there are some posts that just confuse the
      > situation further. I try to help but sometimes I have blundered and, like
      > other, given incorrect information.
      > Sometimes a member of the group with more specialised knowlege comes along
      > gives us a firmware or hardware solution for which we are grateful.
      >
      > The current topic is something new. Virtual Machine is in itself a
      > work-round. I have never used it but from what I read all versions have
      > their limitations and require additional knowlege.
      >
      > 73 Alan G4ZFQ
      >
      >
      >
      >
      >
      >
      > >> - In VMware add the device to the virtual machine ( "Virtual Machine" /
      > >> "Removable devices" / Enable the "dg8saq-i2c" ).
      > >> - Windows XP will ask for the driver, redirect it to the unzip driver
      > >> (NOT
      > >> into the amd64, ia64, w2k or x86 directory!!!) where the pe0fko.inf file
      > > is.
      > >>
      >
    • pe0fko
      The xtal speed from the internal RC oscillator is not that big problem. The inter RC is running on 8MHz and and drive a PLL to generate 16.5MHz to run the
      Message 45 of 45 , Jul 27, 2011
        The xtal speed from the internal RC oscillator is not that big problem.
        The inter RC is running on 8MHz and and drive a PLL to generate 16.5MHz to run the code. The PLL is synced by software with the USB signals of the USB master (PC), not that big problem.

        There is a problem with the at tiny avr chips and that is they are not designed (hardware and interrupt) to handle a USB signal's direct by hardware like a lot of the new avr (and other) microcontrolers.

                          
        73, Fred
        PE0FKO




        2011/7/25 hrpch <hrpch@...>
         

        I've strugged with this issue for several days, since I was stumped in the process of building my kit at the stage where the driver needs to be installed. "USB device not recognized" failure !!!

        After considerable wild goose chasing, I've come to the conclusion it has to do with timing of the USB signals generated back from the ATTiny85. I remember a while back working with the PIC 18F14K50 and reading on the data sheet that, for USB, the microcontroller has to run on an external 48Mhz crystal-controlled clock instead of the internal oscillator, in order to meet the strict timing requirements of the USB protocol. Well, look at the ATTiny... it's running on an internal clock !!!!! (8Mhz). It's freqiuency drifts with temperature and voltage, according to the data sheet. It can be tweaked via firmware but there will still be variations from one device to another. That's why it works for some people but not for others, some of the time but not all the time. Sometimes it's on time, sometimes not.

        With all due respect to the Softrock designers, we have a design flaw here. There are not enough pins for an external xtal on the ATTiny... plus the other tasks. We need a different microcontroller that can handle USB more accurately. How about the PIC 18F14K50 ?
        ----------------------------------------------------------



        --- In softrock40@yahoogroups.com, Dick Allen <rallen@...> wrote:
        >
        > Simon,
        > I had a similar problem installing the driver on my PowerMac running XP under Vmware and solved it thanks to Robin's suggestion. See below:
        > 73
        > Dick AA6UZ
        >
        > On Jan 9, 2011, at 10:32 AM, mrszymon wrote:
        > >
        > SUCCESS!!! Robin's suggestion about editing the VmWare .vmx file to add the line
        > usb.quirks.device0= "0x16c0:0x05dc skip-reset"
        > allowed Windows to recognize the device and allowed me to install the drivers.
        >
        > Robin, Thank you so much. And thanks to all the others who helped me along the way. I have been able to run WinRad.
        >
        > I still can't pickup any signals on my short ~20 ft wire antenna put I'm making progress.
        > Regards to all,
        > Dick AA6UZ
        >
        > --- In softrock40@yahoogroups.com, pe0fko <pe0fko@> wrote:
        > >
        > > OK Robin, nice result!!
        > >
        > > The VMware docs say :
        > > >> These issues can occur because the USB devices do not implement the USB
        > > protocol as expected by Fusion.
        > > But what is the "USB protocol as expected by Fusion", is that different from
        > > the USB 1 specs? Looks like a VMware problem to me.
        > >
        > > Is it only a MAC (VMware Fusion) problem or are there others with the
        > > problem in VMware Player in Windows? (for me it is working without the
        > > tweak).
        > >
        > > --
        > > 73, Fred
        > > PE0FKO
        > >
        > >
        > > 2010/12/2 rdavies6 <rdavies6@>
        > >
        > > >
        > > >
        > > > Dick
        > > >
        > > > Given Fred had some success in his installation I was encouraged to spend a
        > > > few hours playing with options and have made some progress. I tried a couple
        > > > of options in my VMWare config and one seems to have made a positive
        > > > difference:
        > > >
        > > > 1) Add a single USB quirk to the VMware config file:
        > > >
        > > > usb.quirks.device0= "0x16c0:0x05dc skip-reset"
        > > >
        > > > To add the quirk you to firstly find the virtual machine bundle in the OS X
        > > > file system (
        > > > http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1007599)
        > > > - the default bundle location is Macintosh HD/Users/<User
        > > > name>/Documents/Virtual Machines.
        > > >
        > > > Open up the bundle and edit the .vmx file for the guest OS to add the
        > > > USB.quirk (
        > > > http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1014782
        > > > ).
        > > >
        > > > More detailed instructions on the format of USB quirks can be found here -
        > > > http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1025256
        > > >
        > > > 2) I removed a "usb.generic.skipsetconfig" line from my .vmx file (this may
        > > > just have been a remnant in my config from previous troubleshooting attempts
        > > > though)
        > > >
        > > > 3) Powered the Softrock up before starting VMWare (this doesn't appear to
        > > > be a significant step though as I could also add the Softrock after the VM
        > > > had started)
        > > >
        > > > 4) Auto attached the Softrock at the guest OS startup (VMware should auto
        > > > connect devices that were previously attached in earlier sessions) (this
        > > > doesn't appear to be a critical step as manually attaching also subsequently
        > > > worked)
        > > >
        > > > Success!! The Softrock attached and I could then install the driver. The
        > > > process should be OK for VMWare platforms other than Fusion as well I
        > > > believe (although i can't test this as I only have Fusion)
        > > >
        > > > I also tried the same process with other USB devices (a Griffin iMac and
        > > > some ATEN rs232/usb adapters) attached to the machine - and got the same
        > > > success.
        > > >
        > > > I would be interested if this works for you..and would be happy to help
        > > > troubleshoot if your still not getting any joy.
        > > >
        > > > 73
        > > >
        > > > Robin
        > > > G7VKQ
        > Dick Allen
        > rallen@...
        >


      Your message has been successfully submitted and would be delivered to recipients shortly.