Loading ...
Sorry, an error occurred while loading the content.

Re: more info on: CW keying glitches with PSDR and RXTX 6.3

Expand Messages
  • Charles (WC5MC)
    Well Brent, If it were only easier I would recommend you test with Alex s UBW Emulator setup instead of the I2C-USB.
    Message 1 of 3 , Apr 30, 2010
    • 0 Attachment
      Well Brent,

      If it were only easier I would recommend you test with Alex's "UBW Emulator" setup instead of the I2C-USB.

      http://groups.yahoo.com/group/softrock40/files/9V1AL/UBW%20Emulator/

      http://www.sparkfun.com/commerce/product_info.php?products_id=8265


      -- Charles WC5MC



      --- In softrock40@yahoogroups.com, "Brent G DeWitt" <bdewitt@...> wrote:
      >
      > I switched to Rocky, and the same glitches are there. So PSDR is not the
      > problem.
      >
      >
      >
      > From: softrock40@yahoogroups.com [mailto:softrock40@yahoogroups.com] On
      > Behalf Of BD
      > Sent: Thursday, April 29, 2010 9:15 PM
      > To: softrock40@yahoogroups.com
      > Subject: [softrock40] CW keying glitches with PSDR and RXTX 6.3
      >
      >
      >
      >
      >
      > Looking at my transmit signal with a spectrum analyzer, I'm realizing I have
      > lots of "glitches" in my transmitted CW and I'm not sure what adjustments
      > might help. Here is the setup:
      >
      > - Softrock RXTX 6.3 with USB-I2C interface
      > - PowerSDR v1.19.3.15 SV1EIA
      > - Kent dual paddle into Softrock I2C-USB.
      > - Dual core 3.6 GHz Pentium running Windows XP Prof. with SP3
      > - Internal IDT audio adapter with ASIO4ALLv2 to reduce latency, buffer set
      > to 256 samples, 48 kHz, 24 bit.
      > - PSDR set to SDR-Si570 with USBtoI2C checked.
      > - PowerSDR buffer set to 2048 with 48k sample rate.
      > - PSDR keyer set to Primary SDR, Iambic.
      >
      > Latency is pretty low, but I get partial pulses as if the keyer software
      > isn't creating regular pulses.
      >
      > Other info:
      >
      > - CPU runs 10%-20%
      > - Nasty glitches at first key down and last key up.
      > - Output is good with about 28 dBm at the connector.
      > - Running the keyer at between 13 and 18 wpm.
      >
      > Another question, maybe associated; should a band, mode and VFO select front
      > panel selection groups blank out when key down?
      >
      > Lots of stuff to try here!
      >
      > Thanks in advance for any advise,
      >
      > Brent - AB1LF
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.