Loading ...
Sorry, an error occurred while loading the content.


Expand Messages
  • Mr Doug -
    Well if CFGSR sees the AVR (opening window) then I think you are working. I am not sure what you mean by windows does not recognize it? Rocky or any other SDR
    Message 1 of 13 , Jan 1, 2010
      Well if CFGSR sees the AVR (opening window) then I think you are working. I am not sure what you mean by windows does not recognize it? Rocky or any other SDR program would error or not work properly because it would expect the USB interface AND the SI570. Since you have no 570 yet then any error would be expected. I believe all of the SDR programs can be run without USB and 570 support in manual fixed frequency mode. The CFGSD program comes in handy to tune and configure the SI570 once you get that far. You can set the startup frequency for the SI570 and then you would not even need the USB connected to at least make the receiver work in the selected fixed frequency range. You can also run the CFGSR program simultaneously with any SDR program in fixed frequency mode to tune it. Not the way you would want it to be all the time but good for testing purposes.


      From: Ed - K9EW <k9ew57@...>
      To: softrock40@yahoogroups.com
      Sent: Sat, January 2, 2010 12:01:58 AM
      Subject: Re: [softrock40] USB FAILED DRIVER TEST


      Yes, I did use the CFGSR.exe and the SRDLL.dll files, and they recognized the USB device (but for some reason Windows doesn't recognize it).  It looked like I would be able to control the SDR with it, but there was a caution in the instructions not to try that until the Si570 was installed.

      Something I forgot to mention in my earlier post is that I uninstalled Rocky, and the Drivers (sounds like a rock group, doesn't it).  And then I reinstalled them.  This could have made a difference after so many other failed attempts.

      I'm going to assume that it's working, and proceed with the building to confirm it.

      Thanks again to you and Jose for sticking with me and getting me over this bump.

      ed - k9ew

      On Fri, Jan 1, 2010 at 10:36 PM, Mr Doug - <dsc3507@yahoo. com> wrote:


       It sounds like you have installed the right driver. But if you are in doubt you could go through the installation again with the new download. Uninstall and DELETE the old driver - done in hardware window as I described before. Then disconnect and reconnect the device and point the install to the files in Afleet directory you unzipped. The .inf file is an instruction file that installs the driver. So you need all the files. It will find the ones it needs you just need to point to the directory where they are.

      If you are sure you have the right driver or after you do the above and you still get the error it might be that it is looking for the Si570.  Again I am not where I can check that. I have a USBtoI2C built at home that works and I do not remember any errors. I am not sure what the error 5 is you mention. I do not remember seeing that in the checkout of the standalone board. Yours is part of the RX9 kit but I believe it is the same HW as the separate board.

      Did you ever download the cfgsr.exe utility I mentioned? It is a zip kit with DLL. If you put the exe and dll in the same directory (the way it would unzip) and run it, it should come up and identify your USB device and tell you the version of the AVR chip on it. If you get that far I would say you are working. You will not be able to do much else because most of the setup in that program relates to the SI570 chip which you will install on your board later.


      Sent: Fri, January 1, 2010 10:22:27 PM

      Subject: Re: [softrock40] USB FAILED DRIVER TEST


      Hi Doug,

      Here's my most recent progress...

      I have Rocky loaded and the settings are configured for USB control of the Si570.

      I downloaded and unzipped PE0FKO-USB-Driver- zip, putting the files in a new subfolder under Afreet (Rocky is in another subfolder under Afreet).  There are seven files in the new subfolder:  libusb0.dll, libusb0.sys, libusb0_x64.. dll, libusb0_x64. sys, PE0FKO.cat, PE0FKO.inf, and PE0FKO_x64.cat.

      When I plug the Softrock SDR USB cable into the computer USB port, a little USB icon comes up in the same tray as the clock.  When I click on it, a "USB DEVICE NOT RECOGNIZED" window pops up that says the AVR USB Device has failed.  I double-click on the highlighted AVR USB Device, and a new window (AVR USB DEVICE PROPERTIES) pops up.  It identifies the device as "LibUSB-Win32 Devices", and says it's working properly.  It identifies the Driver provider as, "www.obdev.at", with a Driver Date of "3/20/2007", and a Driver Version of "0.1.12..1".  Clicking on the Driver Details box, gives the following Driver Files:  C:\windows\system32 \drivers\ libusb0.sys, and C:\windows\system32 \libusb0. dll.

      I don't know what I did that finally installed a real dll driver file...  Whenever I would go through the driver installation procedure you describe below, the Wizard would only recognize "INF" files, even though there were others in that folder.  Now, when I take the time to document what's there, I find the libusb0.dll and sys drivers seem to be attached to the SDR USB.  This had never happened before:  It would always be a windows driver from 2000.

      So it looks like there's a driver associated with the USB circuit on the SDR board now, but the error message comes up that it doesn't recognize the device.  I don't know if that's my problem or Window's.  The WB5RVZ instructions say that - at this point of assembly (the USB circuit is built, but not connected to anything else yet) - I should get an "error -5...." message.  But I don't.

      Is there still a problem?

      Thanks again - ed, k9ew

      On Fri, Jan 1, 2010 at 8:31 PM, Mr Doug - <dsc3507@yahoo. com> wrote:


       When you attach the unknown HW (USB) it will say it does not have the driver and ask for a disk. Direct it to the dirsectory (raw files) where you unzipped the link we sent you. It will then install the driver.. If you already have a driver and think it is the wrong one go into System, Hardware, Device Manager and find the USBtoI2C USB device, uninstall the old driver first. Then pull out the physical device, reinsert it and you will be asked for the driver as above.

      Unfortunately I am doing this by memory because I am not where my device is installed but I am pretty sure this is correct.

      As far as building the kit, I would say that you could go on. If there is a problem with the USB and you cannot find it now you could still finish the kit and troubleshoot later but hopefully the above will work.


      From: Ed - K9EW <k9ew57@gmail. com>
      To: softrock40@yahoogro ups.com
      Sent: Fri, January 1, 2010 5:15:47 PM

      Subject: Re: [softrock40] USB FAILED DRIVER TEST


      Hi Jose,

      If I understand what you're saying, I should not be pointing to the PE0FKO.inf file as the driver for the USB device.  But that's the only file the Windows Installer will recognize when I try to update the driver.  (It will only see .inf files.)

      Is there another way to install the USB driver?

      Thanks - ed

      On Fri, Jan 1, 2010 at 2:33 PM, Jose Bonanca <jabct1aos@gmail. com> wrote:

      The above link for pe0fko does contain the correct driver its not  inf anyway.
      Now that you installed a different driver you must reinstall the device and the driver , restart the PC and reinstall driver pointing to the location you saved the file to of the above link.
      Do not forget to unzip the file.
      You must install the driver manually.
      Please check this first before you go ahead with the assembly.

      2010/1/1 Ed - K9EW <k9ew57@gmail. com>

      Hi Doug,

      I found that driver today (PE0FKO.inf) , and tried to designate it as the device driver after connecting the SDR to the USB port on my computer.  But I get the message:  "The specified location does not contain information about your hardware", and it won't install it.  I'm running Windows XP Home, and I do keep it updated.

      Any ideas?

      Also, is it OK to keep building with the thought that I can fix this problem later?  Or will it create more problems as I build and test the following sections?

      I appreciate your taking the time to help me with this.

      ed - k9ew

      On Fri, Jan 1, 2010 at 11:24 AM, Mr Doug - <dsc3507@yahoo. com> wrote:

      The USBtoI2C driver SW is available as a link on this page which also has lots of other good info:

      http://home. ict.nl/~fredkrom /pe0fko/SR- V9-Si570/

      Exact link to driver download is:

      http://home. ict.nl/~fredkrom /pe0fko/SR- V9-Si570/ PE0FKO-USB- Driver-0. 1.12.2.zip

      Happy New Year, Doug

      From: Jose Bonanca <jabct1aos@gmail. com>
      To: softrock40@yahoogro ups.com

      Sent: Fri, January 1, 2010 6:16:28 AM
      Subject: Re: [softrock40] USB FAILED DRIVER TEST


      search for PE0FKO and look for the correct driver over the site..
      The driver you used is not the correct one.
      73 HNY

      2010/1/1 Ed - K9EW <k9ew57@gmail. com>

      Hi to the group.... I need some help.

      I'm building the Softrock Lite + USB Xtall v9.0 receiver, using the
      Assembly Instructions from the WB5RVZ documentation. The Power Supply
      is built and tested, and works fine. The USB Control Circuit is
      built, passed the resistance test, but failed the Rocky / USB driver
      test. (I'm supposed to get an "error -5..." message, but I don't.

      I downloaded and installed Rocky ver 3.6. Then I downloaded the
      Si570\AVR-USB- Driver files. (Note: I had to do a lot of navigating
      around to find these files. I think I got the right ones - containing
      AVR.inf.) I didn't get a prompt for the driver location until
      powering up the partially built SDR board and connecting the USB cable
      to my computer. Then I specified "AVR.inf" as the driver to use. I
      did a USB voltage check, and all the voltages are in the range
      specified. I did notice, however, that the U2-5 voltage sits at 67mV
      for a several seconds, then jumps to around 180mV for a second, then
      returns to 67mV for several seconds, etc.

      Can someone tell me where I went wrong? The instructions say I'm
      supposed to get an "error -5..." message when the computer is talking
      to the SDR USB circuit, and I don't get that.

      Thanks - ed, k9ew

      Jose (Ct1aos)

      Jose (Ct1aos)

    Your message has been successfully submitted and would be delivered to recipients shortly.