Loading ...
Sorry, an error occurred while loading the content.
 

USB I2C Interface Plea for Mercy

Expand Messages
  • charles
    To the group: A couple of months ago I purchased two of the USB I2C kits. I had purchased a couple several years ago which used the ATTINY 45 chips and they
    Message 1 of 4 , Oct 1, 2009
      To the group:


      A couple of months ago I purchased two of the USB I2C kits. I had purchased a couple several years ago which used the ATTINY 45 chips and they worked great.

      I finally got around to building one of the current kits which uses the ATTINY 85 chip. The version of software is reported as\\PE)FKO-2.0.

      The USB connection works ok as well as frequency setting. However, I have a problem with the PTT signal. When I use the interface with Rocky 3.6, the PTT goes high and stays high regardless of what I do with Rocky.

      I have replaced the ATTINY 85 in the new interface board with one of my ATTINY 45 chips and all works well with the PTT signal. The version of this software is Beta1.1.

      I have reviewed the softrock40 group messages to see if anyone is having this problem but I got negative results.

      Any ideas about what my problem may be?

      Regards,

      Charley, W5BAA
    • pe0fko
      Hi Charles, The new firmware is default using ABPF (automatic band pass filter) enabled. The ABPF is using the same I/O lines ad the TX and CW on the USB I2C.
      Message 2 of 4 , Oct 1, 2009
        Hi Charles,

        The new firmware is default using ABPF (automatic band pass filter) enabled. The ABPF is using the same I/O lines ad the TX and CW on the USB I2C.

        Download the CfgSR <http://home.ict.nl/~fredkrom/pe0fko/CFGSR/> and disable the APBF (the setting is saved in eeprom).

        --
        73, Fred
        PE0FKO


        2009/10/1 charles <chill@...>
         

        To the group:

        A couple of months ago I purchased two of the USB I2C kits. I had purchased a couple several years ago which used the ATTINY 45 chips and they worked great.

        I finally got around to building one of the current kits which uses the ATTINY 85 chip. The version of software is reported as\\PE)FKO-2.0.

        The USB connection works ok as well as frequency setting. However, I have a problem with the PTT signal. When I use the interface with Rocky 3.6, the PTT goes high and stays high regardless of what I do with Rocky.

        I have replaced the ATTINY 85 in the new interface board with one of my ATTINY 45 chips and all works well with the PTT signal. The version of this software is Beta1.1.

        I have reviewed the softrock40 group messages to see if anyone is having this problem but I got negative results.

        Any ideas about what my problem may be?

        Regards,

        Charley, W5BAA





      • huntlykaty
        Fred, Thanks ever so much. I installed the configurator and I now have the interface working as I want. Regards, Charley
        Message 3 of 4 , Oct 1, 2009
          Fred,

          Thanks ever so much.

          I installed the configurator and I now have the interface working as I want.

          Regards,

          Charley
        • huntlykaty
          Fred, Thanks ever so much. I installed the configurator and I now have the interface working as I want. Regards, Charley
          Message 4 of 4 , Oct 1, 2009
            Fred,

            Thanks ever so much.

            I installed the configurator and I now have the interface working as I want.

            Regards,

            Charley
          Your message has been successfully submitted and would be delivered to recipients shortly.