Loading ...
Sorry, an error occurred while loading the content.

SoftRock v9.0 and PE0FKO v15.9 Firmware

Expand Messages
  • g8voip
    Hi all, As a follow up to the previous messages, here is some additional information that might be of use. I have had the opportunity and pleasure to try out
    Message 1 of 1 , Mar 1, 2009
    • 0 Attachment
      Hi all,

      As a follow up to the previous messages, here is some additional
      information that might be of use. I have had the opportunity and
      pleasure to try out both enhanced versions of the firmware available,
      thanks Jan and Fred.

      Both Fred's v15.9 and the 'official' v2.0 versions of the firmware are
      customised for the v9.0 receiver, the transmit / CW key functions no
      longer work as the pins are now used for the BPF switching.

      To fully gain the benefits from Fred's version, you must install
      Winrad v1.32 and his supporting dll file (not tried with the v1.42
      released 27/02/09 yet).

      http://www.winrad.org/

      http://home.ict.nl/~fredkrom/pe0fko/ExtIO_Si570/

      http://home.ict.nl/~fredkrom/pe0fko/SR-V9-Si570/

      Once you are running Winrad, press 'H' to bring up the set-up screens.

      There is are two options for band pass switching:

      BPF acts like the v2.0 firmware and requires an external dll file to
      provide the support (only Winrad and PSDR currently)

      ABPF function uses the firmware control and makes it compatible with
      other programs like Rocky without the need for an additional dll file*
      This is the better option.

      Smooth tuning is implemented within the firmware, so overcomes the
      'glitch' problem seen when using USB-I2C with PSDR-IQ.

      If you set up the Si570 frequency calibration using Winrad, this is
      retained in the firmware and all other programs should be left at the
      default xtall frequency of 114285000Hz.

      The following programs have been tested with the v15.9 firmware:

      Winrad v1.32 - requires Fred's dll to configure the firmware

      PSDR v1.9.0 (PE1NNZ version), no additional dll file needed, works in
      both SoftRock and SDR1000 modes (better)

      PSDR-IQ v1.12.20 (SV1EIA), no additional dll file needed, now benefits
      from auto image rejection (best choice for v9.0 users)

      PSDR v1.16.1 (Official version), requires modified version of
      SDR1kUSB.dll to work, available from Fred's firmware page.

      Rocky v3.6 (VE3NEA), no additional dll file needed.

      Hope that helps, enjoy!

      73, Bob G8VOI
    Your message has been successfully submitted and would be delivered to recipients shortly.