Loading ...
Sorry, an error occurred while loading the content.

Re: [softrock40] Re: Switching BPFs

Expand Messages
  • Pete Smith
    ... Schematic is now there - a little rough but readable. It s the only file currently in the folder. I am using 4PDT relays to do the switching - switching
    Message 1 of 12 , Aug 2 1:32 PM
    • 0 Attachment
      At 04:36 AM 8/2/2008, drmail377 wrote:
      >Hi Pete,
      >
      >So you're using three sets of contacts per filter? Upload a schematic
      >to the Files > Temp area so we can take a look, hand-written is fine.

      Schematic is now there - a little rough but readable. It's the only file
      currently in the folder. I am using 4PDT relays to do the switching -
      switching pins 2 and 3 of P101 (the transformer output) and each pin of
      P100 (antenna input and return). I have no doubt that PIN diodes would
      make for a more compact switching scheme, but frankly didn't know how to
      implement it - relays, I more or less understand.


      >Are you using coax to interconnect? If so, what type? Make sure all
      >the wire and/or coax lengths are the same. 5 inches at 20 meters is
      >around 2.3 degrees in free space and 1.5 degrees in typical coax.


      No, using #24 hookup wire. I did not pay any particular attention to
      keeping lead lengths equal, and that may well be the source of my
      problems. Tony has suggested testing with one BPF using RG-174 for the
      outputs (pins 3 and 4 of P101, with the shields connected together to pin
      1) and feeding the antenna straight to P100 on the BPF, to see if it is any
      better behaved. I plan to do that next.


      >When you describe your phase error, do you mean it is 4.7 deg. with
      >one filter and 5.4 with a different one? Or is the total phase
      >disparity between 4.7 and 5.4 degrees, at different frequencies
      >perhaps. Or is it between a switched BPF and one plugged directly into
      >the main board? Please clarify.

      The numbers (4.7 to 5.4) define the range of values along the curve
      produced by the phase display of the I/Q balance routine. In the message
      you quoted, I recorded the ranges both for mounting on the RX and remote
      mounting, on the bands where I was able to get the auto I/Q balancing to
      work on the remote mounting. On 40 and above I could not.


      >Remember with coax, if it is not properly terminated it will introduce
      >reactance in likely significant amount even in inches of length (can't
      >remember off-hand how to calculate this). This causes some concern
      >because if you we 50 Ohm coax on the switched BPF transformer
      >secondary the termination is at-best around 25 Ohms, not 50, or maybe
      >not because of the commutating switch, hmmm...

      Don't know, but if this is a problem it probably isn't practical to do
      anything else.

      >Again, at least keep all cabling lengths the same at all points. I'm
      >wondering about the specifications of your relays. DIP relays are in
      >almost all cases not so good at RF. The fact that you're using OMRON
      >is a good sign, they're the only mfgr I've been able to find in a
      >quick search that has some decent RF-capable DIP relays with decent
      >isolation (around 60 dB if memory serves). What kind of relays are you
      >using?


      The relays I used are Omron, specifically designed for small signal use,
      part no. G6A-474P-ST40-US. They are in 14-pin DIP packages.


      >I don't think the switch and switch wires to the relay coils should
      >matter, but you might want to try bypassing them anyway.
      >
      >I presume the software you're using enables you to reset and restart
      >the phase error and phase tracking routine at-will. Don't tell the
      >software anything about frequency change when you change the SDR's
      >frequency and BPF. Then try the opposite, do tell it about the
      >frequency change. I'm concerned the software may be doing some sort of
      >scaling with frequency change. Dunno - reaching for straws.

      If I tell the software what band, it goes back and finds the correction
      curves for that band, which were stored the last time the band was
      changed. When you start collecting phase and gain data again, it seemingly
      starts at zero. I know that if the level difference between the
      fundamental and the image signal is too close (say less than 10 dB) then
      the auto balance routine cannot determine how to correct, because it
      doesn't know which signal is which. but that's all I know about how it
      does its magic.

      73, Pete N4ZR
    Your message has been successfully submitted and would be delivered to recipients shortly.