Loading ...
Sorry, an error occurred while loading the content.

Tx idle current

Expand Messages
  • Jouni Leskinen
    Hello, I wonder if somebody would like to give some hints what to do: * I got the SoftRock RxTxV6.2 80/40 kit (nice kit, mni thanks guys for the effort) * no
    Message 1 of 1 , Sep 1, 2007
    View Source
    • 0 Attachment
      Hello,

      I wonder if somebody would like to give some hints what to do:

      * I got the SoftRock RxTxV6.2 80/40 kit (nice kit, mni thanks guys for the
      effort)
      * no problems with soldering together
      * measured the dc resistances as instructed, all ok
      * as an initial test I connected a dummy load, nothing else, just to see how
      the voltages are
      * the dc source is some wall adapter giving 12 V DC, 1 A
      * after connecting dc supply voltage dropped right away to somewhere 3 V; too
      much current somewhere
      * switched the power off immediately
      * checked the pcb with magnifying glass to see if there were any solder
      bridges, nothing seen
      * repeated the dc connecting test to locate the problem, the power supply was
      connected for < 5 seconds
      * noticed R31 and R32 heated up quickly, really hot, something must be wrong,
      I think
      * looks like dc biasing is not ok; if I right understand , there should not be
      any biasing /current in Q5 and Q6 if there is no 12 V in PTT IN
      * measured the dc resistance between 12 V rail and ground; 99 kohms
      * I have difficulties to understand how this biasing is working, never worked
      with 'power FET's'!
      * anyway, now some help will be appreciated; what to look and how

      Thanks
      Jouni /OH3DC
    Your message has been successfully submitted and would be delivered to recipients shortly.