Loading ...
Sorry, an error occurred while loading the content.

Re: USB Soundcard (minimal size)

Expand Messages
  • Terry
    ... a year ... so I can ... affects the ... components, ... should be ... the ... the ... the ... and ... done ... that ... codec. I ... in the ... affacted
    Message 1 of 54 , Jul 31 9:04 PM
    • 0 Attachment
      --- In softrock40@yahoogroups.com, Ignacio Cembreros <eb4apl@...>
      wrote:
      >
      > Guido wrote:
      > >
      > > On 7/30/07, *Ignacio Cembreros* <eb4apl@...
      > > <mailto:eb4apl@...>> wrote:
      > >
      > > Terry, Guido et all.
      > >
      > > I bought the same kit mentioned in Nuts and Volts, more than
      a year
      > > ago. Finally I found the kit documentation in digital format
      so I can
      > > describe the problems I had.
      > >
      > > The picture has an error, a swapped resistor pair, which
      affects the
      > > balance. If you have followed the picture for placing the
      components,
      > > like me, you swapped R11 and R13. R11 should be 6k8 and R13
      should be
      > > 3k9 and they must be located as per the silkscreen, not per
      the
      > > picture.
      > >
      > > Another error is in the PCB itself which doesn't agree with
      the
      > > schematic and is related to the supply method. This affects
      the
      > > performance, according to TI.
      > >
      > > My solution is to cut the trace which goes from C2 to a via
      and
      > > finally
      > > to U3 pins 8,9 and 27; do it just after C2 and solder a wire
      > > jumper from
      > > C2 (or C1) to R9 (VBUS in the schematic). All this rework is
      done
      > > in the
      > > bottom side of the card.
      > >
      > > As you can see, both problems can be easily fixed, and after
      that
      > > I use
      > > this mini card for demos with an SR40 with reasonable results.
      > >
      > > 73 de Ignacio, EB4APL
      > >
      > >
      > > Hello Ignacio,
      > >
      > > Thanks for reporting about your experience with the PCM2900
      codec. I
      > > have no access to the Nuts and Volts schematic, but presume the
      > > circuit is not different than the typical circuits as published
      in the
      > > datasheet [1] ? Could you indicate which of the components
      affacted
      > > the performance?
      <snip>
      > Guido,
      > I was referring to a PCB layout error in the Nuts and Volts kit
      article,
      > not in the schematic which is close to the TI evaluation boards,
      with
      > minor variations.. If you are interested in the schematics and the
      kit
      > description, let me know it and I will send it directly to you.
      > According to TI, the circuit can be powered from the internal
      regulator
      > or an external one. The use of the internal regulator affects
      > negatively to the harmonic distortion and maybe the noise, I don't
      have
      > the application notes here but are on the TI site. So TI
      recommends to
      > use a cheap external regulator, except for very cost sensitive low
      end
      > applications.
      >
      >
      > --
      > 73 de Ignacio, EB4APL
      >
      Ignacio:
      Thank you for the above information. I checked my ADDA board, and it
      has both the problems you mentioned above. I purchased the assembled
      units, not the kits, but the resistors were wrong anyway.

      I ahve made both the changes you outlined above, and will test the
      board for improvements. It certainly cannot be worse that the board
      originally performed!!

      It will likely be a week before I can test it, as I have some travel
      coming.

      Thank you again for highlighting the two problems above. I do not
      have the original Nuts & Volts article. I have only the schematic
      that came with the board, and the TI datasheet.

      Terry
      WB4JFI
    • Terry
      ... a year ... so I can ... affects the ... components, ... should be ... the ... the ... the ... and ... done ... that ... codec. I ... in the ... affacted
      Message 54 of 54 , Jul 31 9:04 PM
      • 0 Attachment
        --- In softrock40@yahoogroups.com, Ignacio Cembreros <eb4apl@...>
        wrote:
        >
        > Guido wrote:
        > >
        > > On 7/30/07, *Ignacio Cembreros* <eb4apl@...
        > > <mailto:eb4apl@...>> wrote:
        > >
        > > Terry, Guido et all.
        > >
        > > I bought the same kit mentioned in Nuts and Volts, more than
        a year
        > > ago. Finally I found the kit documentation in digital format
        so I can
        > > describe the problems I had.
        > >
        > > The picture has an error, a swapped resistor pair, which
        affects the
        > > balance. If you have followed the picture for placing the
        components,
        > > like me, you swapped R11 and R13. R11 should be 6k8 and R13
        should be
        > > 3k9 and they must be located as per the silkscreen, not per
        the
        > > picture.
        > >
        > > Another error is in the PCB itself which doesn't agree with
        the
        > > schematic and is related to the supply method. This affects
        the
        > > performance, according to TI.
        > >
        > > My solution is to cut the trace which goes from C2 to a via
        and
        > > finally
        > > to U3 pins 8,9 and 27; do it just after C2 and solder a wire
        > > jumper from
        > > C2 (or C1) to R9 (VBUS in the schematic). All this rework is
        done
        > > in the
        > > bottom side of the card.
        > >
        > > As you can see, both problems can be easily fixed, and after
        that
        > > I use
        > > this mini card for demos with an SR40 with reasonable results.
        > >
        > > 73 de Ignacio, EB4APL
        > >
        > >
        > > Hello Ignacio,
        > >
        > > Thanks for reporting about your experience with the PCM2900
        codec. I
        > > have no access to the Nuts and Volts schematic, but presume the
        > > circuit is not different than the typical circuits as published
        in the
        > > datasheet [1] ? Could you indicate which of the components
        affacted
        > > the performance?
        <snip>
        > Guido,
        > I was referring to a PCB layout error in the Nuts and Volts kit
        article,
        > not in the schematic which is close to the TI evaluation boards,
        with
        > minor variations.. If you are interested in the schematics and the
        kit
        > description, let me know it and I will send it directly to you.
        > According to TI, the circuit can be powered from the internal
        regulator
        > or an external one. The use of the internal regulator affects
        > negatively to the harmonic distortion and maybe the noise, I don't
        have
        > the application notes here but are on the TI site. So TI
        recommends to
        > use a cheap external regulator, except for very cost sensitive low
        end
        > applications.
        >
        >
        > --
        > 73 de Ignacio, EB4APL
        >
        Ignacio:
        Thank you for the above information. I checked my ADDA board, and it
        has both the problems you mentioned above. I purchased the assembled
        units, not the kits, but the resistors were wrong anyway.

        I ahve made both the changes you outlined above, and will test the
        board for improvements. It certainly cannot be worse that the board
        originally performed!!

        It will likely be a week before I can test it, as I have some travel
        coming.

        Thank you again for highlighting the two problems above. I do not
        have the original Nuts & Volts article. I have only the schematic
        that came with the board, and the TI datasheet.

        Terry
        WB4JFI
      Your message has been successfully submitted and would be delivered to recipients shortly.