Loading ...
Sorry, an error occurred while loading the content.

RE: [soaplite] Newbie Stating problem.

Expand Messages
  • Chris Davies
    I d suggest that your IIS isn t configured correctly. The returned error, %1 is not a valid Win32 application , isn t from SOAP. Re the debian side, are you
    Message 1 of 2 , Nov 9, 2001
    • 0 Attachment
      I'd suggest that your IIS isn't configured correctly. The returned error,
      "%1 is not a valid Win32 application", isn't from SOAP.

      Re the debian side, are you using mySOAPsh.pl to call your soap server? It's
      a fairly helpful test harness

      Chris

      --
      Chris Davies, Manheim Online
      Tel. 0113 393-2004 Fax. 0870 444-0482. Mobile 07778 199069

      -----Original Message-----
      From: Geoff Ellis [mailto:geoff@...]
      Sent: Thursday, November 08, 2001 5:04 PM
      To: SOAP (E-mail)
      Subject: [soaplite] Newbie Stating problem.


      People, sorry to trouble you with this, but as a newbie, both to
      methods/classes/soap etc, I need to ask to move on.
      I read all the docs off www.soaplite.com about getting started, and I've
      even used their scripts that call the class Temperatures. I've tried this on
      both my laptop(running 2k and IIS) and also on my debian Linux server, and
      in both instances, I get no data back. Below is the error message from my
      Win2k installation. I think the problem may be that I have not loaded the
      class..so here's my question, a soap server... how do I get it started...

      error msg
      =========
      POST http://localhost/soap/temper.cgi
      Accept: text/xml
      Accept: multipart/*
      Content-Length: 518
      Content-Type: text/xml; charset=utf-8
      SOAPAction: "http://localhost/soap/Temperatures#c2f"

      <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
      xmlns:SOAP-ENC="http://
      schemas.xmlsoap.org/soap/encoding/"
      SOAP-ENV:encodingStyle="http://schemas.xmlso
      ap.org/soap/encoding/"
      xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/
      " xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      xmlns:xsd="http://www.w3
      .org/1999/XMLSchema"><SOAP-ENV:Body><namesp1:c2f
      xmlns:namesp1="http://localhost
      /soap/Temperatures"><c-gensym3
      xsi:type="xsd:float">37.5</c-gensym3></namesp1:c2
      f></SOAP-ENV:Body></SOAP-ENV:Envelope>
      HTTP/1.1 500 (Internal Server Error) Server Error
      Date: Thu, 08 Nov 2001 09:20:19 GMT
      Server: Microsoft-IIS/5.0
      Content-Length: 96
      Content-Type: text/html
      Client-Date: Thu, 08 Nov 2001 09:20:19 GMT
      Client-Peer: 127.0.0.1:80
      Title: Error

      <html><head><title>Error</title></head><body>%1 is not a valid Win32
      application
      . </body></html>


      many thanks

      Geoff


      To unsubscribe from this group, send an email to:
      soaplite-unsubscribe@yahoogroups.com



      Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
    Your message has been successfully submitted and would be delivered to recipients shortly.