Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] autoresolve of "href" attributes?

Expand Messages
  • Paul Kulchenko
    Hi, Taras! ... Hm. It s not configurable now. As far as I understand you d like to process hrefs yourself. I can add on_href (or similar) event, but you can
    Message 1 of 2 , Oct 24, 2001
    • 0 Attachment
      Hi, Taras!

      > Is there a way to turn off that auto resolve feature? I looked at
      > SOAP::Deserializer::decode_value but didn't notice any option to
      > turn that off.
      Hm. It's not configurable now. As far as I understand you'd like to
      process hrefs yourself. I can add on_href (or similar) event, but you
      can also override traverse_ids() method in deserializer which is
      called when element with href is found (or MIME message processed)
      and modify ids() or hrefs() lists. Another options is to override
      decode_value() method and handle hrefs yourself (if it's not yours,
      call SUPER::decode_value). What would you prefer?

      You may also take a look into mimedecode() method that handles this
      situation for MIME messages.

      Best wishes, Paul.

      --- Taras Shkvarchuk <tshkvarchuk@...> wrote:
      > It appears that SOAP::Lite deserializer is trying to resolve the
      > references
      > when it sees one.
      >
      > When I am trying to build a message and attach the following body:
      >
      > <m:csvToXML
      >
      xmlns:m="http://www.grandcentralservices.com/schemas/FlatFileTransformation"
      > ><csvInput href="cid:report.csv"/><output
      > href="cid:report_new.xml"/></m:csvToXML>
      >
      > But when it gets to:
      >
      > my $som=SOAP::Deserializer->new->deserialize($contents);
      >
      > I get the following error:
      >
      > Unresolved (wrong?) href (report.csv) in element 'csvInput'
      >
      > Is there a way to turn off that auto resolve feature? I looked at
      > SOAP::Deserializer::decode_value but didn't notice any option to
      > turn that
      > off.
      >
      > Thank you,
      > Taras Shkvarchuk
      >
      >


      __________________________________________________
      Do You Yahoo!?
      Make a great connection at Yahoo! Personals.
      http://personals.yahoo.com
    Your message has been successfully submitted and would be delivered to recipients shortly.