Loading ...
Sorry, an error occurred while loading the content.

Odd Behavior

Expand Messages
  • Ivan R. Judson
    Hi, I ve been happily hacking away on my SOAP application getting close to getting finished. I just wanted to report a small oddity that I can t capture very
    Message 1 of 2 , Oct 4, 2001
    • 0 Attachment
      Hi,

      I've been happily hacking away on my SOAP application getting close to
      getting finished.

      I just wanted to report a small oddity that I can't capture very cleanly
      into a little example yet, but thought should get brought up.

      I tend to use use strict; but even so in some files where I'm using SOAP
      calls syntax errors or other wrongness don't get reported. What happens is
      SOAPLite reports,

      something like 'can't call send_receive on blah blah blah'.

      SOAPLite must be doing some deep magic to hide the errors from me :-).

      Things are going great otherwise!

      Cheers,

      --Ivan

      ..........
      Ivan R. Judson .~. http://www.mcs.anl.gov/~judson
      Futures Laboratory .~. 630 252 0920
      Argonne National Laboratory .~. 630 252 6424 Fax
    • Paul Kulchenko
      Hi, Ivan! ... Could you show full client example where you see this error. Only one reason I can think about is calling method before specifying proxy()
      Message 2 of 2 , Oct 4, 2001
      • 0 Attachment
        Hi, Ivan!

        > I tend to use use strict; but even so in some files where I'm using
        > SOAP
        > calls syntax errors or other wrongness don't get reported. What
        > happens is SOAPLite reports,
        >
        > something like 'can't call send_receive on blah blah blah'.
        >
        > SOAPLite must be doing some deep magic to hide the errors from me
        > :-).
        Could you show full client example where you see this error.

        Only one reason I can think about is calling method before specifying
        proxy() address:

        SOAP::Lite->uri()->mymethod...

        instead of

        SOAP::Lite->uri()->proxy()->mymethod...

        In this case underlying transport object doesn't exist and perl
        complains on call send_receive on undefined value. I'll probably add
        check and better diagnostics. Let me know if it's something else.

        Best wishes, Paul.

        --- "Ivan R. Judson" <judson@...> wrote:
        >
        > Hi,
        >
        > I've been happily hacking away on my SOAP application getting close
        > to
        > getting finished.
        >
        > I just wanted to report a small oddity that I can't capture very
        > cleanly
        > into a little example yet, but thought should get brought up.
        >
        > I tend to use use strict; but even so in some files where I'm using
        > SOAP
        > calls syntax errors or other wrongness don't get reported. What
        > happens is
        > SOAPLite reports,
        >
        > something like 'can't call send_receive on blah blah blah'.
        >
        > SOAPLite must be doing some deep magic to hide the errors from me
        > :-).
        >
        > Things are going great otherwise!
        >
        > Cheers,
        >
        > --Ivan
        >
        > ..........
        > Ivan R. Judson .~. http://www.mcs.anl.gov/~judson
        > Futures Laboratory .~. 630 252 0920
        > Argonne National Laboratory .~. 630 252 6424 Fax
        >
        >
        > ------------------------ Yahoo! Groups Sponsor
        >
        > To unsubscribe from this group, send an email to:
        > soaplite-unsubscribe@yahoogroups.com
        >
        >
        >
        > Your use of Yahoo! Groups is subject to
        > http://docs.yahoo.com/info/terms/
        >
        >


        __________________________________________________
        Do You Yahoo!?
        NEW from Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.
        http://geocities.yahoo.com/ps/info1
      Your message has been successfully submitted and would be delivered to recipients shortly.