Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] Odd error, deserialization?

Expand Messages
  • Paul Kulchenko
    Hi, Ivan! Could you show full wiredump for request? You will get this error ONLY when generate XML code has something like this: and there
    Message 1 of 5 , Sep 22, 2001
    • 0 Attachment
      Hi, Ivan!

      Could you show full wiredump for request? You will get this error
      ONLY when generate XML code has something like this:

      <a href="#ref-123">

      and there is no element <b id="123">. Such envelope is invalid and
      can't be properly deserialized. Looks like a bug on serializer side,
      that's why I need to see a wiredump and client side code. Thanks.

      Best wishes, Paul.

      --- "Ivan R. Judson" <judson@...> wrote:
      >
      > This is in my debugging output:
      >
      > SOAP::Serializer::envelope: ()
      > SOAP::Serializer::envelope: Client Application failed during
      > request
      > deserialization: Unresolved (wrong?) href (ref-140483080) in
      > element 'POC'
      > http://alchesay.mcs.anl.gov:1180/
      >
      > It doesn't make any sense to me, but is it familiar to anyone else?
      >
      > On the client side I'm getting this (as part of my object's new
      > call):
      >
      > $VAR1 = bless( {
      > 'POC' => bless( {
      > 's-gensym21' =>
      > 'http://alchesay.mcs.anl.gov:
      > 1180/'
      > }, 'POC' ),
      >
      > the corresponding code on the server seems to be:
      > bless( {
      > 'POC' => bless( do{\(my $o =
      > 'http://alchesay.mcs.anl.gov:1180/')},
      > 'URI::http' ),
      >
      > Why would that bail? Something seems off to me.
      >
      > --Ivan
      >
      > ..........
      > Ivan R. Judson .~. http://www.mcs.anl.gov/~judson
      > Futures Laboratory .~. 630 252 0920
      > Argonne National Laboratory .~. 630 252 6424 Fax
      >
      >
      > ------------------------ Yahoo! Groups Sponsor
      >
      > To unsubscribe from this group, send an email to:
      > soaplite-unsubscribe@yahoogroups.com
      >
      >
      >
      > Your use of Yahoo! Groups is subject to
      > http://docs.yahoo.com/info/terms/
      >
      >


      __________________________________________________
      Do You Yahoo!?
      Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger. http://im.yahoo.com
    • Ivan R. Judson
      Hey Paul, I can send a dump. The only thing that s got me confounded is my code won t print anything out when I enable debugging on the linux side. I ve
      Message 2 of 5 , Sep 22, 2001
      • 0 Attachment
        Hey Paul,

        I can send a dump. The only thing that's got me confounded is my code won't
        print anything out when I enable debugging on the linux side. I've tried to
        enable it every way I could find in the docs/examples, but I've struck out.

        I'm using ActiveState 5.6.1, with SOAPlite 0.46, on a Linux Mandrake 7.2
        machine.

        Any thoughts?

        --Ivan

        > -----Original Message-----
        > From: Paul Kulchenko [mailto:paulclinger@...]
        > Sent: Saturday, September 22, 2001 9:09 AM
        > To: soaplite@yahoogroups.com
        > Subject: Re: [soaplite] Odd error, deserialization?
        >
        >
        > Hi, Ivan!
        >
        > Could you show full wiredump for request? You will get this error
        > ONLY when generate XML code has something like this:
        >
        > <a href="#ref-123">
        >
        > and there is no element <b id="123">. Such envelope is invalid and
        > can't be properly deserialized. Looks like a bug on serializer side,
        > that's why I need to see a wiredump and client side code. Thanks.
        >
        > Best wishes, Paul.
        >
        > --- "Ivan R. Judson" <judson@...> wrote:
        > >
        > > This is in my debugging output:
        > >
        > > SOAP::Serializer::envelope: ()
        > > SOAP::Serializer::envelope: Client Application failed during
        > > request
        > > deserialization: Unresolved (wrong?) href (ref-140483080) in
        > > element 'POC'
        > > http://alchesay.mcs.anl.gov:1180/
        > >
        > > It doesn't make any sense to me, but is it familiar to anyone else?
        > >
        > > On the client side I'm getting this (as part of my object's new
        > > call):
        > >
        > > $VAR1 = bless( {
        > > 'POC' => bless( {
        > > 's-gensym21' =>
        > > 'http://alchesay.mcs.anl.gov:
        > > 1180/'
        > > }, 'POC' ),
        > >
        > > the corresponding code on the server seems to be:
        > > bless( {
        > > 'POC' => bless( do{\(my $o =
        > > 'http://alchesay.mcs.anl.gov:1180/')},
        > > 'URI::http' ),
        > >
        > > Why would that bail? Something seems off to me.
        > >
        > > --Ivan
        > >
        > > ..........
        > > Ivan R. Judson .~. http://www.mcs.anl.gov/~judson
        > > Futures Laboratory .~. 630 252 0920
        > > Argonne National Laboratory .~. 630 252 6424 Fax
        > >
        > >
        > > ------------------------ Yahoo! Groups Sponsor
        > >
        > > To unsubscribe from this group, send an email to:
        > > soaplite-unsubscribe@yahoogroups.com
        > >
        > >
        > >
        > > Your use of Yahoo! Groups is subject to
        > > http://docs.yahoo.com/info/terms/
        > >
        > >
        >
        >
        > __________________________________________________
        > Do You Yahoo!?
        > Get email alerts & NEW webcam video instant messaging with Yahoo!
        > Messenger. http://im.yahoo.com
        >
        >
        > To unsubscribe from this group, send an email to:
        > soaplite-unsubscribe@yahoogroups.com
        >
        >
        >
        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        >
        >
      • Paul Kulchenko
        Hi, Ivan! ... use SOAP::Lite on_debug = sub{print@_}; should print debug info on standard output. I would first recommend to upgrade to 0.51 and see whether
        Message 3 of 5 , Sep 22, 2001
        • 0 Attachment
          Hi, Ivan!

          > print anything out when I enable debugging on the linux side. I've
          > tried to
          > enable it every way I could find in the docs/examples, but I've
          > struck out.
          use SOAP::Lite
          on_debug => sub{print@_};

          should print debug info on standard output.

          I would first recommend to upgrade to 0.51 and see whether you still
          have this problem.

          Best wishes, Paul.

          --- "Ivan R. Judson" <judson@...> wrote:
          >
          > Hey Paul,
          >
          > I can send a dump. The only thing that's got me confounded is my
          > code won't
          > print anything out when I enable debugging on the linux side. I've
          > tried to
          > enable it every way I could find in the docs/examples, but I've
          > struck out.
          >
          > I'm using ActiveState 5.6.1, with SOAPlite 0.46, on a Linux
          > Mandrake 7.2
          > machine.
          >
          > Any thoughts?
          >
          > --Ivan
          >
          > > -----Original Message-----
          > > From: Paul Kulchenko [mailto:paulclinger@...]
          > > Sent: Saturday, September 22, 2001 9:09 AM
          > > To: soaplite@yahoogroups.com
          > > Subject: Re: [soaplite] Odd error, deserialization?
          > >
          > >
          > > Hi, Ivan!
          > >
          > > Could you show full wiredump for request? You will get this error
          > > ONLY when generate XML code has something like this:
          > >
          > > <a href="#ref-123">
          > >
          > > and there is no element <b id="123">. Such envelope is invalid
          > and
          > > can't be properly deserialized. Looks like a bug on serializer
          > side,
          > > that's why I need to see a wiredump and client side code. Thanks.
          > >
          > > Best wishes, Paul.
          > >
          > > --- "Ivan R. Judson" <judson@...> wrote:
          > > >
          > > > This is in my debugging output:
          > > >
          > > > SOAP::Serializer::envelope: ()
          > > > SOAP::Serializer::envelope: Client Application failed during
          > > > request
          > > > deserialization: Unresolved (wrong?) href (ref-140483080) in
          > > > element 'POC'
          > > > http://alchesay.mcs.anl.gov:1180/
          > > >
          > > > It doesn't make any sense to me, but is it familiar to anyone
          > else?
          > > >
          > > > On the client side I'm getting this (as part of my object's new
          > > > call):
          > > >
          > > > $VAR1 = bless( {
          > > > 'POC' => bless( {
          > > > 's-gensym21' =>
          > > > 'http://alchesay.mcs.anl.gov:
          > > > 1180/'
          > > > }, 'POC' ),
          > > >
          > > > the corresponding code on the server seems to be:
          > > > bless( {
          > > > 'POC' => bless( do{\(my $o =
          > > > 'http://alchesay.mcs.anl.gov:1180/')},
          > > > 'URI::http' ),
          > > >
          > > > Why would that bail? Something seems off to me.
          > > >
          > > > --Ivan
          > > >
          > > > ..........
          > > > Ivan R. Judson .~. http://www.mcs.anl.gov/~judson
          > > > Futures Laboratory .~. 630 252 0920
          > > > Argonne National Laboratory .~. 630 252 6424 Fax
          > > >
          > > >
          > > > ------------------------ Yahoo! Groups Sponsor
          > > >
          > > > To unsubscribe from this group, send an email to:
          > > > soaplite-unsubscribe@yahoogroups.com
          > > >
          > > >
          > > >
          > > > Your use of Yahoo! Groups is subject to
          > > > http://docs.yahoo.com/info/terms/
          > > >
          > > >
          > >
          > >
          > > __________________________________________________
          > > Do You Yahoo!?
          > > Get email alerts & NEW webcam video instant messaging with Yahoo!
          > > Messenger. http://im.yahoo.com
          > >
          > >
          > > To unsubscribe from this group, send an email to:
          > > soaplite-unsubscribe@yahoogroups.com
          > >
          > >
          > >
          > > Your use of Yahoo! Groups is subject to
          > http://docs.yahoo.com/info/terms/
          > >
          > >
          >
          >
          > ------------------------ Yahoo! Groups Sponsor
          >
          > To unsubscribe from this group, send an email to:
          > soaplite-unsubscribe@yahoogroups.com
          >
          >
          >
          > Your use of Yahoo! Groups is subject to
          > http://docs.yahoo.com/info/terms/
          >
          >


          __________________________________________________
          Do You Yahoo!?
          Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger. http://im.yahoo.com
        • Ivan R. Judson
          Good thoughts Paul. I updated everybody to 0.51 and both debugging and my previous error have disappeared :-). Thanks for being so fast with your advice!
          Message 4 of 5 , Sep 22, 2001
          • 0 Attachment
            Good thoughts Paul.

            I updated everybody to 0.51 and both debugging and my previous error have
            disappeared :-).

            Thanks for being so fast with your advice!

            --Ivan

            > -----Original Message-----
            > From: Paul Kulchenko [mailto:paulclinger@...]
            > Sent: Saturday, September 22, 2001 9:47 AM
            > To: soaplite@yahoogroups.com
            > Subject: RE: [soaplite] Odd error, deserialization?
            >
            >
            > Hi, Ivan!
            >
            > > print anything out when I enable debugging on the linux side. I've
            > > tried to
            > > enable it every way I could find in the docs/examples, but I've
            > > struck out.
            > use SOAP::Lite
            > on_debug => sub{print@_};
            >
            > should print debug info on standard output.
            >
            > I would first recommend to upgrade to 0.51 and see whether you still
            > have this problem.
            >
            > Best wishes, Paul.
            >
            > --- "Ivan R. Judson" <judson@...> wrote:
            > >
            > > Hey Paul,
            > >
            > > I can send a dump. The only thing that's got me confounded is my
            > > code won't
            > > print anything out when I enable debugging on the linux side. I've
            > > tried to
            > > enable it every way I could find in the docs/examples, but I've
            > > struck out.
            > >
            > > I'm using ActiveState 5.6.1, with SOAPlite 0.46, on a Linux
            > > Mandrake 7.2
            > > machine.
            > >
            > > Any thoughts?
            > >
            > > --Ivan
            > >
            > > > -----Original Message-----
            > > > From: Paul Kulchenko [mailto:paulclinger@...]
            > > > Sent: Saturday, September 22, 2001 9:09 AM
            > > > To: soaplite@yahoogroups.com
            > > > Subject: Re: [soaplite] Odd error, deserialization?
            > > >
            > > >
            > > > Hi, Ivan!
            > > >
            > > > Could you show full wiredump for request? You will get this error
            > > > ONLY when generate XML code has something like this:
            > > >
            > > > <a href="#ref-123">
            > > >
            > > > and there is no element <b id="123">. Such envelope is invalid
            > > and
            > > > can't be properly deserialized. Looks like a bug on serializer
            > > side,
            > > > that's why I need to see a wiredump and client side code. Thanks.
            > > >
            > > > Best wishes, Paul.
            > > >
            > > > --- "Ivan R. Judson" <judson@...> wrote:
            > > > >
            > > > > This is in my debugging output:
            > > > >
            > > > > SOAP::Serializer::envelope: ()
            > > > > SOAP::Serializer::envelope: Client Application failed during
            > > > > request
            > > > > deserialization: Unresolved (wrong?) href (ref-140483080) in
            > > > > element 'POC'
            > > > > http://alchesay.mcs.anl.gov:1180/
            > > > >
            > > > > It doesn't make any sense to me, but is it familiar to anyone
            > > else?
            > > > >
            > > > > On the client side I'm getting this (as part of my object's new
            > > > > call):
            > > > >
            > > > > $VAR1 = bless( {
            > > > > 'POC' => bless( {
            > > > > 's-gensym21' =>
            > > > > 'http://alchesay.mcs.anl.gov:
            > > > > 1180/'
            > > > > }, 'POC' ),
            > > > >
            > > > > the corresponding code on the server seems to be:
            > > > > bless( {
            > > > > 'POC' => bless( do{\(my $o =
            > > > > 'http://alchesay.mcs.anl.gov:1180/')},
            > > > > 'URI::http' ),
            > > > >
            > > > > Why would that bail? Something seems off to me.
            > > > >
            > > > > --Ivan
            > > > >
            > > > > ..........
            > > > > Ivan R. Judson .~. http://www.mcs.anl.gov/~judson
            > > > > Futures Laboratory .~. 630 252 0920
            > > > > Argonne National Laboratory .~. 630 252 6424 Fax
            > > > >
            > > > >
            > > > > ------------------------ Yahoo! Groups Sponsor
            > > > >
            > > > > To unsubscribe from this group, send an email to:
            > > > > soaplite-unsubscribe@yahoogroups.com
            > > > >
            > > > >
            > > > >
            > > > > Your use of Yahoo! Groups is subject to
            > > > > http://docs.yahoo.com/info/terms/
            > > > >
            > > > >
            > > >
            > > >
            > > > __________________________________________________
            > > > Do You Yahoo!?
            > > > Get email alerts & NEW webcam video instant messaging with Yahoo!
            > > > Messenger. http://im.yahoo.com
            > > >
            > > >
            > > > To unsubscribe from this group, send an email to:
            > > > soaplite-unsubscribe@yahoogroups.com
            > > >
            > > >
            > > >
            > > > Your use of Yahoo! Groups is subject to
            > > http://docs.yahoo.com/info/terms/
            > > >
            > > >
            > >
            > >
            > > ------------------------ Yahoo! Groups Sponsor
            > >
            > > To unsubscribe from this group, send an email to:
            > > soaplite-unsubscribe@yahoogroups.com
            > >
            > >
            > >
            > > Your use of Yahoo! Groups is subject to
            > > http://docs.yahoo.com/info/terms/
            > >
            > >
            >
            >
            > __________________________________________________
            > Do You Yahoo!?
            > Get email alerts & NEW webcam video instant messaging with Yahoo!
            > Messenger. http://im.yahoo.com
            >
            >
            > To unsubscribe from this group, send an email to:
            > soaplite-unsubscribe@yahoogroups.com
            >
            >
            >
            > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.