Loading ...
Sorry, an error occurred while loading the content.

SOAP::Transport::HTTP::Client::send_receive: HTTP/1.0 404 Not Found

Expand Messages
  • Clain, Dominique
    Hi, I m trying to set my own WSDL File, and i receive this error with the trace= all method: Is it due to a bad WSDL File or a configuration error... if I
    Message 1 of 3 , Feb 28, 2001
    • 0 Attachment
      SOAP::Transport::HTTP::Client::send_receive: HTTP/1.0 404 Not Found

      Hi,
      I' m trying to set my own WSDL File, and i receive this error with the "trace=>all" method:
      Is it due to a bad WSDL File or a configuration error...
      if I use my Example.pm generated by stubmaker.pl, i've got this error:

      ********************
      SOAP::Transport::new: ()
      SOAP::Serializer::new: ()
      SOAP::Deserializer::new: ()
      SOAP::Parser::new: ()
      SOAP::Lite::new: ()
      SOAP::Transport::HTTP::Client::new: ()
      SOAP::Lite::call: ()
      SOAP::Serializer::envelope: ()
      SOAP::Data::new: ()
      SOAP::Serializer::envelope: isLocal
      SOAP::Data::new: ()
      SOAP::Data::new: ()
      SOAP::Data::new: ()
      SOAP::Data::new: ()
      SOAP::Data::new: ()
      SOAP::Data::new: ()
      SOAP::Transport::HTTP::Client::send_receive: HTTP::Request=HASH(0x1da2358)
      SOAP::Transport::HTTP::Client::send_receive: POST http://localhost:8080/soap/rpc/router
      Accept: text/xml
      Accept: multipart/*
      Content-Length: 454
      Content-Type: text/xml
      SOAPAction: ""

      <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/1999/XMLSchema"><SOAP-ENV:Body><namesp1:isLocal xmlns:namesp1="lumos.lclient.ServerManager"/></SOAP-ENV:Body></SOAP-ENV:Envelope>

      SOAP::Transport::HTTP::Client::send_receive: HTTP::Response=HASH(0x22fb640)
      SOAP::Transport::HTTP::Client::send_receive: HTTP/1.0 404 Not Found
      Content-Length: 179
      Content-Type: text/html
      Client-Date: Thu, 01 Mar 2001 01:26:21 GMT
      Client-Peer: 127.0.0.1:8080
      Servlet-Engine: Tomcat Web Server/3.2.1 (JSP 1.1; Servlet 2.2; Java 1.3.0; Windows 2000 5.0 x86; java.vendor=Sun Microsystems Inc.)

      Title: Not Found (404)

      <head><title>Not Found (404)</title></head>
      <body><h1>Not Found (404)</h1>
      <b>Original request:</b> /soap/rpc/router<br><br>
      <b>Not found request:</b> /soap/rpc/router</body>

      SOAP::Deserializer::deserialize: ()
      SOAP::Parser::decode: ()
      SOAP call failed: 404 Not Found at schema2.pl line 10
      SOAP::Data::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::Transport::HTTP::Client::DESTROY: ()
      SOAP::Transport::DESTROY: ()
      SOAP::Serializer::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::Deserializer::DESTROY: ()
      SOAP::Lite::DESTROY: ()
      SOAP::Parser::DESTROY: ()
      *************************

      otherwise, if i use directly, i've got this error:

      *************************
      SOAP::Transport::new: ()
      SOAP::Serializer::new: ()
      SOAP::Deserializer::new: ()
      SOAP::Parser::new: ()
      SOAP::Lite::new: ()
      Can't locate object method "isLocal" via package "http://localhost:8080/test/soap/ServerManagerService.wsdl" at xmet.pl line 5.

      SOAP::Lite::DESTROY: ()
      SOAP::Serializer::DESTROY: ()
      SOAP::Transport::DESTROY: ()
      SOAP::Deserializer::DESTROY: ()
      SOAP::Parser::DESTROY: ()
      *************************

      If anyone have advice....
      Thanks..

      Dominique CLAIN
      Lumos Technologies Inc.
      dclain@...
      (310) 453-5832

    • Paul Kulchenko
      Hi, Clain! ... HTTP/1.0 404 Not Found Endpoint mentioned in WSDL file is not found. Either you didn t start the web server or endpoint specified in WSDL is
      Message 2 of 3 , Feb 28, 2001
      • 0 Attachment
        Hi, Clain!

        > Is it due to a bad WSDL File or a configuration error...
        HTTP/1.0 404 Not Found

        Endpoint mentioned in WSDL file is not found. Either you didn't start
        the web server or endpoint specified in WSDL is wrong. You choice?

        > Can't locate object method "isLocal" via package
        > "http://localhost:8080/test/soap/ServerManagerService.wsdl" at
        > xmet.pl
        > line 5.
        As for second error it looks like syntax error, but I cannot tell you
        more without looking into xmet.pl. Could you show the source?

        Best wishes, Paul.

        --- "Clain, Dominique" <Dominique.Clain@...> wrote:
        > Hi,
        > I' m trying to set my own WSDL File, and i receive this error with
        > the
        > "trace=>all" method:
        > Is it due to a bad WSDL File or a configuration error...
        > if I use my Example.pm generated by stubmaker.pl, i've got this
        > error:
        >
        > ********************
        > SOAP::Transport::new: ()
        > SOAP::Serializer::new: ()
        > SOAP::Deserializer::new: ()
        > SOAP::Parser::new: ()
        > SOAP::Lite::new: ()
        > SOAP::Transport::HTTP::Client::new: ()
        > SOAP::Lite::call: ()
        > SOAP::Serializer::envelope: ()
        > SOAP::Data::new: ()
        > SOAP::Serializer::envelope: isLocal
        > SOAP::Data::new: ()
        > SOAP::Data::new: ()
        > SOAP::Data::new: ()
        > SOAP::Data::new: ()
        > SOAP::Data::new: ()
        > SOAP::Data::new: ()
        > SOAP::Transport::HTTP::Client::send_receive:
        > HTTP::Request=HASH(0x1da2358)
        > SOAP::Transport::HTTP::Client::send_receive: POST
        > http://localhost:8080/soap/rpc/router
        > Accept: text/xml
        > Accept: multipart/*
        > Content-Length: 454
        > Content-Type: text/xml
        > SOAPAction: ""
        >
        > <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
        > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
        > SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
        > xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
        > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
        >
        xmlns:xsd="http://www.w3.org/1999/XMLSchema"><SOAP-ENV:Body><namesp1:isL
        > ocal
        >
        xmlns:namesp1="lumos.lclient.ServerManager"/></SOAP-ENV:Body></SOAP-ENV:
        > Envelope>
        > SOAP::Transport::HTTP::Client::send_receive:
        > HTTP::Response=HASH(0x22fb640)
        > SOAP::Transport::HTTP::Client::send_receive: HTTP/1.0 404 Not Found
        > Content-Length: 179
        > Content-Type: text/html
        > Client-Date: Thu, 01 Mar 2001 01:26:21 GMT
        > Client-Peer: 127.0.0.1:8080
        > Servlet-Engine: Tomcat Web Server/3.2.1 (JSP 1.1; Servlet 2.2; Java
        > 1.3.0; Windows 2000 5.0 x86; java.vendor=Sun Microsystems Inc.)
        > Title: Not Found (404)
        >
        > <head><title>Not Found (404)</title></head>
        > <body><h1>Not Found (404)</h1>
        > <b>Original request:</b> /soap/rpc/router<br><br>
        > <b>Not found request:</b> /soap/rpc/router</body>
        >
        > SOAP::Deserializer::deserialize: ()
        > SOAP::Parser::decode: ()
        > SOAP call failed: 404 Not Found at schema2.pl line 10
        > SOAP::Data::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::Transport::HTTP::Client::DESTROY: ()
        > SOAP::Transport::DESTROY: ()
        > SOAP::Serializer::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::Deserializer::DESTROY: ()
        > SOAP::Lite::DESTROY: ()
        > SOAP::Parser::DESTROY: ()
        > *************************
        >
        > otherwise, if i use directly, i've got this error:
        >
        > *************************
        > SOAP::Transport::new: ()
        > SOAP::Serializer::new: ()
        > SOAP::Deserializer::new: ()
        > SOAP::Parser::new: ()
        > SOAP::Lite::new: ()
        > Can't locate object method "isLocal" via package
        > "http://localhost:8080/test/soap/ServerManagerService.wsdl" at
        > xmet.pl
        > line 5.
        > SOAP::Lite::DESTROY: ()
        > SOAP::Serializer::DESTROY: ()
        > SOAP::Transport::DESTROY: ()
        > SOAP::Deserializer::DESTROY: ()
        > SOAP::Parser::DESTROY: ()
        > *************************
        >
        > If anyone have advice....
        > Thanks..
        >
        > Dominique CLAIN
        > Lumos Technologies Inc.
        > dclain@...
        > (310) 453-5832
        >
        >


        __________________________________________________
        Do You Yahoo!?
        Get email at your own domain with Yahoo! Mail.
        http://personal.mail.yahoo.com/
      • Clain, Dominique
        Thanks, it s doesn t work with http://localhost.... i change with my ip adress, and it works now... Thanks again.. Dominique CLAIN Lumos Technologies Inc.
        Message 3 of 3 , Feb 28, 2001
        • 0 Attachment
          RE: [soaplite] SOAP::Transport::HTTP::Client::send_receive: HTTP/1.0 404 Not Found

          Thanks,
          it's doesn't work with http://localhost....
          i change with my ip adress, and it works now...
          Thanks again..

          Dominique CLAIN
          Lumos Technologies Inc.
          dclain@...
          (310) 453-5832


          -----Original Message-----
          From: Paul Kulchenko [mailto:paulclinger@...]
          Sent: Wednesday, February 28, 2001 6:19 PM
          To: soaplite@yahoogroups.com
          Subject: Re: [soaplite] SOAP::Transport::HTTP::Client::send_receive:
          HTTP/1.0 404 Not Found


          Hi, Clain!

          > Is it due to a bad WSDL File or a configuration error...
          HTTP/1.0 404 Not Found

          Endpoint mentioned in WSDL file is not found. Either you didn't start
          the web server or endpoint specified in WSDL is wrong. You choice?

          > Can't locate object method "isLocal" via package
          > "http://localhost:8080/test/soap/ServerManagerService.wsdl" at
          > xmet.pl
          > line 5.
          As for second error it looks like syntax error, but I cannot tell you
          more without looking into xmet.pl. Could you show the source?

          Best wishes, Paul.

          --- "Clain, Dominique" <Dominique.Clain@...> wrote:
          > Hi,
          > I' m trying to set my own WSDL File, and i receive this error with
          > the
          > "trace=>all" method:
          > Is it due to a bad WSDL File or a configuration error...
          > if I use my Example.pm generated by stubmaker.pl, i've got this
          > error:
          >
          > ********************
          > SOAP::Transport::new: ()
          > SOAP::Serializer::new: ()
          > SOAP::Deserializer::new: ()
          > SOAP::Parser::new: ()
          > SOAP::Lite::new: ()
          > SOAP::Transport::HTTP::Client::new: ()
          > SOAP::Lite::call: ()
          > SOAP::Serializer::envelope: ()
          > SOAP::Data::new: ()
          > SOAP::Serializer::envelope: isLocal
          > SOAP::Data::new: ()
          > SOAP::Data::new: ()
          > SOAP::Data::new: ()
          > SOAP::Data::new: ()
          > SOAP::Data::new: ()
          > SOAP::Data::new: ()
          > SOAP::Transport::HTTP::Client::send_receive:
          > HTTP::Request=HASH(0x1da2358)
          > SOAP::Transport::HTTP::Client::send_receive: POST
          > http://localhost:8080/soap/rpc/router
          > Accept: text/xml
          > Accept: multipart/*
          > Content-Length: 454
          > Content-Type: text/xml
          > SOAPAction: ""
          >
          > <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
          > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
          > SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
          > xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
          > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
          >
          xmlns:xsd="http://www.w3.org/1999/XMLSchema"><SOAP-ENV:Body><namesp1:isL
          > ocal
          >
          xmlns:namesp1="lumos.lclient.ServerManager"/></SOAP-ENV:Body></SOAP-ENV:
          > Envelope>
          > SOAP::Transport::HTTP::Client::send_receive:
          > HTTP::Response=HASH(0x22fb640)
          > SOAP::Transport::HTTP::Client::send_receive: HTTP/1.0 404 Not Found
          > Content-Length: 179
          > Content-Type: text/html
          > Client-Date: Thu, 01 Mar 2001 01:26:21 GMT
          > Client-Peer: 127.0.0.1:8080
          > Servlet-Engine: Tomcat Web Server/3.2.1 (JSP 1.1; Servlet 2.2; Java
          > 1.3.0; Windows 2000 5.0 x86; java.vendor=Sun Microsystems Inc.)
          > Title: Not Found (404)
          >
          > <head><title>Not Found (404)</title></head>
          > <body><h1>Not Found (404)</h1>
          > <b>Original request:</b> /soap/rpc/router<br><br>
          > <b>Not found request:</b> /soap/rpc/router</body>
          >
          > SOAP::Deserializer::deserialize: ()
          > SOAP::Parser::decode: ()
          > SOAP call failed: 404 Not Found at schema2.pl line 10
          > SOAP::Data::DESTROY: ()
          > SOAP::Data::DESTROY: ()
          > SOAP::Data::DESTROY: ()
          > SOAP::Data::DESTROY: ()
          > SOAP::Transport::HTTP::Client::DESTROY: ()
          > SOAP::Transport::DESTROY: ()
          > SOAP::Serializer::DESTROY: ()
          > SOAP::Data::DESTROY: ()
          > SOAP::Data::DESTROY: ()
          > SOAP::Data::DESTROY: ()
          > SOAP::Deserializer::DESTROY: ()
          > SOAP::Lite::DESTROY: ()
          > SOAP::Parser::DESTROY: ()
          > *************************
          >
          > otherwise, if i use directly, i've got this error:
          >
          > *************************
          > SOAP::Transport::new: ()
          > SOAP::Serializer::new: ()
          > SOAP::Deserializer::new: ()
          > SOAP::Parser::new: ()
          > SOAP::Lite::new: ()
          > Can't locate object method "isLocal" via package
          > "http://localhost:8080/test/soap/ServerManagerService.wsdl" at
          > xmet.pl
          > line 5.
          > SOAP::Lite::DESTROY: ()
          > SOAP::Serializer::DESTROY: ()
          > SOAP::Transport::DESTROY: ()
          > SOAP::Deserializer::DESTROY: ()
          > SOAP::Parser::DESTROY: ()
          > *************************
          >
          > If anyone have advice....
          > Thanks..
          >
          > Dominique CLAIN
          > Lumos Technologies Inc.
          > dclain@...
          > (310) 453-5832
          >
          >


          __________________________________________________
          Do You Yahoo!?
          Get email at your own domain with Yahoo! Mail.
          http://personal.mail.yahoo.com/

          ------------------------ Yahoo! Groups Sponsor ---------------------~-~>
          Find software faster. Search more than 20,000
          software solutions on KnowledgeStorm. Register
          now and get started.
          http://us.click.yahoo.com/._XvHB/uMSCAA/zf4EAA/WNqXlB/TM
          ---------------------------------------------------------------------_->

          To unsubscribe from this group, send an email to:
          soaplite-unsubscribe@yahoogroups.com

           

          Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/


        Your message has been successfully submitted and would be delivered to recipients shortly.