Loading ...
Sorry, an error occurred while loading the content.

How do I force something other than 'xsi' for type prefix

Expand Messages
  • Rich T_
    I m having trouble getting a soap response to validate because there does not seem to be an easy way to change the prefix of type attributes. Setting
    Message 1 of 2 , Jan 11, 2012
    • 0 Attachment
      I'm having trouble getting a soap response to validate because there does not seem to be an easy way to change the prefix of type attributes. Setting $obj->type() to anything always uses xsi:type, which is fine for standard types, but not for complex types defined in the wsdl. I tried setting prefix but that didn't help.

      I'd also like to be able to set the additional namespaces in the Envelope.

      This has kept me busy for a few days, any help would be really appreciated.
    • Joseph Werner
      How are you building the data structure? Can you show us any SOAP::Data class objects in your code? ... -- Best Regards, [Joseph] Christian Werner Sr C
      Message 2 of 2 , Jan 11, 2012
      • 0 Attachment
        How are you building the data structure?  Can you show us any SOAP::Data class objects in your code?

        On Wed, Jan 11, 2012 at 4:19 PM, Rich T_ <rtomasso@...> wrote:
         

        I'm having trouble getting a soap response to validate because there does not seem to be an easy way to change the prefix of type attributes. Setting $obj->type() to anything always uses xsi:type, which is fine for standard types, but not for complex types defined in the wsdl. I tried setting prefix but that didn't help.

        I'd also like to be able to set the additional namespaces in the Envelope.

        This has kept me busy for a few days, any help would be really appreciated.




        --
        Best Regards,
        [Joseph] Christian Werner Sr
        C 360.920.7183
        H 757.304.0502

      Your message has been successfully submitted and would be delivered to recipients shortly.