Loading ...
Sorry, an error occurred while loading the content.
 

Re: [soaplite] "Peer certificate not verified" errors

Expand Messages
  • rahed
    ... Be sure to supply a correct SOAPAction header (set with on_action method as uri and method). -- Radek
    Message 1 of 5 , Jul 11 12:59 PM
      Karl Boyken <karl.boyken@...> writes:

      > Thisis the output received:
      >
      > <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="
      > http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="
      > http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="
      > http://www.w3.org/2001/XMLSchema"><soap:Body><soap:Fault><faultcode>soap:Client</faultcode><faultstring>Server
      > did not recognize the value of HTTP Header SOAPAction:
      > https://dnawebtesting.iowa.uiowa.edu/DNAData/MetaPeople/GetData.</faultstring><detail
      > /></soap:Fault></soap:Body></soap:Envelope>

      Be sure to supply a correct SOAPAction header (set with on_action method
      as uri and method).

      --
      Radek
    • Karl Boyken
      Thanks, but, aside from the fqdn of the web server, the header is identical to the one that works on the production server. Karl
      Message 2 of 5 , Jul 11 1:05 PM
        Thanks, but, aside from the fqdn of the web server, the header is
        identical to the one that works on the production server.

        Karl

        On Mon, Jul 11, 2011 at 2:59 PM, rahed <raherh@...> wrote:
        > Karl Boyken <karl.boyken@...> writes:
        >
        >> Thisis the output received:
        >>
        >> <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="
        >> http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="
        >> http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="
        >> http://www.w3.org/2001/XMLSchema"><soap:Body><soap:Fault><faultcode>soap:Client</faultcode><faultstring>Server
        >> did not recognize the value of HTTP Header SOAPAction:
        >> https://dnawebtesting.iowa.uiowa.edu/DNAData/MetaPeople/GetData.</faultstring><detail
        >> /></soap:Fault></soap:Body></soap:Envelope>
        >
        > Be sure to supply a correct SOAPAction header (set with on_action method
        > as uri and method).
        >
        > --
        > Radek
        >
      • Karl Boyken
        For completeness, I ve attached two files. soap_prod.txt is the SOAP::Lite trace and Crypt::SSLeay debug output for the production server, which works;
        Message 3 of 5 , Jul 12 11:39 AM
        For completeness, I've attached two files. soap_prod.txt is the
        SOAP::Lite trace and Crypt::SSLeay debug output for the production
        server, which works; soap_test.txt is the output for the test server
        that does not work. I've starred out the username and password.

        Karl Boyken

        --
        Karl Boyken, system administrator karl-boyken@...
        303A MLH, Dept. of Comp. Sci. http://www.cs.uiowa.edu/~boyken/
        The U. of Iowa, Iowa City, IA  52242   319-335-2730 (voice) 319-335-3668 (fax)
      • rahed
        ... I can t see any attachements with my mail client. -- Radek
        Message 4 of 5 , Jul 13 7:41 AM
          Karl Boyken <karl.boyken@...> writes:

          > For completeness, I've attached two files. soap_prod.txt is the
          > SOAP::Lite trace and Crypt::SSLeay debug output for the production
          > server, which works; soap_test.txt is the output for the test server
          > that does not work. I've starred out the username and password.

          I can't see any attachements with my mail client.

          --
          Radek
        Your message has been successfully submitted and would be delivered to recipients shortly.