Loading ...
Sorry, an error occurred while loading the content.

Re: Bad stub: syntax error... in connecting with Open Patent Services

Expand Messages
  • mtys0904
    Thank you. I tried ver.0710.08, but I got the similar error too... (Example) ================================================================ #!/usr/bin/perl
    Message 1 of 4 , Apr 20 5:11 AM
    • 0 Attachment
      Thank you.

      I tried ver.0710.08, but I got the similar error too...

      (Example)
      ================================================================
      #!/usr/bin/perl
      #use SOAP::Lite;
      use SOAP::Lite +trace => 'debug';

      my $service = SOAP::Lite->service('http://ops.epo.org/wsdl/ops.wsdl');
      ================================================================

      (Error message)
      ----------------------------------------------------------------
      Bad stub: syntax error at (eval 95) line 7, near "-and"
      at /usr/lib/perl5/site_perl/5.8.8/SOAP/Lite.pm line 3613
      ----------------------------------------------------------------

      As I was not able to upgrade SOAP::Lite ver. on Fedoracore3 environment, and I tried the ver.0710.08 on CentOS.

      My environment of this time is as follows;
      -CentOS release 5.2
      -Perl5.8.8
      -SOAP::Lite0.710.08

      This time, I did not specify the getDDBJEntry part.
      The Lite.pm error occurred at the same Function with the error result I got in my previous try.

      (Function incuding "lineĀ@3613")
      ============================================
      3608 # Naming? wsdl
      3609 sub service {
      3610 my $self = shift->new;
      3611 return $self->{'_service'} unless @_;
      3612 $self->schema->schema_url($self->{'_service'} = shift);
      3613 my %services = %{$self->schema->parse(@_)->load->services};

      Carp::croak "More than one service in service description.
      Service and port names have to be specifie
      d\n"
      if keys %services > 1;
      my $service = (keys %services)[0]->new;
      return $service;
      }
      ============================================

      I guess the error occurred in WSDL analysis process, but do you know how to avoid the error?

      Thank you again.

      Mitsu
    Your message has been successfully submitted and would be delivered to recipients shortly.