Loading ...
Sorry, an error occurred while loading the content.

dashes (hyphens) in WSDL comments

Expand Messages
  • tvoj_patak
    Hi All, Looks like SOAP::Lite on RHEL5 doesn t like dashes in comments. This manifests itself as junk before XML element . Unfortunately latest JAX-WS puts
    Message 1 of 1 , Jan 29, 2009
    • 0 Attachment
      Hi All,

      Looks like SOAP::Lite on RHEL5 doesn't like dashes in comments. This
      manifests itself as 'junk before XML element'. Unfortunately latest
      JAX-WS puts tons of dashes in wsdl comments.

      WSDL looks like this

      <?xml version="1.0" encoding="UTF-8"?><!-- Published by JAX-WS RI at
      http://jax-ws.dev.java.net RI's version is JAX-WS RI 2.1.3-b02-. --><
      !-- Generated by JAX-WS RI at http://jax-ws.dev.java.net RI's version
      is JAX-WS RI 2.1.3-b02-. --><definitions xmlns:soap=... etc.

      as soon as I remove all the dashes from the comments it works.

      To me it looks more like a perl issue or some dependant module issue
      since the rpm from Fedora Core 8 installed on rhel5 produces the same
      errors but works on fc8, but this is where I got stuck, rather
      bedazzled by the regexps I've found in the code ;)

      Any ideas?

      I have patched it like this, but obviously this is too ugly to go
      official ;)

      --- /usr/lib/perl5/vendor_perl/5.8.8/SOAP/Lite.pm.orig 2009-01-29
      11:31:25.000000000 +0100
      +++ /usr/lib/perl5/vendor_perl/5.8.8/SOAP/Lite.pm 2009-01-29
      11:32:06.000000000 +0100
      @@ -1670,7 +1670,9 @@
      #
      my $ret = undef;
      eval {
      - $ret = $self->parser->parse($_[0]);
      + my $a=$_[0];
      + $a =~ s/<!--.*?-->//g;
      + $ret = $self->parser->parse($a);
      };
      if ($@) {
      $self->final; # Clean up in the event of an error
      ----cut here ---
    Your message has been successfully submitted and would be delivered to recipients shortly.