Loading ...
Sorry, an error occurred while loading the content.

Re: SOAP calls fail randomly

Expand Messages
  • b. nyec
    Nope, time is not a factor. waited a few mins before making 6th request.   Discovered where the problem is, If i add a new package/pm and make my requests to
    Message 1 of 3 , Aug 25, 2008
    • 0 Attachment
      Nope, time is not a factor. waited a few mins before making 6th request.
       
      Discovered where the problem is,

      If i add a new package/pm and make my requests to the new methods, i get the problem described in my first post. restarting apache (HUP) clears the problem. which is the correct way when adding/modifing any packages/methods, at least from what i understand.

      Thanks for the help. :)

      - B


      --- On Sat, 8/23/08, patrick mariani <pat.mariani@...> wrote:
      From: patrick mariani <pat.mariani@...>
      Subject: Re: [soaplite] SOAP calls fail randomly
      To: "bnyec" <bnyec@...>
      Date: Saturday, August 23, 2008, 1:54 AM

      i rethought that early answer about number of clients, my original thought was that
      the children were hanging, but i didn't read your detail closely enough.
       
      is it time sensitive?  in other words if you wait 60 seconds before the 6th call,
      will it work?  if you jam another http request in, does it work, does the soap request then work?
       
      almost as if one of the httpd processes didn't get the signal to reload the conf??
      soes it happen after a restart?
       
      as a test, i believe the httpd procs can be configured to only server one request, then
      fork and restart - not efficient to leave it that way, but may provide short term info.
       
      I'll try it monday
      pat
       
       
       
      ----- Original Message -----
      From: bnyec
      Sent: Friday, August 22, 2008 2:24 PM
      Subject: [soaplite] SOAP calls fail randomly

      Apache/2.2.4
      mod_perl/2.0. 3
      Perl/v5.8.8
      SOAP-Lite-0. 710.08

      Ive noticed that sometimes my soap requests will fail every 6th
      request which is the same number of httpd children that are running.

      httpd.conf
      [....]

      <Location /soap>
      SetHandler perl-script
      PerlSendHeader On
      PerlHandler Apache::SOAP
      PerlSetVar dispatch_to "/path/to/modules"
      PerlSetVar options "compress_threshold => 10000"
      </Location>

      $ ps -auxx | grep httpd | wc -l
      6
      $ ./test-client. pl
      Resopnse: test
      $ ./test-client. pl
      Resopnse: test
      $ ./test-client. pl
      Resopnse: test
      $ ./test-client. pl
      Resopnse: test
      $ ./test-client. pl
      Resopnse: test
      $ ./test-client. pl
      <faultstring> Failed to locate method (my_meathod) in class (testing)
      at /usr/local/lib/ perl5/site_ perl/5.8. 8/SOAP/Lite. pm line 2765.
      </faultstring>
      $ ./test-client. pl
      Resopnse: test

      [... next 5 and error occurs agian ...]

      Over on the perl.apache. org mailing list someone has had a similar
      problem, but hadn't seen what might be causing the problem.

      Further Details:
      http://marc. info/?l=apache- modperl&m= 117759312529637& w=2

      Anyone have any idea's ??

      - B


    Your message has been successfully submitted and would be delivered to recipients shortly.