Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] how to set the env prefix

Expand Messages
  • patrick mariani
    I had the same issue with the SOAP-ENV prefix - here is the answer. http://tech.groups.yahoo.com/group/soaplite/message/6124 p. ... From: cracknphrack To:
    Message 1 of 3 , Aug 25, 2008
    • 0 Attachment
      I had the same issue with the SOAP-ENV prefix - here
      is the answer.
       
       
      p.
       
       
       
      ----- Original Message -----
      Sent: Sunday, August 24, 2008 4:52 AM
      Subject: [soaplite] how to set the env prefix

      I am using SOAP::WSDL (what I heard is a pre processor to the
      SOAP::Lite that runs underneath).
      Started with the usual wsdl2perl generated files (very handy, btw).

      The soap that is generated is *almost* acceptable to the picky .NET
      server that I'm trying to communicate with.
      The two missing parts (that the server administrator has pointed out
      to me) are:
      1) I need to change the prefix of the envelope from "SOAP-ENV" to "soap"

      2) I need to have the <?xml version="1.0" encoding="utf- 8"?> as the
      very first line of the request.

      I thought #2 happened by default, but I guess not.

      I tried a simple $soap->envprefix( 'soap'), but it rejected me with
      "Can't locate object method "envprefix""

      How do I solve the above two problems?
      Thanks.

    Your message has been successfully submitted and would be delivered to recipients shortly.