Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] Passing & via SOAP::Lite

Expand Messages
  • Mark Knoop
    Rahed - ... Chris - ... Thanks guys - this helped alot. I was a bit unsure re the behaviour changing in the newer version of SOAP::Lite - also I was using XML
    Message 1 of 4 , Jul 14, 2008
    • 0 Attachment
      Rahed -
      > Have a look at SOAP/Lite.pm. Description starting at line 359
      > (SOAP::Lite, v.0.710.07) may be helpful.
      > hth
      >
      > --
      > Radek
      >

      Chris -
      > This is a normal substitution and *should* happen automatically; &
      > (like < and >) is an illegal XML character, so it gets encoded as
      > & in the SOAP XML message and is parsed back out at decode.
      >
      > However, older versions of SOAP::Lite didn't do this substitution; I
      > just upgraded all my Ubuntu 6 boxen from 0.66 (the version from the
      > distribution) to the latest 0.71 from CPAN in order to fix this
      > specific issue. I'm sure you'll find other SOAP implementations that
      > don't do this automatically either.
      >
      > HTH,
      >


      Thanks guys - this helped alot. I was a bit unsure re the behaviour changing
      in the newer version of SOAP::Lite - also I was using XML tokens in my logs
      which were encoding the & again and confusing me. I got it working now.

      Cheers
      Mark
    Your message has been successfully submitted and would be delivered to recipients shortly.