Loading ...
Sorry, an error occurred while loading the content.

Re: "Crypt::SSLeay not installed" error

Expand Messages
  • Victor A. Rodriguez
    Hi, ... That s correct !! ... Please, try to ask to the .NET people if now the web service redirects to a new URL that is server through SSL. BTW, if you
    Message 1 of 2 , Jan 14, 2008
    View Source
    • 0 Attachment
      Hi,

      --- In soaplite@yahoogroups.com, "nrocha18" <nuno.a.rocha@...> wrote:
      >
      > Hi,
      >
      > I've been using SOAP::Lite module to access a .NET webservice from a
      > unix machine.
      > Everything was going smoothly until I changed the localization of the
      > .NET webservice to another machine. Since then, I've not been able to
      > complete any request because of the error
      > "SOAP::Transport::HTTP::Client::send_receive: 501 Protocol scheme
      > 'https' is not supported (Crypt::SSLeay not installed)".
      >
      > I've googled about it and it looks like this happens because I'm
      > trying to use https connection without having the Crypt:SSLeay module
      > installed.

      That's correct !!

      > But the address that I put on the proxy property is a simple http!
      > My source code is as follows:

      Please, try to ask to the .NET people if now the web service redirects
      to a new URL that is server through SSL.
      BTW, if you install the Crypt:SSLeay module perhaps the problem goes
      out of your sight, and protects you from similar problems witha
      protocol change behind the curtains.

      Hope this helps
    Your message has been successfully submitted and would be delivered to recipients shortly.