Loading ...
Sorry, an error occurred while loading the content.

Return value wrong

Expand Messages
  • Oeschey, Lars (I/EK-142, extern)
    Hi, I test a little script currently that talks to a SOAP server (Deplhi I think). I have used stubgenerator to get a perl module. Although the server should
    Message 1 of 2 , Nov 21, 2007
    • 0 Attachment
      Hi,

      I test a little script currently that talks to a SOAP server (Deplhi I
      think). I have used stubgenerator to get a perl module. Although the
      server should return a "0" (no error) I get a "1". Could the module be
      the reason?

      heres the code:
      use strict;
      use SoapService qw(teInput);
      my $result=teInput("test0","test1");
      print $result;

      Lars
    • Oeschey, Lars (I/EK-142, extern)
      ... my fault, I solved it. The SOAP server checks the values, so the returned 1 was indeed correct, since my values were illegal ;) Lars
      Message 2 of 2 , Nov 22, 2007
      • 0 Attachment
        > I test a little script currently that talks to a SOAP server (Deplhi I
        > think). I have used stubgenerator to get a perl module. Although the
        > server should return a "0" (no error) I get a "1". Could the module be
        > the reason?
        >
        > heres the code:
        > use strict;
        > use SoapService qw(teInput);
        > my $result=teInput("test0","test1");
        > print $result;

        my fault, I solved it. The SOAP server checks the values, so the
        returned "1" was indeed correct, since my values were illegal ;)

        Lars
      Your message has been successfully submitted and would be delivered to recipients shortly.