Loading ...
Sorry, an error occurred while loading the content.

Re: SOAP::Lite and wsdl

Expand Messages
  • I.B.
    it was a typo in 2nd case. but the main issue still remains - example from documentation returns null pointer exception. is it only for me?
    Message 1 of 5 , Jun 19, 2007
    • 0 Attachment
      it was a typo in 2nd case. but the main issue still remains - example
      from documentation returns null pointer exception. is it only for me?


      On 6/19/07, I. B. <ig3v10@...> wrote:
      > Hi,
      > i installed SOAP::Lite using cpan shell:
      > install SOAP::Lite
      >
      > it compiled and build ok.
      > but following test from module documentation
      > silently failed, without printing out anything
      >
      > use SOAP::Lite;
      > print SOAP::Lite
      > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
      > -> getQuote('MSFT');
      >
      >
      > this is debug information (+trace):
      >
      > SOAP::Transport::HTTP::Client::send_receive: HTTP::Request=HASH(0x87d5968)
      > SOAP::Transport::HTTP::Client::send_receive: POST
      > http://services.xmethods.net/soap HTTP/1.1
      > Accept: text/xml
      > Accept: multipart/*
      > Accept: application/soap
      > Content-Length: 675
      > Content-Type: text/xml; charset=utf-8
      > SOAPAction: "urn:xmethods-delayed-quotes#getQuote"
      >
      > <?xml version="1.0" encoding="UTF-8"?><soap:Envelope
      > xmlns:namesp1="urn:xmethods-delayed-quotes"
      > xmlns:electric="http://www.themindelectric.com/"
      > soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
      > xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
      > xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
      > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      > xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
      > xmlns:tns="http://www.themindelectric.com/wsdl/net.xmethods.services.stockquote.StockQuote/"
      > xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><namesp1:getQuote><symbol
      > xsi:type="xsd:string">MSFT</symbol></namesp1:getQuote></soap:Body></soap:Envelope>
      > SOAP::Transport::HTTP::Client::send_receive: HTTP::Response=HASH(0x87b9d00)
      > SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 500 Internal Server Error
      > Connection: close
      > Date: Tue, 19 Jun 2007 20:16:19 GMT
      > Server: Electric/1.0
      > Content-Length: 1359
      > Content-Type: text/xml
      > Client-Date: Tue, 19 Jun 2007 20:16:29 GMT
      > Client-Peer: 38.102.129.128:80
      > Client-Response-Num: 1
      > X-Cache: MISS from www.xmethods.net
      >
      > <?xml version='1.0' encoding='UTF-8'?>
      > <soap:Envelope xmlns:soap='http://schemas.xmlsoap.org/soap/envelope/'
      > xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'
      > xmlns:xsd='http://www.w3.org/2001/XMLSchema'
      > xmlns:soapenc='http://schemas.xmlsoap.org/soap/encoding/'
      > soap:encodingStyle='http://schemas.xmlsoap.org/soap/encoding/'><soap:Body><soap:Fault><faultcode>soap:Server</faultcode><faultstring/><detail><e:electric-detail
      > xmlns:e='http://www.themindelectric.com/'><class>java.lang.NullPointerException</class><message/><trace>java.lang.NullPointerException
      > at electric.net.soap.http.SOAPHandler.getPath(SOAPHandler.java:128)
      > at electric.net.soap.http.SOAPHandler.service(SOAPHandler.java:76)
      > at electric.server.http.ServletServer.service(ServletServer.java:218)
      > at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
      > at electric.net.servlet.Config.service(Config.java:182)
      > at electric.net.http.HTTPContext.service(HTTPContext.java:118)
      > at electric.net.servlet.Servlets.service(Servlets.java:47)
      > at electric.net.http.WebServer.service(WebServer.java:127)
      > at electric.net.tcp.TCPServer.run(TCPServer.java:145)
      > at electric.net.tcp.Request.run(TCPServer.java:262)
      > at electric.util.ThreadPool.run(ThreadPool.java:105)
      > at java.lang.Thread.run(Thread.java:479)
      > </trace></e:electric-detail></detail></soap:Fault></soap:Body></soap:Envelope>
      > SOAP::Deserializer::deserialize: ()
      > SOAP::Parser::decode: ()
      >
      >
      >
      >
      > When i use my company wsdl, i am getting following message:
      >
      > "Nothing to access. URL is not specified at
      > /usr/lib/perl5/site_perl/5.8.5/SOAP/Lite.pm line 3360"
      >
      > which is not clear for me. Why URL is expected if I have provided WSDL ?
      >
      >
      >
      > thank you for any help.
      >
      > Ig
      >
    • martinh2osport
      It s ok for me, ... #!/usr/bin/perl use SOAP::Lite; print SOAP::Lite - service( http://www.xmethods.net/sd/StockQuoteService.wsdl ) - getQuote( MSFT ); ...
      Message 2 of 5 , Jun 21, 2007
      • 0 Attachment
        It's ok for me,

        :~# cat soapTest.pl
        #!/usr/bin/perl

        use SOAP::Lite;
        print SOAP::Lite
        -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
        -> getQuote('MSFT');

        :~# ./soapTest.pl
        30.22:~#

        using debian;

        perl 5.8.4

        and the apt package on debian for soaplite

        Source: soap-lite
        Version: 0.60-2

        Martin



        --- In soaplite@yahoogroups.com, I.B. <ig3v10@...> wrote:
        >
        > it was a typo in 2nd case. but the main issue still remains - example
        > from documentation returns null pointer exception. is it only for me?
        >
        >
        > On 6/19/07, I. B. <ig3v10@...> wrote:
        > > Hi,
        > > i installed SOAP::Lite using cpan shell:
        > > install SOAP::Lite
        > >
        > > it compiled and build ok.
        > > but following test from module documentation
        > > silently failed, without printing out anything
        > >
        > > use SOAP::Lite;
        > > print SOAP::Lite
        > > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
        > > -> getQuote('MSFT');
        > >
        > >
        > > this is debug information (+trace):
        > >
        > > SOAP::Transport::HTTP::Client::send_receive:
        HTTP::Request=HASH(0x87d5968)
        > > SOAP::Transport::HTTP::Client::send_receive: POST
        > > http://services.xmethods.net/soap HTTP/1.1
        > > Accept: text/xml
        > > Accept: multipart/*
        > > Accept: application/soap
        > > Content-Length: 675
        > > Content-Type: text/xml; charset=utf-8
        > > SOAPAction: "urn:xmethods-delayed-quotes#getQuote"
        > >
        > > <?xml version="1.0" encoding="UTF-8"?><soap:Envelope
        > > xmlns:namesp1="urn:xmethods-delayed-quotes"
        > > xmlns:electric="http://www.themindelectric.com/"
        > > soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
        > > xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
        > > xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
        > > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        > > xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
        > >
        xmlns:tns="http://www.themindelectric.com/wsdl/net.xmethods.services.stockquote.StockQuote/"
        > >
        xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><namesp1:getQuote><symbol
        > >
        xsi:type="xsd:string">MSFT</symbol></namesp1:getQuote></soap:Body></soap:Envelope>
        > > SOAP::Transport::HTTP::Client::send_receive:
        HTTP::Response=HASH(0x87b9d00)
        > > SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 500 Internal
        Server Error
        > > Connection: close
        > > Date: Tue, 19 Jun 2007 20:16:19 GMT
        > > Server: Electric/1.0
        > > Content-Length: 1359
        > > Content-Type: text/xml
        > > Client-Date: Tue, 19 Jun 2007 20:16:29 GMT
        > > Client-Peer: 38.102.129.128:80
        > > Client-Response-Num: 1
        > > X-Cache: MISS from www.xmethods.net
        > >
        > > <?xml version='1.0' encoding='UTF-8'?>
        > > <soap:Envelope xmlns:soap='http://schemas.xmlsoap.org/soap/envelope/'
        > > xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'
        > > xmlns:xsd='http://www.w3.org/2001/XMLSchema'
        > > xmlns:soapenc='http://schemas.xmlsoap.org/soap/encoding/'
        > >
        soap:encodingStyle='http://schemas.xmlsoap.org/soap/encoding/'><soap:Body><soap:Fault><faultcode>soap:Server</faultcode><faultstring/><detail><e:electric-detail
        > >
        xmlns:e='http://www.themindelectric.com/'><class>java.lang.NullPointerException</class><message/><trace>java.lang.NullPointerException
        > > at
        electric.net.soap.http.SOAPHandler.getPath(SOAPHandler.java:128)
        > > at
        electric.net.soap.http.SOAPHandler.service(SOAPHandler.java:76)
        > > at
        electric.server.http.ServletServer.service(ServletServer.java:218)
        > > at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
        > > at electric.net.servlet.Config.service(Config.java:182)
        > > at electric.net.http.HTTPContext.service(HTTPContext.java:118)
        > > at electric.net.servlet.Servlets.service(Servlets.java:47)
        > > at electric.net.http.WebServer.service(WebServer.java:127)
        > > at electric.net.tcp.TCPServer.run(TCPServer.java:145)
        > > at electric.net.tcp.Request.run(TCPServer.java:262)
        > > at electric.util.ThreadPool.run(ThreadPool.java:105)
        > > at java.lang.Thread.run(Thread.java:479)
        > >
        </trace></e:electric-detail></detail></soap:Fault></soap:Body></soap:Envelope>
        > > SOAP::Deserializer::deserialize: ()
        > > SOAP::Parser::decode: ()
        > >
        > >
        > >
        > >
        > > When i use my company wsdl, i am getting following message:
        > >
        > > "Nothing to access. URL is not specified at
        > > /usr/lib/perl5/site_perl/5.8.5/SOAP/Lite.pm line 3360"
        > >
        > > which is not clear for me. Why URL is expected if I have provided
        WSDL ?
        > >
        > >
        > >
        > > thank you for any help.
        > >
        > > Ig
        > >
        >
      • martinh2osport
        Almost :-( my main server is back now still debian but, perl 5.8.8 soaplite ii libsoap-lite-perl 0.69-1 from debug soap request that works;
        Message 3 of 5 , Jun 21, 2007
        • 0 Attachment
          Almost :-(

          my main server is back now still debian but, perl 5.8.8 soaplite

          ii libsoap-lite-perl 0.69-1

          from debug soap request that works;

          <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
          xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
          xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
          xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
          xmlns:xsd="http://www.w3.org/1999/XMLSchema"
          SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><namesp1:getQuote
          xmlns:namesp1="urn:xmethods-delayed-quotes"><symbol
          xsi:type="xsd:string">MSFT</symbol></namesp1:getQuote></SOAP-ENV:Body></SOAP-ENV:Envelope>

          soap request that gets exception;

          <?xml version="1.0" encoding="UTF-8"?><soap:Envelope
          xmlns:namesp1="urn:xmethods-delayed-quotes"
          xmlns:electric="http://www.themindelectric.com/"
          soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
          xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
          xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
          xmlns:tns="http://www.themindelectric.com/wsdl/net.xmethods.services.stockquote.StockQuote/"
          xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><namesp1:getQuote><symbol
          xsi:type="xsd:string">MSFT</symbol></namesp1:getQuote></soap:Body></soap:Envelope>

          Not sure if this helps much,

          Martin



          --- In soaplite@yahoogroups.com, "martinh2osport" <martin@...> wrote:
          >
          >
          > It's ok for me,
          >
          > :~# cat soapTest.pl
          > #!/usr/bin/perl
          >
          > use SOAP::Lite;
          > print SOAP::Lite
          > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
          > -> getQuote('MSFT');
          >
          > :~# ./soapTest.pl
          > 30.22:~#
          >
          > using debian;
          >
          > perl 5.8.4
          >
          > and the apt package on debian for soaplite
          >
          > Source: soap-lite
          > Version: 0.60-2
          >
          > Martin
          >
          >
          >
          > --- In soaplite@yahoogroups.com, I.B. <ig3v10@> wrote:
          > >
          > > it was a typo in 2nd case. but the main issue still remains - example
          > > from documentation returns null pointer exception. is it only for me?
          > >
          > >
          > > On 6/19/07, I. B. <ig3v10@> wrote:
          > > > Hi,
          > > > i installed SOAP::Lite using cpan shell:
          > > > install SOAP::Lite
          > > >
          > > > it compiled and build ok.
          > > > but following test from module documentation
          > > > silently failed, without printing out anything
          > > >
          > > > use SOAP::Lite;
          > > > print SOAP::Lite
          > > > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
          > > > -> getQuote('MSFT');
          > > >
          > > >
          > > > this is debug information (+trace):
          > > >
          > > > SOAP::Transport::HTTP::Client::send_receive:
          > HTTP::Request=HASH(0x87d5968)
          > > > SOAP::Transport::HTTP::Client::send_receive: POST
          > > > http://services.xmethods.net/soap HTTP/1.1
          > > > Accept: text/xml
          > > > Accept: multipart/*
          > > > Accept: application/soap
          > > > Content-Length: 675
          > > > Content-Type: text/xml; charset=utf-8
          > > > SOAPAction: "urn:xmethods-delayed-quotes#getQuote"
          > > >
          > > > <?xml version="1.0" encoding="UTF-8"?><soap:Envelope
          > > > xmlns:namesp1="urn:xmethods-delayed-quotes"
          > > > xmlns:electric="http://www.themindelectric.com/"
          > > > soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
          > > > xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
          > > > xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
          > > > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          > > > xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
          > > >
          >
          xmlns:tns="http://www.themindelectric.com/wsdl/net.xmethods.services.stockquote.StockQuote/"
          > > >
          >
          xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><namesp1:getQuote><symbol
          > > >
          >
          xsi:type="xsd:string">MSFT</symbol></namesp1:getQuote></soap:Body></soap:Envelope>
          > > > SOAP::Transport::HTTP::Client::send_receive:
          > HTTP::Response=HASH(0x87b9d00)
          > > > SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 500 Internal
          > Server Error
          > > > Connection: close
          > > > Date: Tue, 19 Jun 2007 20:16:19 GMT
          > > > Server: Electric/1.0
          > > > Content-Length: 1359
          > > > Content-Type: text/xml
          > > > Client-Date: Tue, 19 Jun 2007 20:16:29 GMT
          > > > Client-Peer: 38.102.129.128:80
          > > > Client-Response-Num: 1
          > > > X-Cache: MISS from www.xmethods.net
          > > >
          > > > <?xml version='1.0' encoding='UTF-8'?>
          > > > <soap:Envelope
          xmlns:soap='http://schemas.xmlsoap.org/soap/envelope/'
          > > > xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'
          > > > xmlns:xsd='http://www.w3.org/2001/XMLSchema'
          > > > xmlns:soapenc='http://schemas.xmlsoap.org/soap/encoding/'
          > > >
          >
          soap:encodingStyle='http://schemas.xmlsoap.org/soap/encoding/'><soap:Body><soap:Fault><faultcode>soap:Server</faultcode><faultstring/><detail><e:electric-detail
          > > >
          >
          xmlns:e='http://www.themindelectric.com/'><class>java.lang.NullPointerException</class><message/><trace>java.lang.NullPointerException
          > > > at
          > electric.net.soap.http.SOAPHandler.getPath(SOAPHandler.java:128)
          > > > at
          > electric.net.soap.http.SOAPHandler.service(SOAPHandler.java:76)
          > > > at
          > electric.server.http.ServletServer.service(ServletServer.java:218)
          > > > at
          javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
          > > > at electric.net.servlet.Config.service(Config.java:182)
          > > > at
          electric.net.http.HTTPContext.service(HTTPContext.java:118)
          > > > at electric.net.servlet.Servlets.service(Servlets.java:47)
          > > > at electric.net.http.WebServer.service(WebServer.java:127)
          > > > at electric.net.tcp.TCPServer.run(TCPServer.java:145)
          > > > at electric.net.tcp.Request.run(TCPServer.java:262)
          > > > at electric.util.ThreadPool.run(ThreadPool.java:105)
          > > > at java.lang.Thread.run(Thread.java:479)
          > > >
          >
          </trace></e:electric-detail></detail></soap:Fault></soap:Body></soap:Envelope>
          > > > SOAP::Deserializer::deserialize: ()
          > > > SOAP::Parser::decode: ()
          > > >
          > > >
          > > >
          > > >
          > > > When i use my company wsdl, i am getting following message:
          > > >
          > > > "Nothing to access. URL is not specified at
          > > > /usr/lib/perl5/site_perl/5.8.5/SOAP/Lite.pm line 3360"
          > > >
          > > > which is not clear for me. Why URL is expected if I have provided
          > WSDL ?
          > > >
          > > >
          > > >
          > > > thank you for any help.
          > > >
          > > > Ig
          > > >
          > >
          >
        • I.B.
          Allright, thank you for help. at least we narrowed it to my box only. Example work from my another system.
          Message 4 of 5 , Jun 22, 2007
          • 0 Attachment
            Allright,
            thank you for help. at least we narrowed it to my box only.
            Example work from my another system.
             
            On 6/21/07, martinh2osport <martin@...> wrote:


            Almost :-(

            my main server is back now still debian but, perl 5.8.8 soaplite

            ii libsoap-lite-perl 0.69-1

            from debug soap request that works;

            <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
            xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
            xmlns:SOAP-ENC=" http://schemas.xmlsoap.org/soap/encoding/"
            xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/ "
            xmlns:xsd="http://www.w3.org/1999/XMLSchema"
            SOAP-ENV:encodingStyle=" http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><namesp1:getQuote
            xmlns:namesp1="urn:xmethods-delayed-quotes"><symbol
            xsi:type="xsd:string">MSFT</symbol></namesp1:getQuote></SOAP-ENV:Body></SOAP-ENV:Envelope>

            soap request that gets exception;

            <?xml version="1.0" encoding="UTF-8"?><soap:Envelope
            xmlns:namesp1="urn:xmethods-delayed-quotes"
            xmlns:electric=" http://www.themindelectric.com/"
            soap:encodingStyle=" http://schemas.xmlsoap.org/soap/encoding/"
            xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/ "
            xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
            xmlns:xsi=" http://www.w3.org/2001/XMLSchema-instance"
            xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/ "
            xmlns:tns="http://www.themindelectric.com/wsdl/net.xmethods.services.stockquote.StockQuote/ "
            xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><namesp1:getQuote><symbol
            xsi:type="xsd:string">MSFT</symbol></namesp1:getQuote></soap:Body></soap:Envelope>

            Not sure if this helps much,

            Martin



            --- In soaplite@yahoogroups.com, "martinh2osport" <martin@...> wrote:
            >
            >
            > It's ok for me,
            >
            > :~# cat soapTest.pl
            > #!/usr/bin/perl
            >
            > use SOAP::Lite;
            > print SOAP::Lite
            > -> service(' http://www.xmethods.net/sd/StockQuoteService.wsdl')
            > -> getQuote('MSFT');
            >
            > :~# ./soapTest.pl
            > 30.22:~#
            >
            > using debian;
            >
            > perl 5.8.4
            >
            > and the apt package on debian for soaplite
            >
            > Source: soap-lite
            > Version: 0.60-2
            >
            > Martin
            >
            >
            >
            > --- In soaplite@yahoogroups.com, I.B. <ig3v10@> wrote:
            > >
            > > it was a typo in 2nd case. but the main issue still remains - example
            > > from documentation returns null pointer exception. is it only for me?
            > >
            > >
            > > On 6/19/07, I. B. <ig3v10@> wrote:
            > > > Hi,
            > > > i installed SOAP::Lite using cpan shell:
            > > > install SOAP::Lite
            > > >
            > > > it compiled and build ok.
            > > > but following test from module documentation
            > > > silently failed, without printing out anything
            > > >
            > > > use SOAP::Lite;
            > > > print SOAP::Lite
            > > > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl ')
            > > > -> getQuote('MSFT');
            > > >
            > > >
            > > > this is debug information (+trace):
            > > >
            > > > SOAP::Transport::HTTP::Client::send_receive:
            > HTTP::Request=HASH(0x87d5968)
            > > > SOAP::Transport::HTTP::Client::send_receive: POST
            > > > http://services.xmethods.net/soap HTTP/1.1
            > > > Accept: text/xml
            > > > Accept: multipart/*
            > > > Accept: application/soap
            > > > Content-Length: 675
            > > > Content-Type: text/xml; charset=utf-8
            > > > SOAPAction: "urn:xmethods-delayed-quotes#getQuote"
            > > >
            > > > <?xml version="1.0" encoding="UTF-8"?><soap:Envelope
            > > > xmlns:namesp1="urn:xmethods-delayed-quotes"
            > > > xmlns:electric="http://www.themindelectric.com/"
            > > > soap:encodingStyle=" http://schemas.xmlsoap.org/soap/encoding/"
            > > > xmlns:soap=" http://schemas.xmlsoap.org/wsdl/soap/"
            > > > xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/ "
            > > > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
            > > > xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
            > > >
            >
            xmlns:tns="http://www.themindelectric.com/wsdl/net.xmethods.services.stockquote.StockQuote/ "
            > > >
            >
            xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><namesp1:getQuote><symbol
            > > >
            >
            xsi:type="xsd:string">MSFT</symbol></namesp1:getQuote></soap:Body></soap:Envelope>
            > > > SOAP::Transport::HTTP::Client::send_receive:
            > HTTP::Response=HASH(0x87b9d00)
            > > > SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 500 Internal
            > Server Error
            > > > Connection: close
            > > > Date: Tue, 19 Jun 2007 20:16:19 GMT
            > > > Server: Electric/1.0
            > > > Content-Length: 1359
            > > > Content-Type: text/xml
            > > > Client-Date: Tue, 19 Jun 2007 20:16:29 GMT
            > > > Client-Peer: 38.102.129.128:80
            > > > Client-Response-Num: 1
            > > > X-Cache: MISS from www.xmethods.net
            > > >
            > > > <?xml version='1.0' encoding='UTF-8'?>
            > > > <soap:Envelope
            xmlns:soap='http://schemas.xmlsoap.org/soap/envelope/ '
            > > > xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'
            > > > xmlns:xsd=' http://www.w3.org/2001/XMLSchema'
            > > > xmlns:soapenc=' http://schemas.xmlsoap.org/soap/encoding/'
            > > >
            >
            soap:encodingStyle=' http://schemas.xmlsoap.org/soap/encoding/'><soap:Body><soap:Fault><faultcode>soap:Server</faultcode><faultstring/><detail><e:electric-detail
            > > >
            >
            xmlns:e=' http://www.themindelectric.com/'><class>java.lang.NullPointerException</class><message/><trace> java.lang.NullPointerException
            > > > at
            > electric.net.soap.http.SOAPHandler.getPath(SOAPHandler.java :128)
            > > > at
            > electric.net.soap.http.SOAPHandler.service(SOAPHandler.java:76)
            > > > at
            > electric.server.http.ServletServer.service(ServletServer.java:218)
            > > > at
            javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
            > > > at electric.net.servlet.Config.service(Config.java:182)
            > > > at
            electric.net.http.HTTPContext.service( HTTPContext.java:118)
            > > > at electric.net.servlet.Servlets.service(Servlets.java:47)
            > > > at electric.net.http.WebServer.service(WebServer.java:127)
            > > > at electric.net.tcp.TCPServer.run(TCPServer.java:145)
            > > > at electric.net.tcp.Request.run(TCPServer.java :262)
            > > > at electric.util.ThreadPool.run(ThreadPool.java:105)
            > > > at java.lang.Thread.run(Thread.java:479)
            > > >
            >
            </trace></e:electric-detail></detail></soap:Fault></soap:Body></soap:Envelope>
            > > > SOAP::Deserializer::deserialize: ()
            > > > SOAP::Parser::decode: ()
            > > >
            > > >
            > > >
            > > >
            > > > When i use my company wsdl, i am getting following message:
            > > >
            > > > "Nothing to access. URL is not specified at
            > > > /usr/lib/perl5/site_perl/5.8.5/SOAP/ Lite.pm line 3360"
            > > >
            > > > which is not clear for me. Why URL is expected if I have provided
            > WSDL ?
            > > >
            > > >
            > > >
            > > > thank you for any help.
            > > >
            > > > Ig
            > > >
            > >
            >


          Your message has been successfully submitted and would be delivered to recipients shortly.