Loading ...
Sorry, an error occurred while loading the content.

SOAP-Lite0.69 on perl 5.005 Can't locate warnings.pm

Expand Messages
  • marcremijn
    I get: Can t locate warnings.pm in @INC (@INC contains: /home/marcr/perllibs/sun4- solaris /home/marcr/perllibs /usr/perl5/5.00503/sun4- solaris
    Message 1 of 1 , Mar 15, 2007
    • 0 Attachment
      I get:

      Can't locate warnings.pm in @INC (@INC
      contains: /home/marcr/perllibs/sun4-
      solaris /home/marcr/perllibs /usr/perl5/5.00503/sun4-
      solaris /usr/perl5/5.00503 /usr/perl5/site_perl/5.005/sun4-
      solaris /usr/perl5/site_perl/5.005 .)
      at /home/marcr/perllibs/SOAP/Transport/HTTP.pm line 39.
      BEGIN failed--compilation aborted
      at /home/marcr/perllibs/SOAP/Transport/HTTP.pm line 39.
      ...propagated at /home/marcr/perllibs/SOAP/Lite.pm line 527.

      Which is reasonable as 'warnings' is a pragma that is not included
      in the core perl before 5.6.0.

      But the SOAP-Lite README says:


      This library has been tested by the author with Perl versions 5.005
      and 5.6.0 on different platforms: Windows 98/2K, Solaris 2.6, Linux
      Should run everywhere where Perl 5.004 or later runs."

      How do I solve this problem. I need to be able to use SOAP::Lite on
      perl 5.005 (Solaris 8).
    Your message has been successfully submitted and would be delivered to recipients shortly.