Loading ...
Sorry, an error occurred while loading the content.
 

Quick question regarding User Agent setting

Expand Messages
  • Mark Wilkinson
    Hi all, Quick question - should the code fragment below set the User Agent HTTP header to be myApp when called by SOAP::Lite? @soapargs = ( $url, proxy = [
    Message 1 of 8 , Jan 25, 2007
      Hi all,

      Quick question - should the code fragment below set the User Agent HTTP
      header to be "myApp" when called by SOAP::Lite?

      @soapargs = ( $url, proxy => [ 'http' => $proxy ], user_agent => "myApp" );
      SOAP::Lite->proxy(@soapargs)->uri($uri)->on_fault(...);

      It isn't working for me, but it may be a bug elsewhere in my code.

      Any advice appreciated.

      Thanks!

      Mark
    • Mark Wilkinson
      Hi all, Is anyone in the SOAP::Lite community dealing with the non-working version that has been in CPAN for the past few months?
      Message 2 of 8 , Feb 5, 2007
        Hi all,

        Is anyone in the SOAP::Lite community dealing with the non-working version
        that has been in CPAN for the past few months?

        http://beta.nntp.perl.org/group/perl.cpan.testers/2006/08/msg343399.html

        I'm getting the exact same error message with failed tests, and I need to
        upgrade my production server... is it safe to ignore these failed tests,
        or are they serious?

        Please advise,

        Mark
      Your message has been successfully submitted and would be delivered to recipients shortly.