Loading ...
Sorry, an error occurred while loading the content.

500 transport errors

Expand Messages
  • damnfrenchy@mindspring.com
    I use Apache::Registry, and when my remote function die on the server (to indicate an error), Apache seem to generate an automated 500 Internal Server Error
    Message 1 of 3 , Feb 23, 2001
    • 0 Attachment
      I use Apache::Registry, and when my remote function die on the server
      (to indicate an error), Apache seem to generate an automated "500
      Internal Server Error" message after the XML SOAP message (see below).

      Of course, this screws up the XML parser and I have to print the
      whole request to see the actual "die" message.

      If I use cgi-script instead of perl-script/Apache::Registry, it works
      fine, SOAP::Lite parses the reply nicely and the fault handlers
      prints the trouble message nicely.

      Is there anything I could set up to prevent mod_perl from tagging
      this inconvenient message?

      Thanks

      -Mathieu

      <?xml version="1.0" encoding="UTF-8"?>
      <SOAP-ENV:Envelope xmlns:xsi="http://www.w3.org/1999/XMLSchema-
      instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
      xmlns:xsd="http://www.w3.org/1999/XMLSchema" SOAP-
      ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
      xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
      <SOAP-ENV:Body>
      <SOAP-ENV:Fault xmlns="http://schemas.xmlsoap.org/soap/envelope/">
      <faultcode xsi:type="xsd:string">SOAP-ENV:Server</faultcode>
      <faultstring xsi:type="xsd:string">Application
      error</faultstring>
      <detail xsi:type="xsd:string">Application failed: test/TODO
      </detail>
      <faultactor xsi:null="1"/>
      </SOAP-ENV:Fault>
      </SOAP-ENV:Body>
      </SOAP-ENV:Envelope>
      <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
      <HTML><HEAD>
      <TITLE>500 Internal Server Error</TITLE>
      </HEAD><BODY>
      <H1>Internal Server Error</H1>
      The server encountered an internal error or
      misconfiguration and was unable to complete
      your request.<P>
      Please contact the server administrator,
      root@localhost and inform them of the time the error occurred,
      and anything you might have done that may have
      caused the error.<P>
      More information about this error may be available
      in the server error log.<P>
      <HR>
      <ADDRESS>Apache/1.3.17 Server at xxx.xxx.xxx.xxx Port 80</ADDRESS>
      </BODY></HTML>
    • Paul Kulchenko
      Hi, Mathieu! Try to set PerlSendHeader On My Apache::Registry configuration works fine: Alias /mod_perl/ /Apache/mod_perl/ SetHandler
      Message 2 of 3 , Feb 23, 2001
      • 0 Attachment
        Hi, Mathieu!

        Try to set
        PerlSendHeader On

        My Apache::Registry configuration works fine:

        Alias /mod_perl/ "/Apache/mod_perl/"
        <Location /mod_perl>
        SetHandler perl-script
        PerlHandler Apache::Registry
        PerlSendHeader On
        Options +ExecCGI
        </Location>

        What is yours? As soon as you have mod_perl you may also try mod_soap
        (added in v0.47).

        Best wishes, Paul.

        --- damnfrenchy@... wrote:
        > I use Apache::Registry, and when my remote function die on the
        > server
        > (to indicate an error), Apache seem to generate an automated "500
        > Internal Server Error" message after the XML SOAP message (see
        > below).
        >
        > Of course, this screws up the XML parser and I have to print the
        > whole request to see the actual "die" message.
        >
        > If I use cgi-script instead of perl-script/Apache::Registry, it
        > works
        > fine, SOAP::Lite parses the reply nicely and the fault handlers
        > prints the trouble message nicely.
        >
        > Is there anything I could set up to prevent mod_perl from tagging
        > this inconvenient message?
        >
        > Thanks
        >
        > -Mathieu
        >
        > <?xml version="1.0" encoding="UTF-8"?>
        > <SOAP-ENV:Envelope xmlns:xsi="http://www.w3.org/1999/XMLSchema-
        > instance"
        > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
        > xmlns:xsd="http://www.w3.org/1999/XMLSchema" SOAP-
        > ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
        > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
        > <SOAP-ENV:Body>
        > <SOAP-ENV:Fault
        > xmlns="http://schemas.xmlsoap.org/soap/envelope/">
        > <faultcode xsi:type="xsd:string">SOAP-ENV:Server</faultcode>
        > <faultstring xsi:type="xsd:string">Application
        > error</faultstring>
        > <detail xsi:type="xsd:string">Application failed: test/TODO
        > </detail>
        > <faultactor xsi:null="1"/>
        > </SOAP-ENV:Fault>
        > </SOAP-ENV:Body>
        > </SOAP-ENV:Envelope>
        > <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
        > <HTML><HEAD>
        > <TITLE>500 Internal Server Error</TITLE>
        > </HEAD><BODY>
        > <H1>Internal Server Error</H1>
        > The server encountered an internal error or
        > misconfiguration and was unable to complete
        > your request.<P>
        > Please contact the server administrator,
        > root@localhost and inform them of the time the error occurred,
        > and anything you might have done that may have
        > caused the error.<P>
        > More information about this error may be available
        > in the server error log.<P>
        > <HR>
        > <ADDRESS>Apache/1.3.17 Server at xxx.xxx.xxx.xxx Port 80</ADDRESS>
        > </BODY></HTML>
        >
        >
        > ------------------------ Yahoo! Groups Sponsor
        >
        > To unsubscribe from this group, send an email to:
        > soaplite-unsubscribe@yahoogroups.com
        >
        >
        >
        > Your use of Yahoo! Groups is subject to
        > http://docs.yahoo.com/info/terms/
        >
        >


        __________________________________________________
        Do You Yahoo!?
        Yahoo! Auctions - Buy the things you want at great prices! http://auctions.yahoo.com/
      • Mathieu Longtin
        It is on. If I turn it off I get a MIME parsing error. SetHandler perl-script SetEnv AB_HOME /home/harvester PerlHandler Apache::Registry
        Message 3 of 3 , Feb 23, 2001
        • 0 Attachment
          It is on. If I turn it off I get a MIME parsing error.
           
          <FilesMatch "\.cgi$">
              SetHandler perl-script
              SetEnv AB_HOME /home/harvester
              PerlHandler Apache::Registry
              PerlSendHeader On
              Options +ExecCGI      
          </FilesMatch>             
           
          I can't currently guarantee that the server will have mod_perl on it, so I'd rather not use mod_perl specific stuff...
          -----Original Message-----
          From: Paul Kulchenko [mailto:paulclinger@...]
          Sent: Friday, February 23, 2001 10:17
          To: soaplite@yahoogroups.com
          Subject: Re: [soaplite] 500 transport errors

          Hi, Mathieu!

          Try to set
              PerlSendHeader On

          My Apache::Registry configuration works fine:

            Alias /mod_perl/ "/Apache/mod_perl/"
            <Location /mod_perl>
              SetHandler perl-script
              PerlHandler Apache::Registry
              PerlSendHeader On
              Options +ExecCGI
            </Location>

          What is yours? As soon as you have mod_perl you may also try mod_soap
          (added in v0.47).

          Best wishes, Paul.

          --- damnfrenchy@... wrote:
          > I use Apache::Registry, and when my remote function die on the
          > server
          > (to indicate an error), Apache seem to generate an automated "500
          > Internal Server Error" message after the XML SOAP message (see
          > below).
          >
          > Of course, this screws up the XML parser and I have to print the
          > whole request to see the actual "die" message.
          >
          > If I use cgi-script instead of perl-script/Apache::Registry, it
          > works
          > fine, SOAP::Lite parses the reply nicely and the fault handlers
          > prints the trouble message nicely.
          >
          > Is there anything I could set up to prevent mod_perl from tagging
          > this inconvenient message?
          >
          > Thanks
          >
          > -Mathieu
          >
          > <?xml version="1.0" encoding="UTF-8"?>
          >   <SOAP-ENV:Envelope xmlns:xsi="http://www.w3.org/1999/XMLSchema-
          > instance"
          > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
          > xmlns:xsd="http://www.w3.org/1999/XMLSchema" SOAP-
          > ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
          > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
          >   <SOAP-ENV:Body>
          >     <SOAP-ENV:Fault
          > xmlns="http://schemas.xmlsoap.org/soap/envelope/">
          >       <faultcode xsi:type="xsd:string">SOAP-ENV:Server</faultcode>
          >       <faultstring xsi:type="xsd:string">Application
          > error</faultstring>
          >       <detail xsi:type="xsd:string">Application failed: test/TODO
          >       </detail>
          >       <faultactor xsi:null="1"/>
          >     </SOAP-ENV:Fault>
          >   </SOAP-ENV:Body>
          > </SOAP-ENV:Envelope>
          > <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
          > <HTML><HEAD>
          > <TITLE>500 Internal Server Error</TITLE>
          > </HEAD><BODY>
          > <H1>Internal Server Error</H1>
          > The server encountered an internal error or
          > misconfiguration and was unable to complete
          > your request.<P>
          > Please contact the server administrator,
          >  root@localhost and inform them of the time the error occurred,
          > and anything you might have done that may have
          > caused the error.<P>
          > More information about this error may be available
          > in the server error log.<P>
          > <HR>
          > <ADDRESS>Apache/1.3.17 Server at xxx.xxx.xxx.xxx Port 80</ADDRESS>
          > </BODY></HTML>
          >
          >
          > ------------------------ Yahoo! Groups Sponsor
          >
          > To unsubscribe from this group, send an email to:
          > soaplite-unsubscribe@yahoogroups.com
          >

          >
          > Your use of Yahoo! Groups is subject to
          > http://docs.yahoo.com/info/terms/
          >
          >


          __________________________________________________
          Do You Yahoo!?
          Yahoo! Auctions - Buy the things you want at great prices! http://auctions.yahoo.com/


          To unsubscribe from this group, send an email to:
          soaplite-unsubscribe@yahoogroups.com



          Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
        Your message has been successfully submitted and would be delivered to recipients shortly.