Loading ...
Sorry, an error occurred while loading the content.

Problem on soap response

Expand Messages
  • Gunter Sammet
    Hello all: Having some trouble with Soap lite talking to a .net service. Don t know enough about Soap to pinpoint the issue and didn t find anything on the net
    Message 1 of 1 , Sep 6, 2006
    • 0 Attachment
      Hello all:
      Having some trouble with Soap lite talking to a .net service. Don't know enough about Soap to pinpoint the issue and didn't find anything on the net with the keywords I used.
      I submit a reservation via Soap. Everything arrives just fine at the other end. However, I don't get valid responses all the time. Here are the 2 responses I receive:

      -->This one is the one I would like to get all the time :)

      SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 200 OK
      Cache-Control: private, max-age=0
      Connection: close
      Date: Wed, 06 Sep 2006 17:56:53 GMT
      Server: Microsoft-IIS/5.1
      Content-Length: 786
      Content-Type: text/xml; charset=utf-8
      Client-Date: Wed, 06 Sep 2006 17:56:49 GMT
      Client-Peer: 192.168.0.21:80
      Client-Response-Num: 1
      X-AspNet-Version: 1.1.4322
      X-Powered-By: ASP.NET

      <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap=" http://schemas.xmlsoap.org/soap/envelope/" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:tns="urn:RoomMaster" xmlns:types="urn:RoomMaster" xmlns:xsi=" http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body soap:encodingStyle=" http://schemas.xmlsoap.org/soap/encoding/"><types:CreateReserveResponse><CreateReserveResult href="#id1" /></types:CreateReserveResponse><types:ReserveFeedBack id="id1" xsi:type="types:ReserveFeedBack"><ConfirmationNumber xsi:type="xsd:string">0019505</ConfirmationNumber><ReferenceNumber xsi:type="xsd:string">IRS007512701240     </ReferenceNumber><Message xsi:type="xsd:string" /></types:ReserveFeedBack></soap:Body></soap:Envelope>


      -->And most of the time I get this one :(

      SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 500 (Internal Server Error) Internal Server Error.
      Cache-Control: private
      Connection: close
      Date: Wed, 06 Sep 2006 17:58:43 GMT
      Server: Microsoft-IIS/5.1
      Content-Length: 1305
      Content-Type: text/xml; charset=utf-8
      Client-Date: Wed, 06 Sep 2006 17:58:40 GMT
      Client-Peer: 192.168.0.21:80
      Client-Response-Num: 1
      X-AspNet-Version: 1.1.4322
      X-Powered-By: ASP.NET

      <?xml version="1.0" encoding="utf-8"?>
      <soap:Envelope xmlns:soap=" http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd=" http://www.w3.org/2001/XMLSchema">
        <soap:Body>
          <soap:Fault>
            <faultcode>soap:Server</faultcode>
            <faultstring>System.Web.Services.Protocols.SoapException : Server was unable to process request. ---&gt; System.Runtime.InteropServices.COMException (0x80070006): The handle is invalid.
         at System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32 errorCode, IntPtr errorInfo)
         at System.Runtime.InteropServices.Marshal.FreeHGlobal(IntPtr hglobal)
         at Aumenta.RoomMaster.API.RoomMasterAPI.CreateReserve(DateTime CheckInDate, DateTime CheckOutdate, Byte NumberOfAdults, Byte NumberOfChildren, String RoomType, String SessionNumber, Byte EntryNumber, Guest GuestInfo, String Notes, String ReferenceNumber)
         at Aumenta.RoomMaster.Service.RoomMaster.CreateReserve(DateTime CheckInDate, DateTime CheckOutdate, Int32 NumberOfAdults, Int32 NumberOfChildren, String RoomType, String SessionNumber, Int32 EntryNumber, Guest GuestInfo, String Notes, String ReferenceNumber)
         --- End of inner exception stack trace ---</faultstring>
            <detail />
          </soap:Fault>
        </soap:Body>


      Not 100% sure if this is an issue with the configuration, the .net service or my perl code. Seems like when I restart the machine IIS runs on or if I restart IIS I get a successful response and later I get the error response.
      Any help or pointers would be greatly appreciated!
      Thanks,

      Gunter

    Your message has been successfully submitted and would be delivered to recipients shortly.