Loading ...
Sorry, an error occurred while loading the content.

* Help! How to set the namespace prefix for the request? *

Expand Messages
  • retoh123
    Hi, I have to send attributes as ... and *not* ... The argument «xsi:type...» is beeing added by SOAP::Lite
    Message 1 of 2 , Jun 18, 2006
    • 0 Attachment

      Hi,

      I have to send attributes as

      <urn:Foo> ... </urn:Foo>

      and *not*

      <Foo xsi:type="..."> ... </Foo>

      The argument «xsi:type...» is beeing added by SOAP::Lite automatically  :-|
      I have found a related hint in the man page about namespaces so far
      but could not come to a solution yet.

      You may please open this painful story on
      http://www.infocopter.com/perl/soap/namespaces.html
      where I will publish the solution with deeply gratefulness
      as far as I know it.

      Thank you & BR,
      Reto

    • Eric Bridger
      SOAP::Data- name( urn:Foo = $theValue)- type( );
      Message 2 of 2 , Jun 21, 2006
      • 0 Attachment
        SOAP::Data->name('urn:Foo' => $theValue)->type('');


        On Sun, 2006-06-18 at 14:43, retoh123 wrote:
        >
        > Hi,
        >
        > I have to send attributes as
        >
        > <urn:Foo> ... </urn:Foo>
        >
        > and *not*
        >
        > <Foo xsi:type="..."> ... </Foo>
        >
        > The argument «xsi:type...» is beeing added by SOAP::Lite
        > automatically :-|
        > I have found a related hint in the man page about namespaces so far
        > but could not come to a solution yet.
        >
        > You may please open this painful story on
        > http://www.infocopter.com/perl/soap/namespaces.html
        > <http://www.infocopter.com/perl/soap/namespaces.html>
        > where I will publish the solution with deeply gratefulness
        > as far as I know it.
        >
        > Thank you & BR,
        > Reto
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.