Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] Problem Accessing Java Web Service

Expand Messages
  • Peter Sinnott
    ... When you try to make SOAP::Lite work do you get any error messages? If you turn on logs do you see anything useful / unexpected? eg : use SOAP::Lite +trace
    Message 1 of 2 , May 23 6:52 AM
    • 0 Attachment
      On Tue, May 23, 2006 at 08:38:34AM -0500, Troy Bull wrote:
      > Hello
      >
      > I am new to web services and I am trying to access a web service that I
      > wrote. If I use LWP and post raw xml it works (returns the expected
      > results). The problem is I can't make SOAP::Lite work at all I have
      > tried so many combinations of things I am truly at a loss.
      >

      When you try to make SOAP::Lite work do you get any error messages?

      If you turn on logs do you see anything useful / unexpected?

      eg :

      use SOAP::Lite +trace => [qw(transport dispatch debug result parameters
      headers objects method fault freeform trace debug )];


      Peter

      > I have the following choices for SOAP Message Format : Document/Wrapped,
      > Document/Literal, RPC/Literal, RPC/Encoded. Which of these do i want to
      > use (I want which ever is simpler). I also have a choice of SOAP 1.1
      > Binding and/or SOAP 1.2 Binding.
      >
      > I am usually pretty good at figuring stuff out but this one has me
      > stumped I would much rather use SOAP to access my web services than raw
      > LWP stuff.. My web server (Oracle OAS 10.1.3) has a built in test your
      > web services web page that shows the XML before it submits it to the
      > services. I currently have it setup for RPC/Literal and here is the XML
      > that my web service wants/expects.
      >
      >
      > <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
      > xmlns:ns="http://cws/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
      > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      > xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">
      > <soap:Body
      > soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
      > <ns:encode>
      > <param0 xsi:type="xsd:string">bull</param0>
      > </ns:encode>
      > </soap:Body>
      > </soap:Envelope>
      >
      > This is the exact XML I post using LWP and it works from perl when done
      > that way.
      >
      > If anyone could point me to an example or give me some tips on how to do
      > this I would be very thankful.
      >
      > Thanks in advance
      > Troy
      >
      >
      >
      >
      >
      >
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
      >

      --
      It is our job to continually facilitate error-free data in order to competently
      disseminate low-risk high-yield solutions because that is what the customer
      expects
    Your message has been successfully submitted and would be delivered to recipients shortly.