Loading ...
Sorry, an error occurred while loading the content.

Problem with mod_perl server, server closes connection

Expand Messages
  • Jonas B. Nielsen
    Hello, I am having a hard time implementing a SOAP webservice on Linux using: - Apache - mod_perl 1 - Perl 5.6.1 - and SOAP::Lite 0.66 To just fool around and
    Message 1 of 2 , Jan 26, 2006
    • 0 Attachment

      Hello,

      I am having a hard time implementing a SOAP webservice on Linux using:

      - Apache
      - mod_perl 1
      - Perl 5.6.1
      - and SOAP::Lite 0.66

      To just fool around and to get a proof of concept I implemented a webservice on my Mac running perl 5.8.6 (and the same version of SOAP).

      This was working after about 10 minutes, so I copied the code to the Linux environment and tried again, but it does not seem as if the module to which I am dispatching is ever reached (or initialized) by the server.

      I am not sure where I should look any more, but could somebody guide me to the place in the code where the action is defined or the dispatch_to target is initialized, that would be appreciated.

      If you want to help me out but need more data, do not hesitate to ask.

      Thanks,

      jonasbn
    • Eric Bridger
      Most likely this has to do with your Perl @INC array under Apache. Check your Apache httd.conf for a PerlRequire /path/to/modperl-startup.pl then make sure
      Message 2 of 2 , Jan 26, 2006
      • 0 Attachment
        Most likely this has to do with your Perl @INC array under Apache.
        Check your Apache httd.conf for a PerlRequire
        "/path/to/modperl-startup.pl" then make sure your module is pushed onto
        the @INC.
        There may be other ways to do this

        On Thu, 2006-01-26 at 07:53, Jonas B. Nielsen wrote:
        > Hello,
        >
        > I am having a hard time implementing a SOAP webservice on Linux using:
        >
        > - Apache
        > - mod_perl 1
        > - Perl 5.6.1
        > - and SOAP::Lite 0.66
        >
        > To just fool around and to get a proof of concept I implemented a
        > webservice on my Mac running perl 5.8.6 (and the same version of SOAP).
        >
        > This was working after about 10 minutes, so I copied the code to the Linux
        > environment and tried again, but it does not seem as if the module to
        > which I am dispatching is ever reached (or initialized) by the server.
        >
        > I am not sure where I should look any more, but could somebody guide me to
        > the place in the code where the action is defined or the dispatch_to
        > target is initialized, that would be appreciated.
        >
        > If you want to help me out but need more data, do not hesitate to ask.
        >
        > Thanks,
        >
        > jonasbn
      Your message has been successfully submitted and would be delivered to recipients shortly.